Project

General

Profile

Missing packages for 16.04 LTS (Xenial Xerus)?

Added by Mr Johnzered about 2 months ago

According to https://tvheadend.org/projects/tvheadend/wiki/AptRepositories packages should be provided for 16.04 LTS (Xenial Xerus) but unfortunately I cannot find any
at https://cloudsmith.io/~tvheadend/

curl -1sLf 'https://dl.cloudsmith.io/public/tvheadend/tvheadend/setup.deb.sh' \ | sudo -E bash
Executing the  setup script for the 'tvheadend/tvheadend' repository ...

   OK: Checking for required executable 'curl' ...
   OK: Checking for required executable 'apt-get' ...
   OK: Detecting your OS distribution and release using system methods ...
 ^^^^: ... Detected/provided for your OS/distribution, version and architecture:
 >>>>:
 >>>>: ... distro=ubuntu  version=16.04  codename=xenial  arch=x86_64
 >>>>:
   OK: Checking for apt dependency 'apt-transport-https' ...
   OK: Checking for apt dependency 'ca-certificates' ...
   OK: Checking for apt dependency 'gnupg' ...
   OK: Checking for apt signed-by key support ...
   OK: Importing 'tvheadend/tvheadend' repository GPG key ...
   OK: Checking if upstream install config is OK ...
   OK: Installing 'tvheadend/tvheadend' repository via apt ...
   OK: Updating apt repository metadata cache ...
   OK: The repository has been installed successfully - You're ready to rock!
sudo apt install tvheadend
No apt package "tvheadend", but there is a snap with that name.

Is it just me not understanding how to install or is the package actually missing?


Replies (2)

RE: Missing packages for 16.04 LTS (Xenial Xerus)? - Added by Ukn Unknown about 2 months ago

I remember, test suite is showing failure for ubuntu 16.04 ... so the short answer is: you can't build tvh master on ubuntu 16.04 (if I remember right some error related to python).

RE: Missing packages for 16.04 LTS (Xenial Xerus)? - Added by Flole Systems about 2 months ago

You can build it, and in fact we are building it, we just can't upload it to our repo. So long story short: Update to a more recent OS or self-compile.

    (1-2/2)