Project

General

Profile

Add new field to webui

Added by Stefan Dietzel 6 months ago

Hi,

at the moment I am trying to extend a little bit the VAAPI transcoding in TVHeadend.
The techical stuff about trancoding is no problem but I am a little bit struggling how to add a new field to the UI mask of "Codec profiles".

It is nessecary to add a few fields to make the quality of encoding more accurate (buffer size for example).

Can someone give me a hint how to add input fields to an existing mask and which src files are relevant for this?

Thx in advance.


Replies (29)

RE: Add new field to webui - Added by Jay O 5 months ago

Kiril St. wrote:

Jay O wrote:

Hi Stefan,

I made a new build with the h264 destroy, but this memleak issue remains.

At the weekend I'll be able to test it on another Intel machine.

Kiril, I didn't try that patch you link in the other thread, that seems to be about NVENC, not Intel? Does it affect both?

Yes, affect both vaapi and nvenc!

OK, I will try this also at the weekend. Although I note from that thread that fix will not be merged into TVHeadend.

I also want to test to see if this memleak was present when using the original VAAPI code. If it exists there also, then I think this shouldn't be a blocker for Stefan's pull request.

If anyone can check to see if they see the same memory leak in VAAPI (about 100MB per stream play), it would be good also.

RE: Add new field to webui - Added by Jay O 5 months ago

First test result: this memleak also exists on the TVHeadend build 4.3.2010 on an Intel J1900.
Starting and stopping VAAPI streams causes system memory usage to increase each time, without being fully released after each stop.
Stefan, I think you can ignore my report of this issue here, as it's not caused by your changes.

Next test when I have time will be to try the fix linked to by Kiril St.

RE: Add new field to webui - Added by Stefan Dietzel 5 months ago

Hi,

when I am testing it with Debian testing distribution and the following ffmpeg versions (non static build) I have no memory problems:

ffmpeg version 4.4.1-3+b2 Copyright (c) 2000-2021 the FFmpeg developers built with gcc 11 (Debian 11.2.0-18)
libavutil 56. 70.100 / 56. 70.100
libavcodec 58.134.100 / 58.134.100
libavformat 58. 76.100 / 58. 76.100
libavdevice 58. 13.100 / 58. 13.100
libavfilter 7.110.100 / 7.110.100
libswscale 5. 9.100 / 5. 9.100
libswresample 3. 9.100 / 3. 9.100
libpostproc 55. 9.100 / 55. 9.100

Maybe it has to do something with ffmpeg version?
Have you tried it with build in ffmpeg (static build) or system ffmpeg (non-static)?

I am using the following build parameters: --enable-libav --disable-hdhomerun_client --disable-hdhomerun_static --disable-ffmpeg_static --disable-libffmpeg_static --enable-libx264 --enable-libx265 --enable-vaapi --enable-libfdkaac --disable-libx264_static --disable-libx265_static --disable-libfdkaac_static --disable-libvorbis_static --disable-libtheora_static --disable-libvpx_static --disable-libopus_static --enable-libav

I guess with static build memory problems are gone.

RE: Add new field to webui - Added by Stefan Dietzel 5 months ago

Changes are now merged into the project.

(26-29/29)