Project

General

Profile

Continuity errors and artifacts after moving to new server

Added by Tom Joe over 1 year ago

Hi,
I recently moved to a new server with my tvheadend installation.
The hardware is basically the same, just swapped disks with new ones. It is running Proxmox 7.0 (kernel 5.11) running on debian bullseye, prior it was Proxmox 6.4 (kernel 5.4) running on debian buster.
I just copied my tvheadend lxc container to the new machine. after 2 mins in the stream I get continuity errors and artifacts, shortly after the picture stops.
Firing up my old hdd everything works perfectly. So basically just the host changes. the container is always the same. I cannot figure out what's causing the problem.
Frontend: Digibit R1

Here some logs:

tvh.rtf (4.92 KB) tvh.rtf

Replies (7)

RE: Continuity errors and artifacts after moving to new server - Added by thermionic valve over 1 year ago

If a container runs correctly on platform A, and doesn't run correctly on platform B, then it would point to platform B being the issue.

I'm afraid I don't open .rtf files from unknown sources, if you attached as a text file it would be more conducive to being read.

RE: Continuity errors and artifacts after moving to new server - Added by Tom Joe over 1 year ago

Yes sure platform B is the issue. But what on platform B. The new kernel?
here the log in .txt

tvh.txt (4.52 KB) tvh.txt

RE: Continuity errors and artifacts after moving to new server - Added by thermionic valve over 1 year ago

thats the application saying that there are continuity issues, you might look at what is happening on the host networking, and possibly take a wireshark trace to see if packets are being dropped somewhere.

RE: Continuity errors and artifacts after moving to new server - Added by saen acro over 1 year ago

Add some network optimisations
The buffer size in the /etc/sysctl.conf

net.core.rmem_max = 16777216
net.core.wmem_max = 16777216
net.ipv4.udp_mem = 8388608 12582912 16777216
net.ipv4.tcp_rmem = 4096 87380 8388608
net.ipv4.tcp_wmem = 4096 65536 8388608
net.core.wmem_default = 16777216
net.core.rmem_default = 16777216
net.ipv4.tcp_tw_reuse = 1

sysctl -p

also can disable firewall

RE: Continuity errors and artifacts after moving to new server - Added by Tom Joe over 1 year ago

After upgrading the container to bullseye the issue still persists, but there are much less errors. It is nearly possible to watch tv (with some lag).
In the standard log I get only the continuity errors. Which subsystem do I need to log? and witch of these subsystems do I need to trace?

RE: Continuity errors and artifacts after moving to new server - Added by Martin Klayer 10 months ago

Same problem here. LXC Container in Promox 7 and Kernel version great equal 5.4.157 cannot host tvheadend.
Tons of continuity errors make the server practically useless.
People reported when performing an inplace upgrade from Promox 6 to 7, they are having (sometimes) no problems. Could be that they are still using an older kernel that 5.4.157.

I also tried with a VM under Promox. This is working better and test recordings were fine. I notices though that after about 20-30 minutes life tV, the video stalls for about 15 seconds.

It looks to me that it is definitely a promox 7 problem and not tvheadend fault.

RE: Continuity errors and artifacts after moving to new server - Added by An di 10 months ago

Hi,

I've seen that tvheadend continues to open new tasks. After some time there are so many tasks to fill up the ram and tvheadend reports continuity errors.

    (1-7/7)