Project

General

Profile

Continuity errors and artifacts after moving to new server

Added by Tom Joe 6 months ago

Hi,
I recently moved to a new server with my tvheadend installation.
The hardware is basically the same, just swapped disks with new ones. It is running Proxmox 7.0 (kernel 5.11) running on debian bullseye, prior it was Proxmox 6.4 (kernel 5.4) running on debian buster.
I just copied my tvheadend lxc container to the new machine. after 2 mins in the stream I get continuity errors and artifacts, shortly after the picture stops.
Firing up my old hdd everything works perfectly. So basically just the host changes. the container is always the same. I cannot figure out what's causing the problem.
Frontend: Digibit R1

Here some logs:

tvh.rtf (4.92 KB) tvh.rtf

Replies (5)

RE: Continuity errors and artifacts after moving to new server - Added by thermionic valve 5 months ago

If a container runs correctly on platform A, and doesn't run correctly on platform B, then it would point to platform B being the issue.

I'm afraid I don't open .rtf files from unknown sources, if you attached as a text file it would be more conducive to being read.

RE: Continuity errors and artifacts after moving to new server - Added by Tom Joe 5 months ago

Yes sure platform B is the issue. But what on platform B. The new kernel?
here the log in .txt

tvh.txt (4.52 KB) tvh.txt

RE: Continuity errors and artifacts after moving to new server - Added by thermionic valve 5 months ago

thats the application saying that there are continuity issues, you might look at what is happening on the host networking, and possibly take a wireshark trace to see if packets are being dropped somewhere.

RE: Continuity errors and artifacts after moving to new server - Added by saen acro 5 months ago

Add some network optimisations
The buffer size in the /etc/sysctl.conf

net.core.rmem_max = 16777216
net.core.wmem_max = 16777216
net.ipv4.udp_mem = 8388608 12582912 16777216
net.ipv4.tcp_rmem = 4096 87380 8388608
net.ipv4.tcp_wmem = 4096 65536 8388608
net.core.wmem_default = 16777216
net.core.rmem_default = 16777216
net.ipv4.tcp_tw_reuse = 1

sysctl -p

also can disable firewall

RE: Continuity errors and artifacts after moving to new server - Added by Tom Joe 3 months ago

After upgrading the container to bullseye the issue still persists, but there are much less errors. It is nearly possible to watch tv (with some lag).
In the standard log I get only the continuity errors. Which subsystem do I need to log? and witch of these subsystems do I need to trace?

    (1-5/5)