Project

General

Profile

Can't use tuners from a SH4 STB

Added by António Mota about 2 months ago

Hello to everyone of this fantastic community.

I use TVH for many years, since I discover it when I bought a Wetek Play (Openelec). It was love at first sight, stream to my devices much better in compare with Enigma2.

But unfortunately the wetek tuner (dual sat) burned. so I start search for solution and I found that I can share all tuners tuners from a E2 STB. I have some old boxes that I don't use and so I start my testing.

So I successful send to my TVH Server 3 tuners from 2x DM800HD and 1x DM800SE with minisatip and everything works like a phisical tuner on TVH Server. Fantastic.

But I need your help, I also have a old SH4 STB (Amiko Alien2) and I can't share the 2 sat tuners (the cable one I don't need it).
I tried diferent E2 images with the same results, with minisatip the tuners are detect on TVH Server, make all configs like others stb but the tuner fails.
I also tried different minisatip version, same result. So I try install on SH4 E2 the TVH, both tuners works (local and over ip to the TVH Server) but I only have 1 frame like every 10 seconds. When I start streaming the sh4 CPU jump to 100% all the time, so this CPU many don't have enough performance to use TVH.

Anyone can help me with minisatip to send 2 sat tuners to TVH Server? I guess is only some config, because my others old STB have 1 tuner, I only run minisatip without special config.

Thank you


Replies (3)

RE: Can't use tuners from a SH4 STB - Added by saen acro about 2 months ago

https://github.com/Audioniek/buildsystem
Need to revert to time before TVH was removed
or compile SATPI or Minisatip

RE: Can't use tuners from a SH4 STB - Added by António Mota about 2 months ago

saen acro wrote:

https://github.com/Audioniek/buildsystem
Need to revert to time before TVH was removed
or compile SATPI or Minisatip

Thank you for your time to help me.

I tried 2 Audioniek images with same results, cpu peaks to 100% when start streaming on TVH.
spark7162_Audioniek_enigma2_gst-epl3_flash_P217_CDK-rev1588
spark7162_Audioniek_enigma2_gst-epl3_flash_P217_CDK-rev1608

The minisatip I can install from OpenATV repositories and also I can find the binaries (https://minisatip.org/forum/viewtopic.php?t=371), tuners are detected on TVH Server but fail to use. I see severals commands on minisatip site, maybe this STB need use some special commands to work. In my others MIPS STB I don't need any special command, only run minisatip on each STB.

That SATPI I don't know, I will search. Thank you

RE: Can't use tuners from a SH4 STB - Added by saen acro about 2 months ago

To work minisatip in any case tuner need to be set as unconfigured in other software's.

Audioniek repo need to be before this commit
https://github.com/Audioniek/buildsystem/commit/bd84df1bdea7a5243cdc703e6e31fec45a10e275

$ git clone https://github.com/Audioniek/buildsystem
$ cd buildsystem
$ git reset --hard c0c496228973873fef54d76b1e0addfb69234e7d

And will have some extra menus
    (1-3/3)