Project

General

Profile

Transcoding does not work

Added by Rainer Dorsch over 1 year ago

Hi,

I setup a codec entry and a streamprofile entry for transcoding.

All I get is -vcodec copy (!)

ffmpeg -loglevel fatal -i https://swrbwhls-i.akamaihd.net/hls/live/667638/swrbwd/master.m3u8 -vcodec copy -acodec copy -metadata service_name=SWR Baden-Wuerttemberg HD -metadata service_provider=IPTV-DE -mpegts_service_type advanced_codec_digital_hdtv -f mpegts pipe:1

instead of

-vcodec libx264

Here is the streamprofile

[[http://bokomoko.de/~rd/tvh/streamprofile.png]]

On top of that there seems to be no audio :-/

and the corresponding codec

[[http://bokomoko.de/~rd/tvh/codec.png]]

The tvh log confirms that the profile imx6 is used

2021-03-14 21:47:37.162 [   INFO] htsp: Got connection from 192.168.7.32
2021-03-14 21:47:37.164 [   INFO] htsp: 192.168.7.32: Welcomed client software: Kodi Media Center (HTSPv34)
2021-03-14 21:47:37.165 [   INFO] htsp: 192.168.7.32 [ Kodi Media Center ]: Identified as user 'tvh'
2021-03-14 21:47:37.165 [   INFO] htsp: 192.168.7.32 [ tvh | Kodi Media Center ]: Privileges updated
2021-03-14 21:47:47.702 [   INFO] mpegts: kn-pipe-tv - BR Fernsehen Nord HD in kodinerds-iptv - tuning on IPTV #1
2021-03-14 21:47:47.712 [   INFO] spawn: Executing "/usr/bin/ffmpeg" 
2021-03-14 21:47:47.712 [   INFO] subscription: 0064: "192.168.7.32 [ tvh | Kodi Media Center ]" subscribing on channel "BR Fernsehen Nord HD", weight: 100, adapter: "IPTV #1", network: "kodinerds-iptv", mux: "kn-pipe-tv - BR Fernsehen Nord HD", provider: "IPTV-DE", service: "BR Fernsehen Nord HD", profile="imx6", hostname="192.168.7.32", username="tvh", client="Kodi Media Center" 
2021-03-14 21:47:56.519 [   INFO] transcode: 001C: 01:H264: ==> Using profile imx6
2021-03-14 21:47:56.529 [   INFO] transcode: 001C: 02:AAC: ==> Using profile webtv-aac
2021-03-14 21:47:56.544 [   INFO] libav: AVCodecContext: using SAR=1/1
2021-03-14 21:47:56.547 [   INFO] libav: AVCodecContext: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
2021-03-14 21:47:56.549 [   INFO] libav: AVCodecContext: profile High, level 3.2, 4:2:0, 8-bit

Why is there

-vcodec copy

and no transcoding takes place?

I use a recent version of tvheadend: Build: 4.3-1940~gfe0e5f1f9 (2021-03-06T18:28:43+0100)


Replies (2)

RE: Transcoding does not work - Added by Flole Systems over 1 year ago

Because that's how you set it up in the input settings.

Transcoding is not done by ffmpeg but by libav, you won't see a ffmpeg process for that.

RE: Transcoding does not work - Added by Rainer Dorsch over 1 year ago

Since my current setup does not really work, whereas transcoded by ffmpeg works, is there a way to switch entirely to ffmpeg?

Can you tell where are the input settings? Could not find such a field in neither the streamprofile nor the codec dialog.

Can anybody tell, why there is no audio? Neither at the kodi client nor at the mpv player started from the web frontend.

    (1-2/2)