Project

General

Profile

Error loading shared libraries after restart

Added by Alex & Cats 3 months ago

Hi All,

Just installed tvheadend on my Rpi 3 setup it and had a good play.

However after my first restart i get this error :

[email protected]:~ $ tvheadend
tvheadend: error while loading shared libraries: liburiparser.so.1: cannot open shared object file: No such file or directory

I have checked and these libaries are up to date
libattr1 is already the newest version (1:2.4.48-4).
dvb-apps is already the newest version (1.1.1+rev1500-1.2).

Im on buster and this is the first thing i have have ( or had ) running on the pi so sorry i am a newbie !

Thank Alex


Replies (4)

RE: Error loading shared libraries after restart - Added by saen acro 3 months ago

Shared libraries are part of operating system (OS)
Only way to overjump this problem is bundle package


https://tvheadend.org/boards/4/topics/24116

RE: Error loading shared libraries after restart - Added by Alex & Cats 3 months ago

Wow Ok thats pretty intense. I thought it wouldnt require any special setup as there was this guide on the offical rpi site / issue was something else as i had it running once.

https://magpi.raspberrypi.org/articles/raspberry-pi-tv-hat-kodi

I will have a proper read later and try and follow the post. Thanks Alex

RE: Error loading shared libraries after restart - Added by Dave Pickles 3 months ago

It worked once so it shouldn't be too hard to make it work again.

I don't have a Raspbian installation to hand but it may be that the uriparser library has somehow become corrupt. Try reinstalling the 'liburiparser1' package.

RE: Error loading shared libraries after restart - Added by Alex & Cats 3 months ago

Thanks that worked perfectly and i am back to playing :)

Cheers for all the replies :)

    (1-4/4)