Project

General

Profile

DaddyLive, PlutoTV, XUMO, M3U/XMLTV, SamsungTV, Plex, TVGuide interfaces (appliance)

Added by G Kazaroth over 2 years ago

Cabernet for (Cable Network) version 0.9.12 (4/13/2023)
TVGuide, DaddyLive, PlutoTV, XUMO, M3U/XMLTV, SamsungTV, Plex

Provides a configurable interface from providers to TVHeadend.

  • Direct streaming plugins for DaddyLive, PlutoTV, XUMO
  • EPG supplemented using TVGuide.com data
  • M3U Plugin provides channels for: SamsungTVPlus, Plex, PBS, Stirr, and others
  • From: https://i.mjh.nz/
  • Import your own M3U file

https://github.com/cabernetwork/cabernet/releases
Purpose is to get a service that will take the DaddyLive, PlutoTV or XUMO server stream, clean it and feed it into TVHeadend and other DVRs (Also tested on Emby, JellyFin and Plex). Also it runs on Linux, Windows as a service and Docker. Windows has a installer. Once installed, setup is easy with TVHeadend. Also includes a TVGuide.com plugin to obtain TVGuide data.

1) Setup the automatic IPTV network (recommend new URL is http://[host]:6077/PlutoTV/channels.m3u)

Make sure to set the "Maximum # input streams". PlutoTV is set to a max of 4 and tvheadend uses 2 per tuner during initial screening. Doing a force scan will create the mux and service values. Also, turn View level to Advanced and set the Re-fetch period (mins) to a very large number. TVheadend has a tenancy to cause issues when channels change (Changed Services will not be mapped to channels). The Maximum Timeout is used to wait for a reply during a Forced scan. Recommend keep this low, like 15-20 seconds. Some of the channels may fail, but it is faster than having a high setting and waiting for all channels to scan. Just individually rescan those that failed by setting each mux back to PEND from IDLE.
2) Next you can setup the grabber. I use a URL grabber written in Unix bash and is an extremely small file. It can be found in the github repo at
https://github.com/cabernetwork/cabernet/tree/master/lib/tvheadend/service/Unix called tv_grab_url
Place the grabber file in the same location as the other TVHeadend tv_grab* files, change the permissions to executable and restart TVHeadend. This should allow TVHeadend to pickup the new grabber. While in the grabber list, make sure and disable any OTA grabbers. Stations no longer send this information and will only cause TVHeadend to use a tuner for scanning. Displaying the log window by clicking the three ^ in the bottom right is helpful at this time.

Have the grabber run and populate the EPG data into the EPG Grabber Channels tab. The log should show a quantity of channels were detected.
Pop over to the EPG Grabber tab and disable the OTA grabber cron. Also, update/replace the Internal grabber cron schedule using something like below. The example will pull the TV guide at 6:04am and 5:52pm. Add more if you need. It is recommended to use static cron times.

4 6 * * *
52 17 * * *

3) In the Channel view, select Map all channels.

This will tie the services, EPG and channels together, automatically. After this, re-grab the EPG data. This will populate the EPG tab with shows. For TVH version 4.3, the Number column will auto-populate. For TVH 4.2, you will need to manually add channel numbers.
4) Display the TVGUIDE. This appliance has special features which maps the tvheadend genre, giving colors on tvguides. It also has enhanced guide descriptions and optional additional channel notations if you use many streams. Below is the Kodi tvguide using the pvr.hts plugin.

For Kodi, go to the settings for PVR and turn on the General setting "Use channel numbers from backend".


Replies (881)

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by G Kazaroth about 1 year ago

LINK IN THE ABOVE TEXT IS SPYWARE AND HAS SENT WIFI DATA TO FOREIGN COUNTRY! DO NOT CLICK ON IT.

locast is dead...

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by G Kazaroth about 1 year ago

0.9.7.4
This has a number of small updates, but has one major update to USTVGO. The channel list changed, significantly. You may need to remove the MUX and EPG list for USTVGO and then rescan/update once Cabernet updates. That is what I did. There are a few more changes to the list, but those are adds. TVH normally works fine when adding channels (modify is where the issue is).

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by R W about 1 year ago

G Kazaroth wrote:

If you are talking about USTVGO, I am working on a release now.

Not sure if this was meant for me but I was talking about USTVGO.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by Mark de Leon about 1 year ago

Ok I got this running under python (not docker) on the Raspberry Pi.

I was fortunate enough to encounter this on github , which took care of issues I was having with Rust and cryptography as I recall.

After doing as instructed on that page, damn, Python 3.8 is now good on my Pi.

So I have this script running and I will say that it is leaps and bounds ahead of the Windows.exe version that seemed so problematic.

I still have the following issues however.

Many channels still fail fail on TVHeadend by way of this script ALL of my channels from Frndly running the frndlytv for channels script. I get probably less than half of the xumo and half of the Pluto channels. I know that there is a method where supposedly one can extract a number from a single stream, but after trying it on TVH4.2 many times I have concluded it is for version 4.3, and does not apply to 4.2. Unfortunately I am stuck with 4.2 from what I can tell.

I was able to get it working once where I was not seeing commercials at all (ad block mode), that was on VLC. When I tried on on TVHeadend TVHeadend the Kodi client for TVHeadend never resumed playback it said something like "No stream" when it went to commercial and never came back. SO I need to figure out what other options work

I think also TVHeadend at least the version I run on the Pi3 (version 4.2) seems to stutter on some streams for no apparent reason, Nothing to do with ads. I did not think TVHeadend was really doing much more than a redirect in this case. Other PVR Solutions running on the same pi have not stuttered this way, and some of them were far more resource hungry..

Questions
Is it possible to use more and one m3u list?
It looks like there is HDHomerun integration but how do we make it work?
How do I make sure that I am seeing all the channels? Much Like TVHeadend channels are missing on some sources, probably due to failing at scanning???.

Feature request : Integration of https://frndlytv.com/ , especially if it can get past TVHeadend scan failures. You might be able to get some useful info from the script here https://github.com/matthuisman/frndlytv-for-channels https://www.matthuisman.nz/2021/11/frndly-tv-for-channels.html

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by R W about 1 year ago

G Kazaroth wrote:

0.9.7.4
This has a number of small updates, but has one major update to USTVGO. The channel list changed, significantly. You may need to remove the MUX and EPG list for USTVGO and then rescan/update once Cabernet updates. That is what I did. There are a few more changes to the list, but those are adds. TVH normally works fine when adding channels (modify is where the issue is).

I followed your steps and now I am on Version: 0.9.7.5 but now I am missing channels that I had access to before like VH1

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by G Kazaroth about 1 year ago

For clarity on the issue, you are running with the appropriate VPN and had access to premium channel VH1 and now you do not. Are you saying that you do not have VH1 listed in the Cabernet channel list, or is the channel not streaming through TVH. Just a note, VH1 has not changed its attributes, so there should not be any issues with Cabernet. You can also check the channels with VLC using
http://ip:6077/ustvgo/channels.m3u
VLC should work.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by R W about 1 year ago

I was able to get the missing channels back by going to Plex > Settings > Live TV & DVR and enabled the channels from there and fixed the channel number for each channel I want. My issue now is that whenever I try to play any of the channels Plex gives me the error Playback Error - Could not tune channel. Please check your tuner or antenna. VLC is also unable to play the channels when I add the m3u file to it.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by R W about 1 year ago

Here is the log error from Plex:

May 20, 2022 14:50:07.723 [0x7f6607bc1b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] HTTP requesting GET http://192.168.69.111:6177/discover.json
May 20, 2022 14:50:07.726 [0x7f661339cb38] DEBUG - [HttpClient] HTTP/1.0 (0.0s) 200 response from GET http://192.168.69.111:6177/discover.json
May 20, 2022 14:50:07.726 [0x7f6607bc1b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] HTTP requesting GET http://192.168.69.111:6177/lineup_status.json
May 20, 2022 14:50:07.729 [0x7f661339cb38] DEBUG - [HttpClient] HTTP/1.0 (0.0s) 200 response from GET http://192.168.69.111:6177/lineup_status.json
May 20, 2022 14:50:08.606 [0x7f6603a7eb38] ERROR - [Transcoder] [tcp @ 0x7f191c3ab480] Connection to tcp://10.6.139.170:5004 failed: Operation timed out
May 20, 2022 14:50:08.607 [0x7f6603955b38] ERROR - [Transcoder] http://10.6.139.170:5004/USTVGO/watch/9233000037: Operation timed out
May 20, 2022 14:50:08.608 [0x7f6614f12b38] DEBUG - Jobs: '/volume1/@appstore/PlexMediaServer/Plex Transcoder' exit code for process 25710 is 1 (failure)
May 20, 2022 14:50:08.608 [0x7f6603f65b38] DEBUG - Streaming Resource: Terminated session 0x7f6612eee2f8:73b18471-79c7-4508-bfae-fced8cd459bf with reason Recording failed. Please check your tuner or antenna.
May 20, 2022 14:50:08.608 [0x7f6603d46b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] TranscodeSession: session failed while waiting for duration
May 20, 2022 14:50:08.608 [0x7f6603d46b38] ERROR - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Failed to start session.
May 20, 2022 14:50:08.608 [0x7f6603d46b38] ERROR - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Recorder: Unable to create transcode session or session failed to start.
May 20, 2022 14:50:08.608 [0x7f6603d46b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Killing job.
May 20, 2022 14:50:08.608 [0x7f6603d46b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Signalling job ID 25710 with 9
May 20, 2022 14:50:08.608 [0x7f6603d46b38] ERROR - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Recorder: Error 16 (Recording failed. Please check your tuner or antenna.) starting the record, shutting things down.
May 20, 2022 14:50:08.608 [0x7f6603d46b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Grabber: Cleaning up rolling grab for channel 5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a.
May 20, 2022 14:50:08.608 [0x7f6603d46b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Recorder: No more consumers, stopping.
May 20, 2022 14:50:08.608 [0x7f6603d46b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Recorder: Asked to stop recording 'Live TV - Session w3wbrfqm18orx8v9i53iiwq2' on channel 5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a.
May 20, 2022 14:50:08.608 [0x7f6603d46b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Grabber: Freed a tuner on device://tv.plex.grabbers.hdhomerun/105AC761 (now 3 available)
May 20, 2022 14:50:08.608 [0x7f6603d46b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Grabber: Operation for 'Live TV - Session w3wbrfqm18orx8v9i53iiwq2' on channel 5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a completed with status error (Recording failed. Please check your tuner or antenna.)
May 20, 2022 14:50:08.609 [0x7f6603d46b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Activity: Ended activity cc3627e0-e905-4f94-966c-f4468d4b643d.
May 20, 2022 14:50:08.609 [0x7f6603d46b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Grabber: Cleaning up rolling grab for channel 5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a.
May 20, 2022 14:50:08.609 [0x7f6603d46b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Recorder: No more consumers, stopping.
May 20, 2022 14:50:08.609 [0x7f6603d46b38] ERROR - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Starting media grab failed.
May 20, 2022 14:50:08.609 [0x7f6603d46b38] ERROR - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Unknown metadata type: 
May 20, 2022 14:50:08.609 [0x7f6603d46b38] DEBUG - [Grabber/5fc77111e3b7d8002d386511-5fc70600598c41002da3dd0a-w3wbrfqm18orx8v9i53iiwq2] Asked for unknown type: -1
May 20, 2022 14:50:08.609 [0x7f6603fbdb38] ERROR - Subscription: Rolling media grab failed to start.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by Mark de Leon about 1 year ago

update on new discoveries with Windows .exe problems

Installed version 9.7.3 clean install.

Program does not start up it returns a (very quick) error that it is missing a file at c:\Program Files\cabernet\data\config.ini

So I copied the existing config.ini from C:\windows\System32\config\systemprofile\Documents\cabernet to c:\Program Files\cabernet\data

once launched I could see that the path above (c:\Program Files\cabernet\data\config.ini) was indeed set in GUi for the config.ini, but not for other data as it was going to the normal data path C:\windows\System32\config\systemprofile\Documents\cabernet

So With the teminal that launched cabernet open on Windows Machine and from a remote machine I tried to make a change in GUI. When the program was launched as a user it does not have permission to write to the c:\Program Files\cabernet\data\config.ini location.

So I then tried to change the config.ini location which appeared to be "read only" and not changable in the GUI. That actually makes half-sense as this is the same file that probably stores file locations such as the config.ini itself.

So that is part of what I see as happening with the Windows version.

I went back to the Win version after seeing that on Raspberry Pi and the DTS/PTS resync setting was causing 100% CPU Usage on all four cores. (This problem has since resolved itself)

Now I have also tried to run the version straight from python3.10 (externally installed FFMPEG with path set) with an entirely different set of errors showing on console every time I try to launch a stream.

After I get the Win exe uninstalled I will continue that on a different post.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by Mark de Leon about 1 year ago

Getting Cabernet running in Windows.

Since I had no luck with the Windows exe version of Cabenet, I wanted to post how to make it run from a python command in Windows 10. This may or may not work for Windows 11. This is actually much easier than getting it to run on existing linux installations, that may have issues upgrading python or other dependencies.

You need to install ffmpeg and python.

Here is a good how to for ffmpeg.
https://www.geeksforgeeks.org/how-to-install-ffmpeg-on-windows/

Here is how you can install python. Use the "custom" option. Make sure to check the boxes to install for all users, and to ad environment variables or add to path. .

Ddownload the cabernet code
https://github.com/cabernetwork/cabernet/archive/refs/heads/master.zip
and unzip it. Copy the main folder contents Caberbet[version] to c:\cabernet

you can launch cabernet by putting the following in a batch file, then adding that batch file to the startup folder for all users or a single user. .

C:\Path\to\Python c:\cabernet\tvh_main.py

Once running you need to set the ffmpeg path in "internal > path" for both ffmpeg.exe and ffprobe. If you followed the guide and installed to c:\ffmpeg then you would set the ffmpeg path tp C:\ffmpeg\bin\ffmpeg.exe and the ffprobe path to C:\ffmpeg\bin\ffprobe.exe

This is a much more effective solution for running under windows. No docker, no exe

You should test with firewall disabled but you will need to open at least ports 6077 and 5004 (possibly others?) on Windows firewall.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by G Kazaroth about 1 year ago

RW, it looks like you are using 2 different IP addresses in the plex log. One for the HDHR interface and the other for a stream. I suspect the 10.6.139.170 address has no access from plex, which is why you are getting a timeout. You can try to change the local_ip from 0.0.0.0 to 192.168.69.111 and see if that works. I do recall in some docker cases, that the IP needs to be bound to a specific IP. After changing the IP in Cabernet, take a look at the lineup.json and see if the IP address has changed.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by john tocher about 1 year ago

For what it's worth I get better playback using dvr function in Jellyfin. I keep setting it up in Plex and it just does not play as smoothly.

Using Antennas to proxy from TVHeadend.

Cabernet > TVHeadEnd > Antennas > Jellyfin

pretty much everything plays as smoothly as if I were using the TVHeadEnd PVR client with Kodi

Seems like USTVGO is smoother now. I had given up on using it before but with latest Cabernet seems to work better.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by R W about 1 year ago

After playing around with it I was able to get USTVGO to work again with the VPN but it still missing channels Like VH1 and some others. At least now the ones that it shows do play. I do want to make a note for people in the future that NordVPN seems to play videos from USTVGO but PIA VPN (Private Internet Access) does not work with USTVGO.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by Mark de Leon about 1 year ago

What are the "recommended Settings" for Xumo TV and PlutoTV instances that will work for TV Viewing without buffering/crashing on commercials?

If you have a response for this, please be complete in your answer. I have been trying to figure it out for too long now. It seems like none of the options make them work. Maybe I just have not hit the right combination?

Thanks

Mark

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by Mark de Leon about 1 year ago

G Kazaroth,

Have you ever seen the Kodi PVR addon for Pluto TV? I refer to the PVR plugin not any of the video addons.

I ask because I had never tried the Pluto TV PVR addon for Kodi until a few days ago.

What I notice is that commercials (mostly non-existent) do not disrupt the video stream at all. There is no flash frame of black several seconds before the commercial starts, none of that. That is to say at least on the channels I tested. What seems to go along with the hacked in commercials is an annoying flash frame of black several seconds before the commercial starts.

My point is that I am sure that tracking down the how and why that PVR addon gets these streams, should not be that difficult. It might be better to incorporate whatever is happening on those links, in Cabernet.

Just a suggestion,

Mark

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by Mark de Leon about 1 year ago

After multiple attempts to Get this running on other PVRs and V4.2 of TVH , none of which seemed to work well. I now have installed to TVH 4.3 built from source on Linux.

This however does not resolve the same issue I had with 4.2 SO I ask the question AGAIN. How do you keep the channel scans from Failing? I have Xumo as a source bu way of Cabernet but only between 20 to 30 channels are "ok" the others are "fail"

I am at my wits end with this and have spent far too long, asked all the questions, and sough the help.

I mean really if TVH does not work then how are people using it? Then again, where are the answers that are complete and succinct? Do people just put up with the shortcomings?

How can Cabernet enhance something that seems so broken? It certainly is not a solution for the failed scanning issue.

Thanks
Mark

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by Mark Clarkstone about 1 year ago

Mark de Leon wrote:

After multiple attempts to Get this running on other PVRs and V4.2 of TVH , none of which seemed to work well. I now have installed to TVH 4.3 built from source on Linux.

This however does not resolve the same issue I had with 4.2 SO I ask the question AGAIN. How do you keep the channel scans from Failing? I have Xumo as a source bu way of Cabernet but only between 20 to 30 channels are "ok" the others are "fail"

I am at my wits end with this and have spent far too long, asked all the questions, and sough the help.

I mean really if TVH does not work then how are people using it? Then again, where are the answers that are complete and succinct? Do people just put up with the shortcomings?

How can Cabernet enhance something that seems so broken? It certainly is not a solution for the failed scanning issue.

Thanks
Mark

When you create the network have you unticked "Scan after creation" (See screenshot)?

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by john tocher about 1 year ago

"Just individually rescan those that failed by setting each mux back to PEND from IDLE."

It literally says this at the top of each page of this thread.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by Mark de Leon about 1 year ago

Mark Clarksone, Are you saying I SHOULD or SHOULD NOT check that box?

John Tocher, I have tried that as well as documented in TVH and that does not work either, unless there is a step I am missing.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by Mark Clarkstone about 1 year ago

Mark de Leon wrote:

Mark Clarksone, Are you saying I SHOULD or SHOULD NOT check that box?

John Tocher, I have tried that as well as documented in TVH and that does not work either, unless there is a step I am missing.

You SHOULD NOT check that box

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by Mark de Leon about 1 year ago

Mark Clarkstone wrote:

Mark de Leon wrote:

Mark Clarksone, Are you saying I SHOULD or SHOULD NOT check that box?

John Tocher, I have tried that as well as documented in TVH and that does not work either, unless there is a step I am missing.

You SHOULD NOT check that box

Yes I have tried Not checking that box too and as I understand it must then initiate a "force Scan" which also fails on most channels.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by Adrian Smith about 1 year ago

Mark de Leon wrote:

Yes I have tried Not checking that box too and as I understand it must then initiate a "force Scan" which also fails on most channels.

Mark de Leon - what do you have "Maximum # input streams" set to on your IPTV network? This needs to be the maximum number of concurrent streams that your IPTV provider will let you access. Scans will fail if TVH tries to scan more channels at once than your IPTV provider will allow you to access.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by G Kazaroth 12 months ago

Reviewing the notes provided by Mark, it seems like there is no information on what the issue is, all I find is its broke. The issue he is facing is open to any number of issues. Based on what he has stated, the most likely issue is an environmental issue and not one associated with either app. It could be the OS, drivers, driver settings, WIFI, network settings, ISP, etc. Recently, I was over at a friends home and was checking out his environment. He was able to play Netflix, but was having issues with Linux (so some streaming was working). After doing some tests, we determined it was the cable provider's box (modem/router/wifi) was not providing WIFI correctly. He purchased a Netgear AX router and hooked it into the network. No more issues, the data rates increased by 10x and Netflix was running much better. They did not even know that they could have better connectivity.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by john tocher 12 months ago

Was going to say similar. The same guy who says: "Then again, where are the answers that are complete and succinct?" Is not bothering to provide anything close to a "complete and succinct" description of the problem.
I almost suggested googling "how to ask smart questions" for the FAQ that ESR maintains. Most of solving a problem (it seems to me) is in a description of the problem.

"Yes I have tried Not checking that box too and as I understand it must then initiate a "force Scan" which also fails on most channels."

It says in the instructions at the top of the page "Some of the channels may fail, but it is faster than having a high setting and waiting for all channels to scan. Just individually rescan those that failed by setting each mux back to PEND from IDLE."

So it's hard to guess about what the problem is but it sounds like PEBKAC.

It's not straightforward to set up anything with tvheadend. It took a while (for me anyway) to figure it out. Many would not have the patience required to figure it out.

RE: PlutoTV, USTVGO, XUMO, M3U/XMLTV, SamsungTV, Plex interfaces (appliance) - Added by Mark de Leon 12 months ago

I have set the number of maximum scans to 1, forced a scan and they still fail

Nobody here should try to make be feel ganged up on or attacked because I did not provide some info that you think I should have. I can not possibly provide ALL the information on ALL of the variations I have tried but this has now dragged on for a month. If you think that in that month I have not tried many different options , you are sadly mistaken.

Asking for any kind of documentation should not be offensive to anyone. Yes, I also believe that documenting a piece of software is perhaps equally as important as writing it. Yes you can put all kinds of variables in the Cabernet config file , but what are the available options? What are the options that should work with Pluto TV or with Xumo? They do not seem to be posted anywhere. I am told to enable PTS/DTS resync but I can also say that if I do that in order for that to work I can not use m3u8redirect as a redirect would bypass any resync done in Cabernet but yet no mention of this anywhere. So what are the WORKING "Resync Type" and "Stream Type" that go along with that? As I see that some of them error out and do not work at all.

Not one person has one time given me a solution that fixes Xumo or Pluto TV , not even with TVHeadend that this is supposed to work with and I have tried V 4.3 and V4.2. The scanning ALWAYS FAILS on most even when set to manually scan and only 1 channel. In fact the problem is NOT Cabernet it is in Fact a TVHeadend problem as it scans with fails with most every source I have tested. Rescanning HUNDREDS of channels Manually even still does not work and is an UNREASONABLE work-around anyway.

I think the scanning in TVHeadend is broken from what I can see. It has been broken for YEARS from what I see on the forums. I have tested most every free or open source PVR for Linux Mac and Windows in the last two months and TVHeadend by far is the WORST for adding channels. I believe it is simply buggy or broken and have posted so elsewhere on these forums. Even the work-arounds offered do not work in TVHeadend. These forums are FULL of posts many un-answered and many people working on the same problems week after week.

I have No problems adding channels with other packages Like NextPVR, TVMosaic, or others. This problem is limited to TVHeadend, so yea go ahead and blame it on some undefined variable , like modem, router, etc that you have no info on.

Do I care what YOU think when you do not ask me for more info rather criticize me for not being a mind reader? Should I have documented every possible setting with its result? I think not . I am simply asking "WHAT DOES WORK?" Not one single answer that is complete

Sorry I am moving on from this, TVHeadend obviously has a lot of issues and by the way it has the most convoluted interface of all the PVRs I have tested.

By the way look at the Pluto TV Kodi Addon and it does not break up on every commercial break. Yea thats right nobody cares

Sorry I am moving on from this. Post what you want about me TVH sucks , and cabernet is undocumented. BTW lovely docs on that horrible generic web site like "Fill in your text here"

Good riddance. I will not respond to more time wasters here.

(576-600/881)