Project

General

Profile

Many data errors after about 15 minutes, restarting stops the errors

Added by Sébastien Aubry 20 days ago

Hello,

I have some signal noise problems using an USB DVB-T tuner AVerMedia AVerTV Volar hd2 (seen as Afatech AF9033 in TVHeadend).
When I plug the antenna cable on my Sony TV, everything works fine. The signal information page gives a "Pre Viterbi" of about 2e-4.
On the computer (HTPC), I sometimes have a lot of Transport Errors and Continuity Errors. The signal is usually very good, but several times per hour, it gets totally scrambled. When this is the case, stopping the playback and starting it again solves the problem, which is weird.

For instance, at this moment, the program I am recording has >100000 errors.
The PER (Packet Error Ratio) is about 0.06, the SNR 31.5 dB and the signal strength -34 dB.
At some other moments, everything works fine.

I use LibreElec 9.2.3 with TvHeadend 4.3-1896 (nightly build).

I have tried :
  • to enable/disble the LNA (low noise amplifier) in TvHeadend
  • to enable/disble "Force old status" in TvHeadend
  • to enable/disable the latest drivers in LibreElec
  • to play with the 167KHz offsets
  • to replace my cables, amplifier, HTPC
  • to disable the hardware descrambling in the "CAs" tab

but it did not improve this problem.
Below are a few screenshots: in 3 of them everything works fine, but in the last one, the image is noisy:

A session

Force old status

Another session

Signal noise example

I also add a log.txt of a buggy session:

  • I start the streaming from the TVH web interface at 09:12:06
  • It works fine until 09:30:22 (18 minutes later) when I encounter the first continuity errors
  • I stop it after a lot of errors (~10000) at 09:53:39 and start it again immediately
  • then it works fine during at least 21 minutes, at 10:15, though before stopping it, there were errors every minute
  • I restart it at 10:45, after thousands of errors
  • Again, it works fine until 15 minutes

Do you see anything I could try in order to understand why I get this high noise ?

Should I buy another USB tuner?

Thanks

Note: this was also posted on the LibreElec forum.

[edit] Below are all the tests run in this topic:

Start time Hardware OS Kernel TV tuner DVB Module PVR Amplifier ? Amplifier level Cables Duration (s) Poor signal count (s) UCB (uncorrected blocks) First UCB at (s)
20/07/20 10:25 HTPC LibreElec 9.2.3 5.1.16 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.1.16 TVHeadend yes 50% pink+blue 1000 21 1743 375
20/07/20 10:49 HTPC LibreElec 9.2.3 5.1.16 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.1.16 TVHeadend yes 50% pink+blue 1000 0 0
20/07/20 11:10 HTPC LibreElec 9.2.3 5.1.16 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.1.16 TVHeadend yes 50% pink+blue 1200 149 181119 155
22/07/20 01:34 HTPC LibreElec 9.2.3 5.1.16 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.1.16 TVHeadend yes 50% pink+blue 1200 0 0
22/07/20 08:04 HTPC LibreElec 9.2.3 5.1.16 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.1.16 TVHeadend yes 50% pink+blue 1800 4 296 0
22/07/20 08:39 HTPC LibreElec 9.2.3 5.1.16 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.1.16 TVHeadend yes 50% pink+blue 2000 151 259485 1320
22/07/20 09:47 Laptop Linux Mint 19.3 5.4.0-42 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.4.0-42 TVHeadend yes 50% pink+blue 2000 0 0
22/07/20 10:35 Laptop Linux Mint 19.3 5.4.0-42 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.4.0-42 TVHeadend yes 50% pink+blue 2100 0 0
22/07/20 11:15 Laptop Linux Mint 19.3 5.4.0-42 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.4.0-42 TVHeadend yes 50% pink+blue 2400 0 0
22/07/20 11:58 Laptop Linux Mint 19.3 5.4.0-42 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.4.0-42 TVHeadend yes 50% pink+blue 2500 0 0
22/07/20 13:24 HTPC LibreElec 9.2.3 5.1.16 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.1.16 TVHeadend yes 50% pink+blue 2500 117 109520 1170
22/07/20 15:16 HTPC LibreElec 9.2.3 5.1.16 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.1.16 VDR yes 50% pink+blue 2500 133 165932 1230
23/07/20 00:07 Laptop Linux Mint 19.3 5.0.0-32 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 5.0.0-32 TVHeadend yes 50% pink+blue 21000 0 0
24/07/20 12:10 HTPC OpenELEC 8.0.4 4.9.30 AVerMedia AVerTV Volar hd2 dvb_usb_af9035 4.9.30 VDR yes 50% pink+blue 13800 0 0
24/07/20 16:47 HTPC LibreElec 9.2.3 5.1.16 Hauppauge WinTV-dualHD em28xx 5.1.16 TVHeadend yes 50% pink+ green 2500 0 0

Replies (35)

RE: Many data errors after about 15 minutes, restarting stops the errors - Added by Sébastien Aubry 12 days ago

Hello,
I have performed a new test: I ran Linux Mint with an older kernel (older than LibreELEC's one), and let the test run all the night. There was no error:

Start time Hardware OS Kernel DVB Module PVR Amplifier ? Amplifier level Cables Duration (s) Poor signal count (s) UCB (uncorrected blocks) First UCB at (s)
23/07/20 00:07 Laptop Linux Mint 19.3 5.0.0-32 5.0.0-32 TVHeadend yes 50% pink+blue 21000 0 0

About OpenELEC or AlexELEC, can I use them without installing them? I would like not to lose my LibreELEC installation. Else, can I just use a live USB distribution and install TVHeadend on it?

Thank you for your advice.

RE: Many data errors after about 15 minutes, restarting stops the errors - Added by saen acro 12 days ago

Sébastien Aubry wrote:

About OpenELEC or AlexELEC, can I use them without installing them? I would like not to lose my LibreELEC installation. Else, can I just use a live USB distribution and install TVHeadend on it?

Thank you for your advice.

install it on usb drive

RE: Many data errors after about 15 minutes, restarting stops the errors - Added by Brent McArthur 11 days ago

Glad to hear you’ve found a combo with no errors!

I did not try OpenELEC or AlexELEC, but until we find out what is driving the errors in LibreELEC my guess is high risk these distributions will have the same issue given they are in the same family. Give it a go, but you may need to fall back to a more generic Debian based distribution to avoid errors.

What is it in the LibreELEC install that you don’t want to lose? If it’s Kodi there are relatively easy ways to backup/restore your Kodi catalogue & setup between machines or distributions.

I’m still curious as to what is the root cause. I tried downgrading to multiple earlier versions of LibreELEC which in turn downgrades the kernel version as well. But I was unable to find an LibreELEC/Kernal combo that didn’t produce the errors.

RE: Many data errors after about 15 minutes, restarting stops the errors - Added by Sébastien Aubry 11 days ago

saen acro wrote:

install it on usb drive

Hello,
I have installed OpenELEC on an USB key. It is quite slow but it works.
I could not find TVHeadend backend in the repositories (it seems to have been removed), so I installed VDR.
But I cannot find the dvb-tools add-on and the dvb-fe-tool program, in order to monitor the signal quality. I looked for them but it does not seem obvious. Any idea?
Thanks

RE: Many data errors after about 15 minutes, restarting stops the errors - Added by Sébastien Aubry 11 days ago

Hello,
I managed to monitor the signal quality under OpenELEC using Kodi: I enabled "Show signal quality" and pressed "o" in order to display the PVR info.
The counter works, because on my first run, it used to show some uncorrected blocks (but I think this is usual when scanning for the channel frequencies).
After rebooting (and plugging the USB key on an USB3 port - much faster!), I was able to run live TV without any error, for more than one hour now:

Start time Hardware OS Kernel DVB Module PVR Amplifier ? Amplifier level Cables Duration (s) Poor signal count (s) UCB (uncorrected blocks) First UCB at (s)
24/07/20 12:10 HTPC OpenELEC 8.0.4 4.9.30 4.9.30 VDR yes 50% pink+blue 13800 0 0

I will leave it a few more hours, but this seems to work fine. [edit: it has been working for ~4 hours]

RE: Many data errors after about 15 minutes, restarting stops the errors - Added by Sébastien Aubry 10 days ago

I just bought a new (dual) USB tuner: Hauppauge WinTV-dualHD. As expected, it seems to work without any problem:

Start time Hardware OS Kernel TV tuner DVB Module PVR Amplifier ? Amplifier level Cables Duration (s) Poor signal count (s) UCB (uncorrected blocks) First UCB at (s)
24/07/20 16:47 HTPC LibreElec 9.2.3 5.1.16 Hauppauge WinTV-dualHD em28xx 5.1.16 TVHeadend yes 50% pink+ green 2500 0 0

RE: Many data errors after about 15 minutes, restarting stops the errors - Added by saen acro 10 days ago

Brent McArthur wrote:

Glad to hear you’ve found a combo with no errors!

I did not try OpenELEC or AlexELEC, but until we find out what is driving the errors in LibreELEC my guess is high risk these distributions will have the same issue given they are in the same family. Give it a go, but you may need to fall back to a more generic Debian based distribution to avoid errors.

Its not correct because all have some specific patches drivers etc
When I use AlexElec there is no Open or LibreElec
They come when author start to ask money for new versions

Sébastien Aubry what is in your scenario

pink+ green

cables???

RE: Many data errors after about 15 minutes, restarting stops the errors - Added by Sébastien Aubry 10 days ago

Yes, I put a different color on each cable in order to identify them. I have 2 cables: one from the wall to the amplifier and one from the amplifier to the USB tuner.

RE: Many data errors after about 15 minutes, restarting stops the errors - Added by Sébastien Aubry 7 days ago

Hello,
After a few days, I confirm this is probably not a signal problem: with the new Hauppauge dual tuner, I don't get any error. With the AverMedia, I always get some. For instance, tonight I am recording 7 programs, 2 of them with the AverMedia:

This is more likely a problem due to a combination of LibreElec/kernel version/driver/tuner/hardware.

RE: Many data errors after about 15 minutes, restarting stops the errors - Added by Brent McArthur 7 days ago

This is more likely a problem due to a combination of LibreElec/kernel version/driver/tuner/hardware.

Yes agree. Consistent with the the results I found as well. Feels unlikely a fix will come any time soon given volumes of users impacted trying to do TvHeadend/LibreELEC/AVerMedia Afatech AF9033 is low.

So to help anyone else that may experience this same issue are we saying the 2 possible workarounds are
  • Buy new TV Tuner that isn't from AVerMedia; or
  • Try another Linux distribution other than LibreELEC - (Linux Mint | Raspbian confirmed to work with AVerMedia tuner/TvHeadend)

?

(26-35/35)