Project

General

Profile

Comskip

Added by Lisa White 4 months ago

Does anyone have comskip up and running using ubuntu tvheadend? If so, how did you do it?

Thanks
Lisa


Replies (10)

RE: Comskip - Added by saen acro 4 months ago

As post processing.
https://github.com/erikkaashoek/Comskip
but this can help only in some player's
https://github.com/BrettSheleski/comchap.git

So to be more effective need something as:
https://github.com/kirbs-/video-transcode
comskip + comcut + transcode = record without commercials

RE: Comskip help setup - Added by Lisa White 11 days ago

Thanks for the information. I just got around to installing some of these programs. I installed comskip and downloaded comchap. I could not find info on installing comchap or transcode on ubuntu. What are my next steps? There is minimal information on google. How do I tie this software into tvheadend with postprocessing commands?

Thanks
Lisa

RE: Comskip - Added by Lisa White 10 days ago

Come on guys, I know a lot of you all got this going. Can someone give me some guidance?

Thanks

RE: Comskip - Added by Brian C 10 days ago

I recently followed this guide to setup Comskip and it's working well enough.
http://unixetc.co.uk/2020/03/16/how-to-install-comskip-on-a-raspberry-pi/

RE: Comskip - Added by Lisa White 9 days ago

Thanks Brian. I checked this website out and did the install of comskip. I tested it like the author explained but ran into a snag. I ran the command line usr/local/bin comskip First Time Flippers.mkv and received error 'file not found". The mkv was stored in my tvheadend root. (home/hts/recordings/First Time Flippers/First Time Flippers.mkv) I copied the mkv over to usr/local/bin and ran the command line again and comskip started and completed the conversion, creating First Time Flippers.txt. I copied both files back over to the hts root recordings folder and played the file with Kodi. The MKV played but the commercials were still present. Any tips on what I am doing wrong?

Thanks
Lisa

RE: Comskip - Added by Brian C 9 days ago

I have to ask...
Were you in the /home/hts/recordings/"First Time Flippers" folder when you ran the command?
Did you use double quotes (") around "First Time Flippers.mkv"?
Hopefully its something that simple.

If it does run successfully, it will make a file named "First Time Flippers.txt" in the same folder.

RE: Comskip - Added by Lisa White 9 days ago

I tried it with the quotes (/usr/local/bin/comskip /home/hts/recordings/First Time Flippers/"First Time Flippers-24.mkv")
and received this:

Detection methods available:
1 - Black Frame
2 - Logo
4 - Scene Change
8 - Resolution Change
16 - Closed Captions
32 - Aspect Ratio
64 - Silence
128 - CutScenes
255 - USE ALL AVAILABLE

Errors:
ComSkip: excess option Flippers
ComSkip: unexpected argument "First Time Flippers-24.mkv"

Thoughts?

RE: Comskip - Added by Brian C 9 days ago

You're getting closer. Try:
/usr/local/bin/comskip /home/hts/recordings/"First Time Flippers"/"First Time Flippers-24.mkv"

RE: Comskip - Added by Lisa White 9 days ago

Thanks for the help. I did that and it processed the file. (YA!!) I downloaded an ini file as instructed by the author and installed it. I opened the postrecord.sh in text editor and changed the file paths to the following:

LOG=/usr/local/bin/scripts/logs
COMSKIP=/usr/local/bin/comskip
INI=/usr/local/bin/comskip.ini
#ADMIN=.

I executed comskip again and the ini was not recognized during the transition. I checked my paths that I created for the log and none was created. Do I have to give the ini execute permission in linux for the ini to be recognized by comskip?

Thoughts?

Thanks
Brian

RE: Comskip - Added by Brian C 3 days ago

I had not played around with the INI since the author of that tutorial says he was happy with the default settings. I also have found similar comments elsewhere.
I did play around with it today. I wasn't sure where to put it so it would be used when executing from the command line, but I see the message says "No INI file found in current directory. Searching PATH..."
I put the INI file in the same folder as my recording and it worked. You get a message confirming it -- "Using comskip.ini for initiation values".
Now, having said that, I ran this with the command line script shown in the tutorial.
The postrecord.sh script is run after tvheadend records a program, so your edits to that file only matter when you run that script -- which is after recording a program if you follow the tutorial.

    (1-10/10)