Project

General

Profile

Freeview Sutton Issues

Added by Chris G 21 days ago

Hi. I am having problems with Freeview 746Mhz. Sometimes scan fails, sometimes it says OK (partial) and sometimes it says OK. Sometimes it wont tune a channel at all, sometimes its fine and sometimes I get audio only and Kodi treats it as a radio station.

Does anyone know what the correct settings would be?
The Freeview website doesn't help me because I don't understand the info it gives me and TVH has more boxes than I can see info on the website.

Any help is appreciated,
Chris


Replies (5)

RE: Freeview Sutton Issues - Added by Chris G 20 days ago

Thanks for the reply. Looks like my problems are elsewhere. Here is the output when it does a scan.

2019-05-04 14:17:06.645 mpegts: 746MHz in Freeview - tuning on Panasonic MN88472 #1 : DVB-T #0
2019-05-04 14:17:06.645 subscription: 2C5D: "epggrab" subscribing to mux "746MHz", weight: 4, adapter: "Panasonic MN88472 #1 : DVB-T #0", network: "Freeview", service: "Raw PID Subscription"
2019-05-04 14:17:08.269 tbl-base: pat: 746MHz in Freeview: invalid checksum (len 146, errors 1)
2019-05-04 14:17:10.379 tbl-base: nit: 746MHz in Freeview: invalid checksum (len 89, errors 1)
2019-05-04 14:17:18.767 tbl-base: pat: 746MHz in Freeview: invalid checksum (len 3, errors 9)
2019-05-04 14:17:31.645 mpegts: 746MHz in Freeview - scan complete (partial - 4/2 tables)

Looks bad. Its an xbox tuner. No idea if I have the correct firmware but if all the other muxes are working I would assume so?

I ran the following to get my sat tuner detected and it also made my xbox tuner appear.

cd /usr/src
git clone https://github.com/tbsdtv/media_build.git
git clone --depth=1 https://github.com/tbsdtv/linux_media.git -b latest ./media
cd media_build
uname -a
rm -rf /lib/modules/$(uname -r)/extra
rm -rf /lib/modules/$(uname -r)/kernel/drivers/media
rm -rf /lib/modules/$(uname -r)/kernel/drivers/staging/media
rm -Rf /lib/modules/4.15.0-29-generic/kernel/drivers/media
make dir DIR=../media
make remove
make clean
make dir DIR=../media
make allyesconfig
make -j4
make install
cd
reboot
dmesg | grep frontend
wget http://www.tbsdtv.com/download/document ... .0.tar.bz2
tar jxvf tbs-tuner-firmwares_v1.0.tar.bz2 -C /lib/firmware/

That was posted on the tbs forum.

Cheers,
Chris

RE: Freeview Sutton Issues - Added by Mark Clarkstone 19 days ago

I have a few xbox tuners not currently in use, I'll have to hook one up and see if I get the sane output, and report back.

If I don't reply in a few days bump this thread :)

RE: Freeview Sutton Issues - Added by Mark Clarkstone 18 days ago

I'm back, with some interesting results.. :D

Yes there certainly does seem to be an issue with the Panasonic tuner/driver and COM 7 HD on 746mhz! Mine tunes OK but errors like crazy..

2019-05-06 05:53:32.623 subscription: 000C: "HTTP" subscribing to mux "746MHz", weight: 10, adapter: "Panasonic MN88472 #3 : DVB-T #0", network: "DVB-T - Sutton Coldfield", service: "Raw PID Subscription", hostname="192.168.1.253", client="VLC/3.0.3 LibVLC/3.0.3" 
2019-05-06 05:53:34.161 tbl-base: pat: 746MHz in DVB-T - Sutton Coldfield: invalid checksum (len 1162, errors 1)
2019-05-06 05:53:37.339 tbl-base: nit: 746MHz in DVB-T - Sutton Coldfield: invalid checksum (len 89, errors 1)
2019-05-06 05:53:44.473 tbl-base: pat: 746MHz in DVB-T - Sutton Coldfield: invalid checksum (len 3, errors 6)
2019-05-06 05:53:50.307 tbl-base: nit: 746MHz in DVB-T - Sutton Coldfield: invalid checksum (len 89, errors 5)
2019-05-06 05:53:54.645 tbl-base: pat: 746MHz in DVB-T - Sutton Coldfield: invalid checksum (len 4, errors 9)
2019-05-06 05:54:07.182 tbl-eit: uk_freeview: 746MHz in DVB-T - Sutton Coldfield: invalid checksum (len 25, errors 1)
2019-05-06 05:54:08.694 tbl-base: pat: 746MHz in DVB-T - Sutton Coldfield: invalid checksum (len 3, errors 13)

but.. and here's the kicker.. after roughly 20-30 seconds of errors, they suddenly stop and VLC shows a picture!

I'm only guessing here but I think the tuner is getting confused, especially seeing as other transmitters near have COM7 on 746 too. SFN issues maybe? Who knows!

Solutions:
  • Horrible workaround, set a 247 hour recording so it's constantly tuned, saving the output to /dev/null
  • Wait wait wait.. and wait for a picture LOL

It's a weird one, sorry I couldn't be of much help :(

huh.png (669 KB) huh.png

RE: Freeview Sutton Issues - Added by Chris G 18 days ago

Thanks for looking into it for me. Seems the xbox tuners are no good for freeview then.
Is this the kind of thing that can be fixed with firmware? I still have no idea if I have the correct firmware. Like I said the device appeared after I built firmware for another device.

I thought 700mhz was being cleared?

Cheers,
Chris

    (1-5/5)