Project

General

Profile

Intermittent disappearing recordings

Added by Dan Schmidt 29 days ago

Issue:
Intermittently, I get recordings that appear to record fine, but do not show up in "Finished" or "Failed" recordings. Post recording script even runs without issue. I am perplexed as to why and apologize if this has been addressed elsewhere.

Background:
I am running HTS Tvheadend 4.2.8-21~g0c36205f7 on Ubuntu 18.04.2 LTS via the https://apt.tvheadend.org/stable repo. I use a HDHR-US HDHomeRun DUAL tuner.

Logs:
Unfortunately, I do not have debug, only syslog wherein everything appears to have worked fine. I would gather debug if it weren't intermittent.
https://pastebin.com/uLCxwAzT

Note, despite being missing from tvheadend, the files do exist:

[email protected]:~$ ls -l /home/hts/ | grep Carol
-rw-rw-rw- 1 hts video          79 Mar 19 22:30 Carol-Burnett-and-Friends.edl
-rw-rw-r-- 1 hts video   630073916 Mar 19 22:29 Carol-Burnett-and-Friends.ts

Thank you for your time, this one is driving me nuts.


Replies (7)

RE: Intermittent disappearing recordings - Added by Mark Clarkstone 29 days ago

Tvh uses inotify, if you make changes to the file you need update tvh via the API. See #4020

RE: Intermittent disappearing recordings - Added by Dan Schmidt 27 days ago

Thank you kindly for your reply. It would be interesting to see how other people do this, however, I am just a beginner - the post processing script I stole/modified only runs comskip and does not modify the ts.

RE: Intermittent disappearing recordings - Added by Mark Clarkstone 27 days ago

Dan Schmidt wrote:

Thank you kindly for your reply. It would be interesting to see how other people do this, however, I am just a beginner - the post processing script I stole/modified only runs comskip and does not modify the ts.

Are you storing these on a separate drive that you mount at boot or via fstab?

RE: Intermittent disappearing recordings - Added by Dan Schmidt 27 days ago

No, nothing fancy like that - one drive, one mount. And, most of the time, it works - that is the strange part.

RE: Intermittent disappearing recordings - Added by Em Smith 24 days ago

How soon after recording do the recordings disappear?

Perhaps you have accidentally changed the "retention period" that has info about the files for some recordings? Config->Recording->DVR Profile, but can also be overridden in DVR->Autorec entries on the expert settings if you edit an entry. If the Tvheadend logfile retention is low (for example a day) then after a day it will forget about the programme, but the recorded file will still exist on disk.

RE: Intermittent disappearing recordings - Added by Dan Schmidt 21 days ago

Thank you for your response! That is a good idea, but I have no retention period and it is missing immediately afterwards. Also, the original file is still there - it's just not listed in the tvheadend application anymore.

RE: Intermittent disappearing recordings - Added by Em Smith 21 days ago

I use 4.3 (dev) so it might be different in 4.2. If you mean you can't see any retention period line then you need to click "expert settings" first. For example, mine says "info retention: forever", "file retention: maintained space". But since you say the recording info is missing immediately, it does not sound like that can be the problem since the minimum setting is a day.

Other thing it could (very unlikely) be is "user permissions". Could it be that you have multiple users set up on Config->Users? But, since it is intermittent I don't think it could be this either.

I can't think of anything obvious without increasing debug level to see if it logs when/why it is deleting.

    (1-7/7)