Project

General

Profile

IPTV name-not-set

Added by Terry Kramer almost 4 years ago

TVHEADEND - HTS Tvheadend 4.2.8-4~g9f7ab681a~bionic
OS -Ubuntu 18.04.1 LTS
Kodi - 17.6
IPTV provider - Vaderstreams

I have created a "IPTV Network Automatic" network with a URL that contains my userid and password for my Vader account. Tvheadend successfully recognizes 1200+ muxes. After first initial scan of these 1200+ muxes, it end up with about 1000 Services.

I then selectively parse through these 1000 services and individually select my desired muxes, and map them. Typicall less than 100.

After mapping them, I end up with individual Channels, with properly resolved names. All works as planned. Kodi via the Tvheaded PVR addon picks up the 100 channels.

Then sometime in the next 24 hours or so, most of my 100 channels are corrupted or changed. The NAME field will get set to "name-not-set", they disappear from my Kodi channel listing. In "DVB Inputs - Services" tab, I notices that for my choosen 100 channels, the CHANNEL column is not blank.

I think that Tvheadend is automatically rescanning all Vader muxes during the night. After which they are not proper merged/reconciled with the previously mapped channel and I end up with "name-not-set". This does not happen for all 100 channels, strangly there are seem to be 5-8 that are un-affected by this cycle.

I have tried to configure Tvheaded from doing any additional mux scans after the initial scan, but have not stumbled on the correct parameters to achive this. Plus if I was successful with this approach, it seems that it would only be a work-around, and just mask the base problem.

Is there away to force Tvheadend to stop subsequent mux scans after the initial scan?

I have tried to reselect my choosen Services and remap them with the "Merge", but since the name fields are corrupt, this does not work.

Anyone have a proper solution.

Thanks in advance!


Replies (4)

RE: IPTV name-not-set - Added by Lisa White almost 4 years ago

Hi Terry,

I ran into this problem before and I believe that the provider updates the mux which causes the corruption. I know this is a lot of work, but I solved this problem by disabling the "alway use the name defined by the provider" within the channels tab. Edit the channel name to the original name and save it. This procedure worked for me. Its a lot of work, especially if you have a 1000 channels. The only other alternative is to delete and re-scan the muxes and disable the update.
Good luck,
Lisa

RE: IPTV name-not-set - Added by Fred Fred almost 4 years ago

These tabs: Configuration, Channel / EPG, Channels.
In right bottom corner where it normally say Per Page 50, change that to all.
On keyboard press CTRL+A to select all channels.
Hit Edit button, some channel manipulation comes up.
Under advanced settings to the left of "Automatically name from network" put a check in that checkbox, to the right of "Automatically name from network" uncheck that box.
Then hit Apply button
Then hit Cancel button.
Now you should be all done.

I think I rebooted TVH after that or it just toke some time, but now all is back for me anyway.

RE: IPTV name-not-set - Added by Terry Kramer almost 4 years ago

Great advice! I agree with Lisa, I think Vader is changing the muxes on the corrupted items. On a few channels, like ESPN, this problem does not present itself. Thanks.

RE: IPTV name-not-set - Added by Terry Kramer almost 4 years ago

Final update.
Lisa's post got me thinking.
In the Configuration-DVB Inputs-Networks setting for this IPTV provider, I had the URL setting pointing across the internet directly to the URL at Vader. It looked something like this "http://vaders.tv/vget?username=xxxxx&password=xxxx".

That worked, but it seems that Vaders was constantly changes something in the muxes, which prevented tvheadend from syncing them up with my services and channels.

So, instead of direct across the internet URL, I used my brownser to go to that url and downloaded it to my harddrive as a .m3u.

Then I changed tvheaded to use that file in the URL: field. It looks like this "file:///home/user1/Downloads/Vader.m3u".

I now am not constantly having to rebuild my services-channels. The .m3u is stable.

Not perfect, but a workaround.

    (1-4/4)