Project

General

Profile

Digital Devices Cine S2 V6 issue with newest stable 4.2 from Git

Added by William Shoveller almost 5 years ago

Hello,

I compiled Tvheadend 4.2.6-7 (which is the newest fom stable branch) from Git and installed the deb packages on an ubuntu 18.04 Server and everything worked without problems.
Then the first Setup via the Webinterface channel scanning went wrong. It took a few seconds and scan status was 100% with only 1 found muxes and no services.
I even tried Tvheadend 4.3 developer version but same issue.

So I purged the Tvheadend 4.2.6-7 and installed an older version 4.2.5-29 (from which I compiled earlier this year) and everything worked fine, channel scanning and so on...

Now I can say that version 4.2.5-29 is the last working version of Tvheadend with my Cine S2 V6. Here the message from grep:

[ 9.613005] ddbridge 0000:02:00.0: detected Digital Devices Cine S2 V6 DVB adapter
[ 9.614449] ddbridge 0000:02:00.0: Port 0: Link 0, Link Port 0 (TAB 1): DUAL DVB-S2
[ 9.617790] ddbridge 0000:02:00.0: Port 2: Link 0, Link Port 2 (TAB 3): DUAL DVB-S2
[ 9.618060] dvbdev: DVB: registering new adapter (DDBridge)
[ 9.618062] dvbdev: DVB: registering new adapter (DDBridge)
[ 9.618063] dvbdev: DVB: registering new adapter (DDBridge)
[ 9.618064] dvbdev: DVB: registering new adapter (DDBridge)
[ 9.848053] ddbridge 0000:02:00.0: DVB: registering adapter 0 frontend 0 (STV090x Multistandard)...
[ 9.892180] ddbridge 0000:02:00.0: DVB: registering adapter 1 frontend 0 (STV090x Multistandard)...
[ 10.076174] ddbridge 0000:02:00.0: DVB: registering adapter 2 frontend 0 (STV090x Multistandard)...
[ 10.120181] ddbridge 0000:02:00.0: DVB: registering adapter 3 frontend 0 (STV090x Multistandard)...
[ 15.437176] ddbridge 0000:02:00.0: DVB: adapter 3 frontend 0 frequency 0 out of range (950000..2150000)
[ 16.316500] ddbridge 0000:02:00.0: DVB: adapter 2 frontend 0 frequency 0 out of range (950000..2150000)
[ 16.360586] ddbridge 0000:02:00.0: DVB: adapter 1 frontend 0 frequency 0 out of range (950000..2150000)
[ 16.399963] ddbridge 0000:02:00.0: DVB: adapter 0 frontend 0 frequency 0 out of range (950000..2150000)

Can you please help me with this issue? Please tell me, if you need more information.


Replies (4)

RE: Digital Devices Cine S2 V6 issue with newest stable 4.2 from Git - Added by saen acro almost 5 years ago

Lot of Digital Devices is supported by kernel in 18.04 but not all.
Also be more specific What and How you scan.

RE: Digital Devices Cine S2 V6 issue with newest stable 4.2 from Git - Added by William Shoveller almost 5 years ago

Dear saen acro,

thank you for your reply.
If you read carefully you will figure out that this is no driver issue.

I set up an VDR Server running since the year 2012 when I bought the Cine S2 V6 Card.
In 2016 I switched to Tvheadend running on Ubuntu 16.04 (the kernel already included the Cine S2 V6 Driver).
Everything worked fine!

The issue came with Version 4.2.6(and later versions) of Tvheadend. I will now try and reproduce this scan failure and send some pics..

For your understanding: Version 4.2.5(and earlier versions) of Tvheadend is working fine and without any problems. It wouldn't work if the driver's not supported

Greetings

update: made some pics with ver 4.3.1252 but it's the same like with 5.2.6 the last pics with working 4.2.5

RE: Digital Devices Cine S2 V6 issue with newest stable 4.2 from Git - Added by Stefan Kozlowski over 4 years ago

Hello,

I'm using a Digital Devices Cine S2 Version 5.5 (or 5.4, don't exactly, but it's old like from 2007 or so) and have exactly the same problem.
Currently I'm running Win 10 and MediaPortal, but testing LibreElec with Kodi.

The problem is exactly the same, and with the current release of tvheadend, only Tuner #1 finds exactly only the same TV stations like in the screenshots of William Shoveller (Bibel TV, QVC etc.).
If I downgrade the tvheadend Addon to an older package, the problem disappears and it finds all TV stations and both Tuners work.

Installed OS:
LibreELEC (additional dvb drivers) v8.2.0 (Kodi Krypton v17.5)
http://cvh.libreelec.tv/

Platform:
x86, AMD A4 CPU, 4 GB RAM, 256 GB SDD, 1 TB HDD

Addon:
The lowest version that the LibreElec Repository of TVHeadend offers works - the highest doesn't.
I need to figure out the exact versions numbers.

Best regards,
TurboAsterix

RE: Digital Devices Cine S2 V6 issue with newest stable 4.2 from Git - Added by Levente Cseh over 4 years ago

Not sure if the issue is the same, but I have just installed a new instance of TVH running on Bionic with a Cine S2 v6 having an extension card, so 4 tuners in total.

If all tuners are active, TVH has a huge lag, zapping takes a lot of time, and there are intermittent stops on clients.
If the daughter card's tuners are disabled, all goes well, zapping returns to normal.

Drivers are not installed, it works with the default driivers from Bionic. I am updating TVH from the unstable repo, hoping that this bug will go away.... Is this a driver issue or TVH issue?

Has anyone else experienced this?

    (1-4/4)