Project

General

Profile

timeshift buffer size problems

Added by Markus Endres about 1 year ago

My Tvheadend 4.2.6-7~g561355130 on Debian stretch ignores my timeshift-buffer-settings (Limited to 10 GB). It is growing until no space is left.
Did i forget anything or a wrong setting?

       "enabled": true,
        "ondemand": false,
        "path": "",
        "max_period": 60,
        "unlimited_period": true,
        "max_size": 10000,
        "ram_size": 0,
        "unlimited_size": false,
        "ram_only": false,
        "ram_fit": false,
        "teletext": false
screen_tvh_settings.PNG (18 KB) screen_tvh_settings.PNG Settings tvheadend
screen_tvh_df.PNG (26.9 KB) screen_tvh_df.PNG Screenshot du

Replies (1)

RE: timeshift buffer size problems - Added by James Hutchinson 12 months ago

I believe I had the same problem after upgrading to tvheadend 4.2.6 and have now reverted back to v4.2.5.

I use RAM only for all my timeshift buffer, with a max size of 1024MB:

"enabled": true,
"ondemand": false,
"max_period": 60,
"unlimited_period": false,
"max_size": 1024,
"ram_size": 1024,
"unlimited_size": false,
"ram_only": true,
"ram_fit": true,
"teletext": false

What I found was that the picture was jerky and at times the machine was sluggish, until I restarted tvheadend. I checked in top and found that tvheadend was using >3GB of RAM which is certainly out of the ordinary. This combined with normal RAM usage of other processes on the machine was causing my machine to make excessive use of the swap file. With the settings above on v4.2.5 I never see the RAM usage go above roughly 2GB so a RAM leak certainly seems to have been introduced in v4.2.6, so I'm sticking with v4.2.5 for the time being.

    (1-1/1)