Project

General

Profile

[Solved] Admin UI always in English

Added by Любомир Василев 8 months ago

Hello,

I've recently set up TVHeadend for the first time, and I seem to have some issue with the web UI language. This is my setup:
  • OS: Ubuntu 17.10 64 bit
  • Tvheadend 4.2.6-1~g74220185d~artful
I've made the initial setup and then I've configured muxes, channels, etc. All that is working fine. However, I want the UI to be in Bulgarian. So, I've set Bulgarian in all places I could see:
  • General > Base
    • Language settings > only Bulgarian is added to the list of Default languages
    • Web user interface — User language is Bulgarian
  • Users > Access Entries — both the '*' user and the other administrator user have Bulgarian set for "Language" and "Web interface language"
  • My OS (Ubuntu) is also in Bulgarian, in case that matters.
However, here is what happens:
  • When I open the web UI and I'm not logged in, the web UI is in Bulgarian
  • After I log in, the web UI switches to English. On inspection, the above list of settings is not changed - everything is still in Bulgarian.

Am I doing something wrong or is that a bug?


Replies (2)

RE: Admin UI always in English - Added by Mark Clarkstone 8 months ago

If you're using the superuser credentials to login it'll always use English, as it's supposed to be a backdoor in case you get locked out, not a general account.

Create yourself a new admin user with a different name & it should work as expected.

    (1-2/2)