Project

General

Profile

IPTV Tvheadend 4.3-943

Added by Vahram Mazlumyan over 3 years ago

Hello

Channel is working properly , but i found errors in the log, problem ?

2018-01-13 20:38:15.253 subscription: 03DB: "HTTP" subscribing on channel "Nat Geo Wild HD", weight: 100, adapter: "IPTV", network: "TPTV", mux: "Nat Geo Wild HD", provider: "FFmpeg"

2018-01-13 20:38:15.959 libav: AVCodecContext: non-existing SPS 0 referenced in buffering period
2018-01-13 20:38:15.959 libav: AVCodecContext: SPS unavailable in decode_picture_timing
2018-01-13 20:38:15.960 libav: AVCodecContext: non-existing SPS 0 referenced in buffering period
2018-01-13 20:38:15.960 libav: AVCodecContext: SPS unavailable in decode_picture_timing
2018-01-13 20:47:49.614 libav: URLContext: HTTP error 404 Not Found
2018-01-13 20:47:49.614 libav: AVFormatContext: Failed to open segment of playlist 0
2018-01-13 20:47:49.760 libav: URLContext: HTTP error 404 Not Found
2018-01-13 20:47:49.760 libav: AVFormatContext: Failed to open segment of playlist 0
2018-01-13 20:47:49.898 libav: URLContext: HTTP error 404 Not Found


Replies (4)

RE: IPTV Tvheadend 4.3-943 - Added by Mark Clarkstone over 3 years ago

Check that the provider isn't blocking the user-agent. You can pass your own to override tvh's default. Just edit the "Custom HTTP headers" (for all the services) to include a

User-Agent: foo
string, spoofing vlc.

You can also try turning off use a/v library in the network.

RE: IPTV Tvheadend 4.3-943 - Added by saen acro over 3 years ago

Mark Clarkstone wrote:

Check that the provider isn't blocking the user-agent. You can pass your own to override tvh's default. Just edit the "Custom HTTP headers" (for all the services) to include a [...] string, spoofing vlc.

You can also try turning off use a/v library in the network.

this feature not working correctly, on TVH client and server always tvh user reported

RE: IPTV Tvheadend 4.3-943 - Added by Roland Pellegrin 4 months ago

There is a workaround for this:
You can edit your /home/hts/.hts/tvheadend/config file and change the value of the "http_user_agent" property like

        "http_user_agent": "VLC/2.1.4",

Simply restart your tvheadend, and this should work.

RE: IPTV Tvheadend 4.3-943 - Added by Flole Systems 4 months ago

Roland Pellegrin wrote:

There is a workaround for this:
You can edit your /home/hts/.hts/tvheadend/config file and change the value of the "http_user_agent" property like
[...]

Simply restart your tvheadend, and this should work.

Why don't you just set that in the Webinterface? Messing with the config files is generally a bad idea and shouldn't be done unless absolutely necessary.

    (1-4/4)