Project

General

Profile

Not listening on port 9981

Added by Yv Gl almost 5 years ago

Hello,

I have installed version 4.0.9 on Fedora 25 through the rpmfusion rpm.

The process is running:

/usr/bin/tvheadend -f -p /var/run/tvheadend.pid -c /var/lib/tvheadend/config -u tvheadend -g video -6 -C --http_port 9981 --htsp_port 9982

The problem is that I can not connect to the web interface. It seems tvheadend is not listening on port 9981. Checking with netstat -ltn even proves it does not.

What could be the issue here?


Replies (8)

RE: Not listening on port 9981 - Added by Mark Clarkstone almost 5 years ago

Yv Gl wrote:

Hello,

I have installed version 4.0.9 on Fedora 25 through the rpmfusion rpm.

The process is running:

[...]

The problem is that I can not connect to the web interface. It seems tvheadend is not listening on port 9981. Checking with netstat -ltn even proves it does not.

What could be the issue here?

try running it from terminal (as the user you'd normally run it as) & check the output. omit the -g,-u and -f args.

RE: Not listening on port 9981 - Added by Yv Gl almost 5 years ago

Ok, so this is the result:

[[email protected] ~]$ sudo -u tvheadend /usr/bin/tvheadend -p /var/run/tvheadend.pid -c /var/lib/tvheadend/config -6 -C --http_port 9981 --htsp_port 9982
2017-01-26 21:51:08.002 [   INFO] main: Log started
2017-01-26 21:51:08.023 [   INFO] config: loaded
2017-01-26 21:51:08.495 [   INFO] scanfile: DVB-T - loaded 43 regions with 1107 networks
2017-01-26 21:51:08.496 [   INFO] scanfile: DVB-S - loaded 1 regions with 112 networks
2017-01-26 21:51:08.496 [   INFO] scanfile: DVB-C - loaded 17 regions with 56 networks
2017-01-26 21:51:08.496 [   INFO] scanfile: ATSC - loaded 2 regions with 14 networks
2017-01-26 21:51:10.909 [   INFO] dvr: Creating new configuration ''
2017-01-26 21:51:10.910 [   INFO] CSA: Using SSE2 128bit parallel descrambling
2017-01-26 21:51:10.910 [   INFO] epggrab: module eit created
2017-01-26 21:51:10.910 [   INFO] epggrab: module uk_freesat created
2017-01-26 21:51:10.910 [   INFO] epggrab: module uk_freeview created
2017-01-26 21:51:10.910 [   INFO] epggrab: module viasat_baltic created
2017-01-26 21:51:10.915 [  ERROR] upnp: upnp_thread_unicast - failed to create socket [Address family not supported by protocol]
2017-01-26 21:51:10.921 [   INFO] epggrab: module opentv-skyit created
2017-01-26 21:51:10.922 [   INFO] epggrab: module opentv-ausat created
2017-01-26 21:51:10.922 [   INFO] epggrab: module opentv-skyuk created
2017-01-26 21:51:10.922 [   INFO] epggrab: module opentv-skynz created
2017-01-26 21:51:10.929 [   INFO] epggrab: module pyepg created
2017-01-26 21:51:10.929 [   INFO] epggrab: module xmltv created
2017-01-26 21:51:10.941 [   INFO] epgdb: loaded v2
2017-01-26 21:51:10.941 [   INFO] epgdb:   config     1
2017-01-26 21:51:10.941 [   INFO] epgdb:   channels   0
2017-01-26 21:51:10.941 [   INFO] epgdb:   brands     0
2017-01-26 21:51:10.941 [   INFO] epgdb:   seasons    0
2017-01-26 21:51:10.941 [   INFO] epgdb:   episodes   0
2017-01-26 21:51:10.941 [   INFO] epgdb:   broadcasts 0
2017-01-26 21:51:10.942 [ NOTICE] START: HTS Tvheadend version 4.0.9 started, running as PID:2283 UID:966 GID:39, CWD:/home/yves CNF:/var/lib/tvheadend/config
2017-01-26 21:51:11.735 [   INFO] AVAHI: Service 'Tvheadend' successfully established.

Still not listening on port 9981:

[[email protected] ~]$ netstat -ltn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
tcp        0      0 0.0.0.0:3050            0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:6379          0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN     
tcp        0      0 192.168.122.1:53        0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:5432          0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:17434           0.0.0.0:*               LISTEN

RE: Not listening on port 9981 - Added by saen acro almost 5 years ago

without

--http_port 9981 --htsp_port 9982

is there a same problem?

netstat -lnt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 0.0.0.0:9981            0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:9982            0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:3551          0.0.0.0:*               LISTEN
tcp        0      0 192.168.1.222:554       0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:11211         0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:10000           0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:7634          0.0.0.0:*               LISTEN
tcp        0      0 127.0.1.1:53            0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:36602           0.0.0.0:*               LISTEN

RE: Not listening on port 9981 - Added by Mark Clarkstone almost 5 years ago

saen acro wrote:

without
[...]
is there a same problem?

[...]

He could also try changing the ports to something else.

RE: Not listening on port 9981 - Added by Yv Gl almost 5 years ago

I tried with different port parameters, and without the --http_port and --htsp_port, with no difference. The problem still occurs.

I wonder if this error does not explain why it does not work:

2017-01-26 21:51:10.915 [  ERROR] upnp: upnp_thread_unicast - failed to create socket [Address family not supported by protocol]

Note that ipv6 is disabled on my system (by passing ipv6.disable=1 as kernel parameter)

RE: Not listening on port 9981 - Added by Yv Gl almost 5 years ago

Bingo...

After removing ipv6.disable=1 and rebooting, Tvheadend works.

Is that a bug or a feature? :-)

RE: Not listening on port 9981 - Added by Mark Clarkstone almost 5 years ago

Yv Gl wrote:

Bingo...

After removing ipv6.disable=1 and rebooting, Tvheadend works.

Is that a bug or a feature? :-)

Clearly a bug, please open an issue.

    (1-8/8)