Project

General

Profile

Too many channels!

Added by Scott Robinson over 4 years ago

Howdy.

So - I have too many channels... Trying to match my EPG/Channel list to Sky to keep the other half happy.

I delete channels from TVH - Reboot the box Inc. TVH, then sadly they appear again... Screenshot below is what it's like post reboot... How can I get me 'deletes' to 'stay'? (I.E In this screenshot I want to remove duplicate ITV's, channels below 100 etc.


Replies (4)

RE: Too many channels! - Added by Mark Clarkstone over 4 years ago

Highlight all (change the number of shown services using the pager at the bottom to All), use Ctrl+A to select the lot, then use Detach selected channels from bouquet from the Map services drop-down. Note that this will prevent the bouquet from updating.

If you still want updates from the bouquet, select the channels you want hidden from view (use ctrl + click to select multiple), then press the Edit button, uncheck Enable (but tick the additional checkbox before the Enable checkbox to apply to all selected) & hit Save. Be aware that they'll reappear if an update from the bouquet for the service occurs.

RE: Too many channels! - Added by Scott Robinson over 4 years ago

Fantastic - Thanks for the reply.

But... :(

That doesn't appear to have done anything. I've tried a few times to make sure It's not me missing something. Select ALL channels and detached them (I see nothing in the UI logs when I do this). Give it a few minutes, delete the channels below 100. Give it a few more minutes, box reboots.

Depending on it's mood I either get... Exactly what's in the screenshot above, or I also get some additional channels thrown in for good measure, but the deleted ones never go.

I'm happy not to have updates from the bouquet and manually update if/when required.

RE: Too many channels! - Added by Scott Robinson over 4 years ago

Bump! Sorry...

RE: Too many channels! - Added by Jonathan Thomson over 4 years ago

Looks like your setup (and intentions) are the same as mine.

Firstly, the channel numbers that appear when you are mapped to a bocquet which have channel numbers less than 101 started appearing a couple of months ago (around the same time the "detach from bocquet" feature was added). With those, simply disable them rather than deleting them. It's the first checkbox in your screenshot. You can multi-select a load of them, click on the "Edit" button then ensure the "Enabled" checkbox is unchecked - you also need to CHECK the box immediately to the right of it to enable the "multi-select" feature to update all the channels you selected.

Delete will not work (putting aside the "detach from bocquet" feature which should stop this happening) - if a channel is in a bocquet, it will be re-added when the bocquet is refreshed (i.e. at boot time and periodically). Disabling them keeps them part of the bocquet but invisible from your clients. To also hide them from the web ui, drop the menu down next to the "Enabled" button and set the filter to "Yes" - this will hide any disabled channels from the web ui (you'll need to do this on every browser you use or if you clear your cookies).

Next, you seem to have a load of duplicate "genuine" Sky channels in that list (i.e. multiple ITV versions assigned to channel 103) which suggests some channels are manually added (unintentionally) or the bocquet is a bit screwed.

  • In your bocquets list, have you got both "Enabled" and "Automap" checked only for bocquet 5?
  • Does the "# Services" column and "# Services Seen" numbers match in the bocquets list? I'm seeing 640 channels in that bocquet at the time of posting
  • What happens if you uncheck both boxes for bocquet 5 in the bocquets list - are any channels left over once TVHeadend removes the ones in bocquet 5?
    (1-4/4)