mn88473 (Astrometa?) problem

Added by Anders Gustafsson about 2 years ago

So, I had it working, and suddenly after a restart it no longer works. The Stick is detected as DVB-T only. TVH is 4.0.7 and nothing else has changed. I have two DVB-C sticks ro recording works, but I like to have multiple tuners.

Found several posts with similar issues, fir example https://www.tvheadend.org/boards/5/topics/17895

Someone suggested running w_scan prior, which I did:

w_scan version 20141122 (compiled for DVB API 5.10)
using settings for FINLAND
DVB cable
DVB-C FI
scan type CABLE, channellist 8
output format vdr-2.0
WARNING: could not guess your codepage. Falling back to 'UTF-8'
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
        /dev/dvb/adapter0/frontend0 -> "Realtek RTL2832 (DVB-T)" doesnt support CABLE -> SEARCH NEXT ONE.
        /dev/dvb/adapter0/frontend1 -> CABLE "Panasonic MN88473": very good :-))

Using CABLE frontend (adapter /dev/dvb/adapter0/frontend1)
-_-_-_-_ Getting frontend capabilities-_-_-_-_
Using DVB API 5.10
frontend 'Panasonic MN88473' supports
INVERSION_AUTO
QAM_AUTO
FEC_AUTO
FREQ (42.00MHz ... 1002.00MHz)
SRATE (1.000MSym/s ... 7.200MSym/s)
-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
146000: sr6900 (time: 00:02.424)         signal ok:     QAM_AUTO f = 146000 kHz S6900C999  (0:0:0)

No change though. Ie I disabled the tvheadend service so it would not start upon boot. Power down, power up (even pulled the sick briefly just to be sure), w-scan, then start tvheadend. It appears to loaf the firmware, but then refuses to open the adapter?

Aug 28 11:24:03 tvburk tvheadend[4201]: dvr: Creating new configuration ''
Aug 28 11:24:03 tvburk tvheadend[4201]: linuxdvb: unable to open /dev/dvb/adapter0/frontend1
Aug 28 11:22:20 tvburk tvheadend[4201]: linuxdvb: adapter added /dev/dvb/adapter0
Aug 28 11:22:20 tvburk kernel: usb 4-1.1: DVB: adapter 0 frontend 0 frequency 0 out of range (174000000..862000000)
Aug 28 11:22:19 tvburk kernel: usb 4-1.5: DVB: adapter 1 frontend 0 frequency 0 out of range (174000000..862000000)
Aug 28 11:22:19 tvburk tvheadend[4201]: linuxdvb: adapter added /dev/dvb/adapter1
Aug 28 11:22:11 tvburk tvheadend[4201]: linuxdvb: adapter added /dev/dvb/adapter2
Aug 28 11:22:11 tvburk kernel: usb 4-1.6: DVB: adapter 2 frontend 0 frequency 0 out of range (174000000..862000000)
Aug 28 11:22:04 tvburk kernel: usb 2-2: DVB: adapter 3 frontend 0 frequency 0 out of range (55000000..862000000)
Aug 28 11:22:04 tvburk kernel: si2157 14-0060: firmware version: 3.0.5
Aug 28 11:22:04 tvburk tvheadend[4201]: linuxdvb: adapter added /dev/dvb/adapter3
Aug 28 11:22:04 tvburk kernel: si2157 14-0060: found a 'Silicon Labs Si2157-A30'
Aug 28 11:22:04 tvburk kernel: si2168 13-0064: firmware version: 4.0.11
Aug 28 11:22:03 tvburk kernel: si2168 13-0064: downloading firmware from file 'dvb-demod-si2168-b40-01.fw'
Aug 28 11:22:03 tvburk kernel: si2168 13-0064: found a 'Silicon Labs Si2168-B40'
Aug 28 11:22:02 tvburk tvheadend[4201]: scanfile: ATSC - loaded 2 regions with 14 networks
Aug 28 11:22:02 tvburk tvheadend[4201]: scanfile: DVB-C - loaded 16 regions with 51 networks
Aug 28 11:22:02 tvburk tvheadend[4201]: scanfile: DVB-S - loaded 1 regions with 92 networks
Aug 28 11:22:02 tvburk tvheadend[4201]: scanfile: DVB-T - loaded 43 regions with 729 networks
Aug 28 11:22:02 tvburk tvheadend[4201]: config: loaded
Aug 28 11:22:02 tvburk tvheadend[4201]: main: Log started
Aug 28 11:22:02 tvburk systemd[1]: Cannot add dependency job for unit logrotate.timer, ignoring: Unit logrotate.timer failed to l
Aug 28 11:21:34 tvburk kernel: rtl2832 6-0010: i2c reg read failed -32
Aug 28 11:15:01 tvburk CRON[3313]: pam_unix(crond:session): session closed for user root
Aug 28 11:15:01 tvburk cron[3313]: pam_unix(crond:session): session opened for user root by (uid=0)
Aug 28 11:06:32 tvburk kernel: mn88473 6-0018: firmware parity check succeeded=0x20
Aug 28 11:06:31 tvburk kernel: mn88473 6-0018: downloading firmware from file 'dvb-demod-mn88473-01.fw'

I am stuck here :( Any ideas?


Replies (27)

RE: mn88473 (Astrometa?) problem - Added by Anders Gustafsson 5 months ago

Sadly, the upgrade from OpenSuSE 42.1 to 42.3 jinxed it. Same issue as before. If I power on, then run 'w_scan -fc -cFI', then start tvheadend then it works just fine.

RE: mn88473 (Astrometa?) problem - Added by War psycmos 4 months ago

Thanks a lot MikeB2013 for your solution, and Joris van puyenbroeck to share edited commands to work on libreelec!!!!

Now i have DVB-C working!!! :D

1 2 (26-27/27)