Project

General

Profile

H/W accelerated transcoding

Added by joky joky over 6 years ago

Hi guys,

I just tried to compile tvheadend from git rep to enable hw-accelerated transcoding. In fact, my current PC (Phenom 9150e Quad-Core, 4GB) is completely overloaded transcoding more than 2 streams at once.

I always fail due to some errors:

  1. ./configure --prefix=/usr --enable-libav --enable-dvbcsa --enable-imagecache --enable-avahi --enable-inotify --enable-uriparser --enable-ccache --enable-tvhcsa --enable-mpegps --enable-bundle --enable-qsv
    [..]
    cc: error: ~/tvheadend/build.linux/ffmpeg/build/ffmpeg/lib/libmfx.a: File not found
  1. ./configure --prefix=/usr --enable-ffmpeg --enable-dvbcsa --enable-imagecache --enable-avahi --enable-inotify --enable-uriparser --enable-ccache --enable-tvhcsa --enable-mpegps --enable-bundle --enable-qsv
    [..]
    cc: error: ~/tvheadend/build.linux/ffmpeg/build/ffmpeg/lib/libmfx.a: File not found

As I've manually compiled and installed ffmpeg and also libav before I tried to skip the ffmpeg-static (--disable-ffmpeg_static) resulting in a tvheadend-build without transcoding functions at all.

Can anyone tell me what to do to get tvheadend compiled with hw/acceleration?
Is hw-acceleration available on my hardware (GPU: GeForce 8200, CPU: AMD 9150e)?
Do you have any recommendation for another GPU/CPU?

thanks in advance!


Replies (1)

RE: H/W accelerated transcoding - Added by Davor Komljenovic over 5 years ago

Did you ever get an answer? I'm trying to do the same thing, compile Tvheadend so that it uses already compiled ffmpeg that can do hardware transcoding on my Odroid XU4. Same issue, if I compile with disable-ffmpeg_static, I get no transcoding options.

There has to be a way to build Tvheadend with the very specific ffmpeg you want to use OR so simply allow external ffmpeg but also allow transcoding options.

    (1-1/1)