Project

General

Profile

Cannot login on TVHeadend-testing 4.1.1923-2 on Synology with DSM6.0

Added by Rene Arts over 5 years ago

Current version DSM 6.0-7321 Update 3

Since I installed the update to TVHeadend-testing 4.1.1923-2 (syno.dierkse.nl) on my Synology NAS I am not able to login on TVHeadend. At the end of the install procedure a wizard ask for a admin account name and password (default admin;admin) but I cannot login using these credentials. I tried reinstalling TVHeadend, changing the credentials but it did not solve the problem.
I also altered the start-stop-status script to start with -C, which works one time. I get the TVHeadend setup wizard, walked through it and I also assigned a user account name and password (tried altering and not altering the admin account as well). After I logout or restart TVHeadend I still cannot login. Starting with --noacl also did not really solve anything (could login once, after removing and configuring admin and user accounts not anymore).

Is this a TVHeadend problem or is it related to the Synology package, and most important, how to solve this?


Replies (28)

RE: Cannot login on TVHeadend-testing 4.1.1923-2 on Synology with DSM6.0 - Added by Bernd Schuster over 4 years ago

There ist a bug in Tvheadend from http://syno.dierkse.nl/ which I can confirm in armada375 version.

In synology user settings I did create a new user first. This user will be used later in tvheadend install setup.

First Setup everything is fine. It takes a lot of time to set sender Logo , sequence, etc. Its a pain in the ass.
After reboot the work ist gone because you cant login anymore.

Nobody could help so far. I'm not a programmer but I found a solution which simple but it works. I can confirm for tvheadend-testing_armada375-5.2_4.3.28042017-1.spk

Just go to http://syno.dierkse.nl/ load you right package, make an manual installation. it is actually an over install
After that I could log in an all settings where still there.

This workt for me

RE: Cannot login on TVHeadend-testing 4.1.1923-2 on Synology with DSM6.0 - Added by Giuseppe Sicilia over 4 years ago

It seams there is a bug regarding user-handling:

Yesterday i made a fresh install tvh with latest 4.3.28042017-1. After Installation i could login and set all settings with my selected Diskstation main-user. But ...
After reboot, dsm has created new user "tvheadend" and all user-rights in /var/packages/tvh.../target changed from "sc-tvheadend-testing:user" to "tvheadend:user". But tvh starts every time with user "sc-tvheadend-testing", so either tvh does'nt starts at all or it starts and i cannot login.
I have changed the starting user from "sc-tvheadend-testing" to "tvheadend" (in /var/packages/tvh.../scripts/start-stop...). With automatic created user (within dsm) "tvheadend" now i can set user-access-rights for different folders.
Why DSM doesnt create user sc-tvheadend-testing? I checked all install-files but i cannot find the Parameter which is responsible for user-handling/creating...

(26-28/28)