Project

General

Profile

RTL2832u DVB-T on OpenWRT : frontend avaiable but not detected

Added by T C over 7 years ago

I'm trying TVH on a TP-Link MR3020 with OpenWRT Barrier Breaker (Kernel 3.10)

opkg update
opkg install kmod-input-core -d ram
insmod /tmp/lib/modules/3.10.49/input-core.ko

cd /tmp

wget http://openwrt.stargate.pw/compiled-modules/ar71xx/latest/dvb-core.ko
wget http://openwrt.stargate.pw/compiled-modules/ar71xx/latest/dvb-pll.ko
wget http://openwrt.stargate.pw/compiled-modules/ar71xx/latest/rc-core.ko
wget http://openwrt.stargate.pw/compiled-modules/ar71xx/latest/i2c-mux.ko
wget http://openwrt.stargate.pw/compiled-modules/ar71xx/latest/dvb-usb.ko
wget http://openwrt.stargate.pw/compiled-modules/ar71xx/latest/dvb_usb_v2.ko
wget http://openwrt.stargate.pw/compiled-modules/ar71xx/latest/rtl2830.ko
wget http://openwrt.stargate.pw/compiled-modules/ar71xx/latest/rtl2832.ko
wget http://openwrt.stargate.pw/compiled-modules/ar71xx/latest/r820t.ko
wget http://openwrt.stargate.pw/compiled-modules/ar71xx/latest/dvb-usb-rtl28xxu.ko

insmod dvb-core.ko
insmod dvb-pll.ko
insmod rc-core.ko
insmod i2c-mux.ko
insmod dvb-usb.ko
insmod dvb_usb_v2.ko
insmod rtl2830.ko
insmod rtl2832.ko
insmod r820t.ko
insmod dvb-usb-rtl28xxu.ko

---

[  270.050000] usbcore: registered new interface driver dvb_usb_rtl28xxu
[  590.070000] usb 1-1: new high-speed USB device number 2 using ehci-platform
[  590.240000] usb 1-1: dvb_usb_v2: found a 'Realtek RTL2832U reference design' in warm state
[  590.320000] usb 1-1: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[  590.330000] DVB: registering new adapter (Realtek RTL2832U reference design)
[  590.340000] usb 1-1: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
[  590.350000] r820t 0-001a: creating new instance
[  590.370000] r820t 0-001a: Rafael Micro r820t successfully identified
[  590.380000] Registered IR keymap rc-empty
[  590.390000] input: Realtek RTL2832U reference design as /devices/platform/ehci-platform/usb1/1-1/rc/rc0/input0
[  590.390000] rc0: Realtek RTL2832U reference design as /devices/platform/ehci-platform/usb1/1-1/rc/rc0
[  590.400000] usb 1-1: dvb_usb_v2: schedule remote query interval to 400 msecs
[  590.420000] usb 1-1: dvb_usb_v2: 'Realtek RTL2832U reference design' successfully initialized and connected

---

opkg install tvheadend -d ram
Installing tvheadend (3.4patch1-0.1) to ram...
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/oldpackages/tvheadend_3.4patch1-0.1_ar71xx.ipk.
Installing libcurl (7.38.0-1) to ram...
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/base/libcurl_7.38.0-1_ar71xx.ipk.
Installing libpolarssl (1.3.9-2) to ram...
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/base/libpolarssl_1.3.9-2_ar71xx.ipk.
Installing libopenssl (1.0.2a-0) to ram...
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/base/libopenssl_1.0.2a-0_ar71xx.ipk.
Installing zlib (1.2.8-1) to ram...
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/base/zlib_1.2.8-1_ar71xx.ipk.
Installing librt (0.9.33.2-1) to ram...
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/base/librt_0.9.33.2-1_ar71xx.ipk.
Installing libpthread (0.9.33.2-1) to ram...
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/base/libpthread_0.9.33.2-1_ar71xx.ipk.
Configuring libpthread.
Configuring libpolarssl.
Configuring libcurl.
Configuring librt.
Configuring zlib.
Configuring libopenssl.
Configuring tvheadend.
[email protected]:~# 

---

export PATH=/usr/bin:/usr/sbin:/bin:/sbin:/tmp/usr/sbin:/tmp/usr/bin
export LD_LIBRARY_PATH=/lib:/usr/lib:/tmp/lib:/tmp/usr/lib

[email protected]:~# tvheadend -C
Apr 02 01:31:37.959 [   INFO]:epggrab: module pyepg created
Apr 02 01:31:37.961 [   INFO]:epggrab: module xmltv created
Apr 02 01:31:37.967 [   INFO]:epgdb: loaded v2
Apr 02 01:31:37.968 [   INFO]:epgdb:   channels   0
Apr 02 01:31:37.969 [   INFO]:epgdb:   brands     0
Apr 02 01:31:37.970 [   INFO]:epgdb:   seasons    0
Apr 02 01:31:37.977 [   INFO]:epgdb:   episodes   0
Apr 02 01:31:37.981 [   INFO]:epgdb:   broadcasts 0
Apr 02 01:31:37.982 [   INFO]:dvr: Creating new configuration ''
Apr 02 01:31:37.985 [ NOTICE]:START: HTS Tvheadend version  started, running as PID:1336 UID:0 GID:0, settings located in '/root/.hts/tvheadend'

So, the stick works, but is not detected. any idea?


Replies (8)

RE: RTL2832u DVB-T on OpenWRT : frontend avaiable but not detected - Added by Prof Yaffle over 7 years ago

Without knowing this stick, I suppose I'd check:

1. Kernel support (the stick sounds old, so 3.10 might be fine or you may need additional drivers)

2. See if those kernel modules are actually loading and are the right ones

3. Any firmware required?

4. Access permissions - can the tvheadend process access the video devices in /dev/dvb or similar

5. Anything in syslog from tvh beyond what you posted

6. Anything in dmesg beyond what you posted

7. What precisely does the tvh web interface tell you - can it see the tuner at all, is it enabled, etc.

RE: RTL2832u DVB-T on OpenWRT : frontend avaiable but not detected - Added by T C over 7 years ago

1&2. i got all the right kmods for my kernel from an external site and all loaded fine after some tinkering
3. nope, not for the rt2832u (but the myGica T230 i want to use later will do)
4. i have root user only and ran it as root, so yes. and even testwise chmod -R 'ded /dev/dvb/ to 777
5&6 no, neither bash or dmesg throwed anything after completing the package setup and starting tvh
7. it only offers a "IPTV" tab under DVB-devices

RE: RTL2832u DVB-T on OpenWRT : frontend avaiable but not detected - Added by Lyubomir Trifonov over 7 years ago

You load more modules than necessary.
I'm using the latest kernel 3.18.14 and load only these:

dvb-core.ko
dvb-usb-rtl28xxu.ko
dvb_usb_v2.ko
input-core.ko
r820t.ko
rtl2830.ko
rtl2832.ko
rtl2832_sdr.ko

it loads like this:

[   14.070000] dvb_usb_rtl28xxu 1-1:1.0: no of_node; not parsing pinctrl DT
[   14.070000] usb 1-1: dvb_usb_v2: found a 'Realtek RTL2832U reference design' in warm state
[   14.410000] usb 1-1: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[   14.430000] DVB: registering new adapter (Realtek RTL2832U reference design)
[   14.440000] i2c i2c-0: Added multiplexed i2c bus 1
[   14.460000] i2c i2c-0: Added multiplexed i2c bus 2
[   14.470000] usb 1-1: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
[   14.480000] r820t 0-001a: creating new instance
[   14.510000] r820t 0-001a: Rafael Micro r820t successfully identified
[   14.540000] usb 1-1: dvb_usb_v2: 'Realtek RTL2832U reference design' successfully initialized and connected
[   14.560000] dvb_usb_rtl28xxu 1-1:1.1: no of_node; not parsing pinctrl DT
[   14.560000] usbcore: registered new interface driver dvb_usb_rtl28xxu

And then tvheadend just works.
I start it, hovewer, like this:

tvheadend -C -u root

http://www.tvrouter.org

RE: RTL2832u DVB-T on OpenWRT : frontend avaiable but not detected - Added by Lyubomir Trifonov over 7 years ago

T C wrote:

So, the stick works, but is not detected. any idea?

Actually, the issue is in the tvheadend binary you use.
It seems that the binary was compiled without "linux-dvb" support.

You can use the version I've just compiled and tested on my TP-Link TL-WDR3600
Find it attached to the post.
ar71xx tvheadend binary ipk

Regards,
Lyu
www.tvrouter.org

RE: RTL2832u DVB-T on OpenWRT : frontend avaiable but not detected - Added by edgar nina over 7 years ago

I've tried your compiled version for ar71xx (I've tested on TP-Link TL-WDR4300, with BB) and works pretty well with a USB dvb-t dongle with chip IT9135.
On my system I've also an SAT-IP server for DVB-S. With actual binary they get not recognized, I assume because Tvheadend is compiled without SAT-IP, is that corrects? Can you compile with SAT-IP and share?

Thanks
ENina

RE: RTL2832u DVB-T on OpenWRT : frontend avaiable but not detected - Added by Lyubomir Trifonov over 7 years ago

Hi ENina,

actually the binary I've uploaded is compiled WITH sat-ip support.
these are all the options. Just disabled the decrypting stuff.
I'm happy to recompile with some other options turned on.

CONFIG_CWC = no
CONFIG_CAPMT = no
CONFIG_CONSTCW = no
CONFIG_LINUXDVB = yes
CONFIG_SATIP_SERVER = yes
CONFIG_SATIP_CLIENT = yes
CONFIG_HDHOMERUN_CLIENT = no
CONFIG_HDHOMERUN_STATIC = no
CONFIG_IPTV = yes
CONFIG_TSFILE = yes
CONFIG_DVBSCAN = yes
CONFIG_TIMESHIFT = yes
CONFIG_TRACE = yes
CONFIG_IMAGECACHE = yes
CONFIG_AVAHI = no
CONFIG_ZLIB = yes
CONFIG_LIBAV = no
CONFIG_LIBFFMPEG_STATIC = no
CONFIG_INOTIFY = yes
CONFIG_EPOLL = yes
CONFIG_URIPARSER = no
CONFIG_CCACHE = no
CONFIG_TVHCSA = no
CONFIG_BUNDLE = yes
CONFIG_DVBCSA = no
CONFIG_KQUEUE = no
CONFIG_DBUS_1 = no
CONFIG_ANDROID = no
CONFIG_TSDEBUG = no
CONFIG_LOCKOWNER = yes
CONFIG_QSORT_R = yes
CONFIG_LIBICONV = yes
CONFIG_PY_GZIP = yes
CONFIG_BIN_BZIP2 = yes
CONFIG_SSL = yes
CONFIG_LINUXDVBAPI = yes
CONFIG_UPNP = yes
CONFIG_INOTIFY_H = yes
CONFIG_MPEGTS = yes
CONFIG_MPEGTS_DVB = yes

Regards,
Lyu
www.tvrouter.org

RE: RTL2832u DVB-T on OpenWRT : frontend avaiable but not detected - Added by edgar nina over 7 years ago

Hello, thanks for the kick replay.

I've dig more on this and found a tread explaining that satip servers can have detection problems and its possible specify them on the command line (I've already tested on a raspberry pi and X86 systems with tvheadend and never had this issue on the detection).

My sat Ip server is a Digibit R1 and the way I overcome this was set/add following command option "--satip_xml http://xxx.xxx.xxx.xxx:8080/desc.xml" to tvheadend start command

Now I've realized and that is in line what you have already commented that decrypting settings are missing.

If you don't mind can you compile with that options activated.

Many thanks for your time.
Best Regards
ENina

RE: RTL2832u DVB-T on OpenWRT : frontend avaiable but not detected - Added by edgar nina over 7 years ago

Hello,

Did you have problems compiling with decrypting settings?

Best regards
ENina

    (1-8/8)