Project

General

Profile

TVHeadend detects wrong resolution (Analog Hauppauge)

Added by Johannes Peeters about 10 years ago

I have recently bought a Hauppauge HVR-1900 which works fine with mplayer. The basics are working with TVHeadend it seems, but there is still a problem with resolution:

TVHeadend sets the resolution 384x288 by default, while PAL is 720x576. Changing the resolution using v4l2-ctl -v width=720,height=576 works fine (I see the resolution change in XBMC), but how can I force TVHeadend (or XBMC?) to use this resolution?

Johannes


Replies (2)

RE: TVHeadend detects wrong resolution (Analog Hauppauge) - Added by Hein Rigolo about 10 years ago

What if you set the resolution before you start tvheadend? will that work?
Also you might be able to use some kernel module parameters when it is loaded to set the defaults for your device.

Do you realy need to use the analog side of the HVR-1900? can you not use the digital side of the HVR-1900? As I understand it it does also support DVB-T.

RE: TVHeadend detects wrong resolution (Analog Hauppauge) - Added by Johannes Peeters about 10 years ago

It is working fine now and I did not change a thing to my configuration. Might be tv-viewer or another tool I've been using set the resolution to 384x288, but I can't reproduce that behavior anymore.

Reason why I'm using the analog part is due to the services available here in Belgium. DVB-T and DVB-C (although not supported on the HVR-1900) only give me a few free-to-air channels, analog is still the way to go if you don't want to be locked-in by one of the telco's.

The system is working fine now. I only had to disable the DVB-T part in the kernel module in order to have TVHeadend recognize the analog tuner.

    (1-2/2)