Project

General

Profile

"frequency 0 out of range" shown in syslog when starting TVH - also shown when doing dmesg | grep -i dvb

Added by Crazy Fin over 4 years ago

Everytime I start TVH I see the following error message for the adapters:

Oct 1 22:03:41 tvserver tvheadend24555: linuxdvb: adapter added /dev/dvb/adapter7
Oct 1 22:03:41 tvserver tvheadend24555: linuxdvb: adapter added /dev/dvb/adapter6
Oct 1 22:03:41 tvserver tvheadend24555: linuxdvb: adapter added /dev/dvb/adapter5
Oct 1 22:03:41 tvserver tvheadend24555: linuxdvb: adapter added /dev/dvb/adapter4
Oct 1 22:03:41 tvserver kernel: [19957.745013] ddbridge 0000:05:00.0: DVB: adapter 4 frontend 0 frequency 0 out of range (950000..2150000)
Oct 1 22:03:41 tvserver tvheadend24555: linuxdvb: adapter added /dev/dvb/adapter3
Oct 1 22:03:41 tvserver kernel: [19957.782155] ddbridge 0000:03:00.0: DVB: adapter 3 frontend 0 frequency 0 out of range (950000..2150000)
Oct 1 22:03:41 tvserver tvheadend24555: linuxdvb: adapter added /dev/dvb/adapter2
Oct 1 22:03:41 tvserver kernel: [19957.821679] ddbridge 0000:03:00.0: DVB: adapter 2 frontend 0 frequency 0 out of range (950000..2150000)
Oct 1 22:03:41 tvserver tvheadend24555: linuxdvb: adapter added /dev/dvb/adapter1
Oct 1 22:03:41 tvserver kernel: [19957.844220] ddbridge 0000:03:00.0: DVB: adapter 1 frontend 0 frequency 0 out of range (950000..2150000)
Oct 1 22:03:41 tvserver tvheadend24555: linuxdvb: adapter added /dev/dvb/adapter0
Oct 1 22:03:41 tvserver kernel: [19957.884211] ddbridge 0000:03:00.0: DVB: adapter 0 frontend 0 frequency 0 out of range (950000..2150000)

Tuning in XBMC and TVH works fine though and it works perfectly fine to watch LiveTV via XBMC.

Note also that the tuning errors only is happening for adapter 0 to 5 out of my 8 adapters.


Replies (7)

RE: "frequency 0 out of range" shown in syslog when starting TVH - also shown when doing dmesg | grep -i dvb - Added by Crazy Fin over 4 years ago

Sorry to keep chatting in this thread that was changed from "New" to "Invalid".

I still believe it is TVH doing something strange during the startup sequence that causes these "adapter 2 frontend 0 frequency 0 out of range (950000..2150000)" messages from kernel in the syslog:

Oct 5 23:16:30 tvserver tvheadend17114: linuxdvb: adapter added /dev/dvb/adapter4
Oct 5 23:16:30 tvserver tvheadend17114: linuxdvb: adapter added /dev/dvb/adapter3
Oct 5 23:16:30 tvserver kernel: [34269.287161] ddbridge 0000:03:00.0: DVB: adapter 3 frontend 0 frequency 0 out of range (950000..2150000)
Oct 5 23:16:30 tvserver tvheadend17114: linuxdvb: adapter added /dev/dvb/adapter2
Oct 5 23:16:30 tvserver kernel: [34269.326781] ddbridge 0000:03:00.0: DVB: adapter 2 frontend 0 frequency 0 out of range (950000..2150000)
Oct 5 23:16:30 tvserver tvheadend17114: linuxdvb: adapter added /dev/dvb/adapter1
Oct 5 23:16:30 tvserver tvheadend17114: linuxdvb: adapter added /dev/dvb/adapter0
Oct 5 23:16:30 tvserver kernel: [34269.377017] ddbridge 0000:03:00.0: DVB: adapter 0 frontend 0 frequency 0 out of range (950000..2150000)
Oct 5 23:16:30 tvserver tvheadend17114: dvr: Creating new configuration ''

I downloaded dvb-apps. I shutdown TVH and did a SCAN according to the info at http://www.linuxtv.org/wiki/index.php/Scan to create a complete channel list for the satellite THOR 1.0W (actually it is 0.8W).
After that I tuned each adapter to a channel using Szap-S2 app (http://www.linuxtv.org/wiki/index.php/Szap-s2and). Then I started TVH again and voilaaaa! No more messages in the syslog about "frequency 0 out of range"! :-)

So it definately looks like that when TVH starts it initiates the adapters without having a valid frequency set?

RE: "frequency 0 out of range" shown in syslog when starting TVH - also shown when doing dmesg | grep -i dvb - Added by Gil Lima about 2 years ago

hello
I have Tvheadend 4.1-999~gee9b6da with 2x TBS 6985 DVBS/S2 (8 tuners total) fresh installation and still continue to have DVB: adapter 7 frontend 0 symbol rate 0 out of range (1000000..45000000) and in the Tvheadend have the error linuxdvb: TurboSight TBS 6985 DVBS/S2 frontend : DVB-S #0 - failed to tune [e=Invalid argument]
anyone already fix that or have a idea to fix?
i try to use hispasat 30W and have good signal.

RE: "frequency 0 out of range" shown in syslog when starting TVH - also shown when doing dmesg | grep -i dvb - Added by Mark Clarkstone about 2 years ago

Gil Lima wrote:

hello
I have Tvheadend 4.1-999~gee9b6da with 2x TBS 6985 DVBS/S2 (8 tuners total) fresh installation and still continue to have DVB: adapter 7 frontend 0 symbol rate 0 out of range (1000000..45000000) and in the Tvheadend have the error linuxdvb: TurboSight TBS 6985 DVBS/S2 frontend : DVB-S #0 - failed to tune [e=Invalid argument]
anyone already fix that or have a idea to fix?

It's not broken. The driver just doesn't like the values passed to it from Tvheadend. If you're manually adding muxes avoid using AUTO & see if it goes away.

i try to use hispasat 30W and have good signal.

RE: "frequency 0 out of range" shown in syslog when starting TVH - also shown when doing dmesg | grep -i dvb - Added by Gil Lima about 2 years ago

Mark Clarkstone wrote:

Gil Lima wrote:

hello
I have Tvheadend 4.1-999~gee9b6da with 2x TBS 6985 DVBS/S2 (8 tuners total) fresh installation and still continue to have DVB: adapter 7 frontend 0 symbol rate 0 out of range (1000000..45000000) and in the Tvheadend have the error linuxdvb: TurboSight TBS 6985 DVBS/S2 frontend : DVB-S #0 - failed to tune [e=Invalid argument]
anyone already fix that or have a idea to fix?

It's not broken. The driver just doesn't like the values passed to it from Tvheadend. If you're manually adding muxes avoid using AUTO & see if it goes away.

i try to use hispasat 30W and have good signal.

thank you very much, tried and looks to work
doing some more tests
thanks again

RE: "frequency 0 out of range" shown in syslog when starting TVH - also shown when doing dmesg | grep -i dvb - Added by Gil Lima about 2 years ago

already searched and mapped the channels but still receiving errors

2017-03-13 08:06:59.231 linuxdvb: TurboSight TBS 6985 DVBS/S2 frontend : DVB-S #2 - poll TIMEOUT

2017-03-13 08:06:59.973 linuxdvb: TurboSight TBS 6985 DVBS/S2 frontend : DVB-S #2 - retune nodata

2017-03-13 08:07:06.891 linuxdvb: TurboSight TBS 6985 DVBS/S2 frontend : DVB-S #2 - poll TIMEOUT

2017-03-13 08:07:07.000 mpegts: 12207H in TP12207H TP3 - scan no data, failed

2017-03-13 08:07:07.024 linuxdvb: TurboSight TBS 6985 DVBS/S2 frontend : DVB-S #2 - retune nodata

2017-03-13 08:07:08.000 subscription: 0453: service instance is bad, reason: No input detected

any ideas?

    (1-7/7)