Project

General

Profile

transcode: Unable to find H264 encoder

Added by Morten Trab almost 9 years ago

I'm trying to setup TVHeadend for a XBMC and Plex backend.

XBMC is working with the IPTV strems from my provider.
When trying to get Plex working I get this in log:

transcode: Unable to find H264 encoder

And then no picture and only audio is working.

TVHeadend is running on a Debian Squeeze box.

Any tips on how to get H264 encoding working on Squeeze?

Regards,
Morten


Replies (6)

RE: transcode: Unable to find H264 encoder - Added by Prof Yaffle almost 9 years ago

No personal experience, but I'm guessing you're missing the extra codecs - libavcodec-extra-53 on Ubuntu, so probably similar on Debian. Either that or x264, something like that.

RE: transcode: Unable to find H264 encoder - Added by Morten Trab almost 9 years ago

libavcodec-extra-53 returns something like "no versions" (can't remember the exact phrase.
x264 is installed.

RE: transcode: Unable to find H264 encoder - Added by Prof Yaffle almost 9 years ago

I really don't know Debian, but a quick Google suggests that it's in the backports repository from Wheezy to Squeeze?

RE: transcode: Unable to find H264 encoder - Added by Morten Trab almost 9 years ago

Backports - why haven't I thought of that :)

Well, tried that - no luck.
Still have the error.

transcode: Unable to find H264 encoder

RE: transcode: Unable to find H264 encoder - Added by Prof Yaffle almost 9 years ago

Ah, well, it was worth a try...

Have you got the ffmpeg/libav libraries all installed? I'm thinking of libavcodec-dev, libavutil-dev and similar.

Again, just Googling with extreme prejudice, so don't mistake me for an expert... :-)

RE: transcode: Unable to find H264 encoder - Added by Morten Trab almost 9 years ago

Been foolin around today.
Haven't got it solved yet.
Build x264 from GIT but that didn't solve it either.

And now I got everything messed up, can't recompile tvheadend

 checking for pkg libavcodec <=55.0.0 ...          fail
ERROR: libav development support not found (use --disable-libav)

Tried apt-get install libavcodec-dev but that wont install because of livavcodec-extra-53 :/ Bummer

    (1-6/6)