Project

General

Profile

No Service Enabled

Added by Thomas Francis over 8 years ago

Hi All

I have been using TVHeadend for a few years with good results. I originally used TVheadend with a DVBS2 usb dongle from Sundtek on a Synology NAS (DS712+). Everything worked perfectly. I then moved to a house where there was a terrestrial airel so purchased a PCTV nano DVBT2 USB stick. I also upgraded my Synology NAS to a DS1513+. Installed TVHeadend through SynoCommunity. Again Everything worked perfectly.

Last weekend I moved again and there was a sat dish so reverted to the Sundtek dongle. I installed the drivers for the dongle and TVHeadend could see the device no problem. I did a scan for channels using the Astra 28.2E (I live in south east london) and TVHeadend found a load of muxes and a load more services.I then set about mapping the services to the channels. All working fine so far.

When I go into XBMC to view tv, I get "Tvheadend HTSP Client No service enabled". If i check the live log in TVHeadend I get:

Media Center : Skipping "Sundtek DVB-S/S2 (III)/Astra: 10,773,000 kHz (Default (Port 0, Universal LNB))/BBC 2 England" -- Not Enabled

I have double checked that the device is enabled as outlined here: https://tvheadend.org/boards/5/topics/8240

Still no joy. Not great with Linux but when I installed the Sundtek device i used this:

  1. cd /tmp
  2. wget http://www.sundtek.de/media/sundtek_netinst.sh
  3. chmod 777 sundtek_netinst.sh
  4. sudo ./sundtek_netinst.sh

That is all I did. I didnt configure anything else driver/service wise.

Would anyone have any suggestions on how to get this up and running?

Many thanks


Replies (8)

RE: No Service Enabled - Added by Hugo Rodenburg over 8 years ago

I guess your channels in Tvheadend are messed up and don't correspond to the current services on the muxes (anymore). Try to delete a channel and re-add it from the "Services" tab. Then, test that channel again. Does that solve the problem?

RE: No Service Enabled - Added by Thomas Francis over 8 years ago

I tried removing all channels and then just adding 1 - channel 4 but still get the same error.I also removed the other muxes for testing purposes

RE: No Service Enabled - Added by Thomas Francis over 8 years ago

I have also noticed that manually adding a MUX never finds any services.only adding via network location

RE: No Service Enabled - Added by Hugo Rodenburg over 8 years ago

That's weird. I've had this problem when the channel existed and I removed and added the muxes. Delete and add the channels works for me in that case.
You can try enable the debug logging and take a look at the log to see what is going on.

RE: No Service Enabled - Added by Thomas Francis over 8 years ago

How do I enable the debug log?

RE: No Service Enabled - Added by Hugo Rodenburg over 8 years ago

You can start the tvheadend process with --debug specified, or configure the synology startup scripts (I'm not familair with Synology). Or you can enable debug within the web frontend in the lower right corner.
Messages will be displayed in the webinterface or in your system's syslog /var/log/syslog or /var/log/messages most likely.

RE: No Service Enabled - Added by Dan Chicheportiche about 8 years ago

Hi,
Do you have news?
I have the same problem only on dvb-s2 muxes:
May 04 12:00:42.478 Service: Subscription "127.0.0.1 [ XBMC Media Center ]": Skipping "STB0899 Multistandard/: 12,207,000 kHz Vertical (Astra)/PARIS PREMIERE HD" -- not enabled

If I try to had a dvbs2 muxe manually like :
Astra 19.2 - 12012V - 29700 - 2/3 - DVB-S2 - 8PSK
Hotbird 13.0 - 16681H - 27500 - 3/4 - DVB-S2 - 8PSK
it doesn't want to detect any channel (on dvbs muxes it work like a charm).

If enter one muxe and have checked DETECT MUXES it detect all channels, but when I want to start a HD channel on these muxes it tell me NOT ENABLE like the message above.

Do you konw how to activate these channel ?

(I test it on my Technisat SkyStar USB 2 HD CI, on a real computer and on my raspberry pi, with ubuntu openlec and debian, x86 and x64, but the same problem on all)

Thanks

RE: No Service Enabled - Added by Paul Bußmann over 7 years ago

I also got the same symptom for 2 of my 8 configured channels in /var/log/syslog using tvheadend-3.4.28 on KODIbuntu:

Mar 20 16:41:09 MediaPC tvheadend[7080]: Service: Subscription "192.168.178.41 [ kodi | XBMC Media Center ]": Skipping "Conexant CX24120/CX24118/ASTRA 1: 11,361,750 kHz Horizontal (No satconf)/ZDF HD" -- not enabled

The log message is confusing as it suggests that Configuration > DVB Inputs > Services > Enabled is not set for "ZDF HD", but the Web Interface listening on port 9981 shows it is set. So the issue is somewhere else.

I digged a little into tvheadend sources and finaly worked-around the issue by patching function dvb_service_is_enabled in src/dvb/dvb_service.c:

- return tda->tda_enabled && tdmi->tdmi_enabled && t->s_enabled && t->s_pmt_pid;
+ return tda->tda_enabled && tdmi->tdmi_enabled && t->s_enabled;

I don't know why s_pmt_pid is not set correctly. I didn't see any further helpful message in /var/log/syslog .
But ignoring it with the patch I was able to tune to all channels I configured.

Hope this helps.

    (1-8/8)