Project

General

Profile

Tvheadend access denied

Added by Mark Hula over 9 years ago

Hi,

On Ubuntu with XBMC Frodo.
Whilst XBMC complains about tvheadend client access denied I notice in the log:

NOTICE: AddOnLog: Tvheadend HTSP Client: CHTSPConnection - SendGreeting - connection opened to 'HTS Tvheadend 2.99.53.4502158', protocol v5
12:35:29 T:2873408320 ERROR: AddOnLog: Tvheadend HTSP Client: ReadResult - 'enableAsyncMetadata' failed - access denied
12:35:29 T:2873408320 ERROR: AddOnLog: Tvheadend HTSP Client: Open - couldn't send EnableAsync().
12:35:29 T:2873408320 ERROR: ADDON: Dll Tvheadend HTSP Client - Client returned bad status (1) from Create and is not usable
12:35:29 T:2873408320 WARNING: UpdateAndInitialiseClients - failed to create add-on Tvheadend HTSP Client, status = 1

I've googled and made sure the dev/adaptor0 is owned by group hrs - what else should I check??

Cheers


Replies (21)

RE: Tvheadend access denied - Added by Adam Sutton over 9 years ago

This says you have a username/password configured in TVH for access control (do you enter a password when logging into the UI?). And that you've not configured XBMC with those details.

Adam

RE: Tvheadend access denied - Added by Mark Hula over 9 years ago

Hi,

I tried to add a user in the tvheadend ui. I tried both an xbmc user and also the user created when tvheadend was installed.
The UI always comes back with 'transaction aborted'

Cheers

RE: Tvheadend access denied - Added by Mark Hula over 9 years ago

If I remove a user (assuming they were actually added which I doubt); the debug log/error is the same. I was guessing it wasn't a user related problem.....

Cheers

RE: Tvheadend access denied - Added by Adam Sutton over 9 years ago

Check the contents of ~TVHUSER/.hts/tvheadend/superuser and ~TVHUSER/.hts/tvheadend/accesscontrol

where TVHUSER is the username used to run TVH (default: hts). See what accounts you have created.

Adam

RE: Tvheadend access denied - Added by Mark Hula over 9 years ago

Hi,

Appreciate your help!
Ok, now I am confused.
The user has a .hts directory with tvheadend in it; but that just contains a epgdb file ; no access control or superuser directory.

thanks

RE: Tvheadend access denied - Added by Adam Sutton over 9 years ago

How have you installed this (and from where)? Doesn't sound like its been set up properly.

Adam

RE: Tvheadend access denied - Added by Mark Hula over 9 years ago

Hi,

I just did:

sudo add-apt-repository ppa:pulse-eight/pulse
sudo apt-get update
sudo apt-get install xbmc tvheadend

If this is incorrect can you please advise how to uninstall and then reinstall correctly??

thanks

RE: Tvheadend access denied - Added by Adam Sutton over 9 years ago

Hmmm, not sure if P8 repo doesn't anything else diff but I thought they were just shadowing our builds these days.

Try running:

dpkg-reconfigure tvheadend

And see if that asks you to put in a username/password for the super/admin user.

Adam

RE: Tvheadend access denied - Added by Mark Hula over 9 years ago

Hi,

No difference. I enter my user and password ; still get the same errors

:-(

RE: Tvheadend access denied - Added by Adam Sutton over 9 years ago

Check exactly which user tvh is running as. Then add the following file:

~TVHUSER/.hts/tvheadend/superuser

with contents {
"username": "USERNAME,
"password": "PASSWORD"
}

replacing USERNAME/PASSWORD accordingly. This should do what that reconfigure should have done.

Adam

RE: Tvheadend access denied - Added by Mark Hula over 9 years ago

Hi,

I added that file; no difference.
Just to check I am doing this right; how do I check exactly who is running tvheaded?; I can't see it in 'top'

Cheers

RE: Tvheadend access denied - Added by Adam Sutton over 9 years ago

ps -ef | grep tvheadend

RE: Tvheadend access denied - Added by Mark Hula over 9 years ago

Hi,

hts 6921 1 0 15:06 ? 00:00:00 /usr/bin/tvheadend -f -u hts -g video
pocster 7587 2280 0 15:22 pts/2 00:00:00 grep --color=auto tvheadend

I assume this is correct?

RE: Tvheadend access denied - Added by Adam Sutton over 9 years ago

Looks right to me, and you restarted that process after changing the superuser file?

RE: Tvheadend access denied - Added by Adam Sutton over 9 years ago

Do you use IRC? If so come along to #hts, much easier than using the forum.

RE: Tvheadend access denied - Added by Mark Hula over 9 years ago

Forgive my confusion!
So user hrs was created by tvheadend yes? - does it have a password? (or does it not require one?).
I login in via ip:9981 with the pocster user.

RE: Tvheadend access denied - Added by Adam Sutton over 9 years ago

Assuming you've changed nothing, the hts (system) user will be created without the ability to login. (It's for running the daemon only). You will need to put the file into /home/hts/.hts/tvheadend/superuser (as root - use sudo vi etc...). I still don't get why it didn't do this on initial install.

Adam

RE: Tvheadend access denied - Added by Mark Hula over 9 years ago

Yep; did that. Still the same :-(

RE: Tvheadend access denied - Added by Adam Sutton over 9 years ago

Come along to #hts if you can, this will be much easier to deal with there.

Adam

RE: Tvheadend access denied - Added by Mark Hula over 9 years ago

OK - thanks for all your help

RE: Tvheadend access denied - Added by Brian Ellis almost 5 years ago

Hi all, please forgive me if this is the wrong place for this or if it has already been dealt with elsewhere. I am very new to this and just trying to figure things out (I'm a biologist, not a computer guy). I have two issues. A little background first. I want to use my QNAP NAS as the backend to run tvheadend and use kodi as the frontend and run tvheadend as an add-on in order to use my NAS as a DVR. I have HDHomerun working and setup with Tvheadend. I can watch live tv through the HDhomerun app (on my comp, phone, ipad). I can also watch live tv through kodi. I was previously able to go into tvheadend through the web on my NAS, and record, and then watch a show (I did this one time with one of the world series games) on my computer. Problems: I can't figure out how to set up something to record going from Kodi. When I have pushed record nothing worked. And now, recently, when I tried to go back into the tvheadend app on the NAS from the web using my computer, it won't let access. It says 'authentication required' http://192.168.1.130:9981 your connection to this site is not private. Username_________ Password __. I have tried my normal passwords. xbmc/xbmc. So, I am hoping you can help me get back in to the app, and to get it setup to record from Kodi. Thanks, Brian

    (1-21/21)