403 Forbidden

Added by Ulrich G. about 2 months ago


I am running a Synology NAS 1817+, and be in need for a replacement for TV Mosaic.
Tvheadend was recommended, so I first activated the SynoCommunity, and thereafter I installed the Tvheadend package from there, together with ffmpeg.
After the installation I used the url with the port :9981 for the web interface.
I was asked for a password during installation, and also when I used the web interface for the first time.
The password I entered on the web interface was rejected, and I ended up with a page: 403 Forbidden.
I found no way to enter the password again, so I deinstalled the package, and made a new installation.
This time I ended up on page 403 without a chance for a password.
I tried it now for several times, with, and without a password during installation, without success.
Furthermore I found no file from Tvheadend within the home/homes shared folder, and port :9982 is not reachable at all.
There is also no icon within the MainMenue of the DSM.

What did I wrong, how can I get these program running, without knowledge in programming?

Replies (4)

RE: 403 Forbidden - Added by Hiro Protagonist about 2 months ago

If you look at the wiki, this issue is covered by the 2nd FAQ entry.

Good luck.

RE: 403 Forbidden - Added by Ulrich G. about 1 month ago

thank you for your reply, but I'm aware of this FAQ entry.

Unfortunately I tried to install the app on a Synology System from a package within the App-Center, as described somewhere in the Wiki.
So I used no Arguments and no Debian.
For a Synology System, the FAQ#2 has no description.

I had, during the installation the opportunity to enter a password (No Username!), but it ends up on page 403, with this password, and also if I leave the password empty, during installation. I even get no chance to enter a password anymore, as I end up on page 403 right away, without password-entry promt.

Also, I would expect to find at least some kind of file within the "home"-folder, but there is also no file related to tvheaded, after the "successful" installation.

Has someone a solution?

RE: 403 Forbidden - Added by saen acro about 1 month ago

Simple basic linux knowledge.

netstat -lpnt

can show opened by processes ports.

can show running processes and resources.

Answer following questions:
1. Is TVH running?
2. Is port's are correct?

RE: 403 Forbidden - Added by Ulrich G. about 1 month ago

Hi, saen acro,
thank you for your reply also.
Unfortunately I have no basic linux knowledge, that is one of the reasons I use Mac, Synology and other GUI based systems.
I also have no command line on my synology, or be currently able to connect via ssh.

But anyway, the protocol of the Diskstation shows a successful installation of TVH, and with a portscan from my Mac I can also confirm the ports 9981, 9982.

The ports are disappearing, if I made a deinstallation, and reappearing with the reinstallation.