Project

General

Profile

Channels / Services no longer found

Added by encore 2097 about 2 months ago

Hello, I had Tvheadend running on debian 10 with a Hauppauge WinTV-HVR-1250 working with ATSC.

After sometime, the channels no longer work and re-scanning finds no channels / services.

My TV w/ built in tuner can find the channels as always.

Thinking my card might be dead I got a Hauppauge WinTV-HVR-1265 with the same result.

Tvheadend "version": 24
          "full_version": "4.2.8-dmo1" 
uname -a
Linux stratus 4.19.0-16-amd64 #1 SMP Debian 4.19.181-1 (2021-03-19) x86_64 GNU/Linux

I've apt install'ed firmware-misc-nonfree

Here's the channels / services that were discovered before:

attached: channel-list.m3u

It played fine in VLC.

I've scanned with tvheadend with:

United States: us-Cable-Standard-center-frequencies-QAM256
United States: us-ATSC-center-frequencies-8VSB

attached: tvheadend.log

Here's the scan with w_scan

$ w_scan -fa -A3 -c US -X 

attached wscan.log

Any ideas why my tuner / tvheadend can no longer find channels?

tvheadend.log (132 KB) tvheadend.log tvheadend scan log
channel-list.m3u (171 KB) channel-list.m3u pervious_channel_list
1265-wscan-2.txt (41.9 KB) 1265-wscan-2.txt wscan

Replies (5)

RE: Channels / Services no longer found - Added by encore 2097 about 2 months ago

I tried the cards on a Win 10 machine with NextPVR, it identified one of the tuner front ends as QAM the other as ATSC. When I hit scan on QAM it found around 300+ channels.

How can I replicate this in tvheadend?

I've tried a custom ATSC-C network and adding muxes manually.

Guessing Symbol/s as 6900000 , QAM/256 and FEC: AUTO

Its still not working.

I read it might help to reduce PCIe speed to 1x at the *update it didnt make a difference.

The only change in my system is I upgraded my CPUs from Xeon Sandy Bridge to Xeon Ivy Bridge. I reset BIOS after the upgrade and haven't noticed any issues except this now.

Another change is to try enable CSM, vs UEFI only.

RE: Channels / Services no longer found - Added by saen acro about 2 months ago

You have problem with driver or firmware.
If want to use UEFI then make signed Driver.
Start to read DMESG.

RE: Channels / Services no longer found - Added by encore 2097 about 2 months ago

dmesg shows no issues as far as I can tell. dmesg.txt attached

wasn't an UEFI issue.. maybe power management..

I'm going to reset my BIOS to default and see if that fixes the issue.

dmesg.txt (98.5 KB) dmesg.txt dmesg

RE: Channels / Services no longer found - Added by encore 2097 about 2 months ago

Well it wasn't the BIOS settings.

I booted a debian live cd , debian-live-10.6.0-amd64-gnome . The UI mouse and kb would freeze intermittently but I got ssh up and ran w_scan and it found channels!

I tried the 4.19.0-14 (debian 10.8) and 4.19.0-9 (debian 10.9 kernel on my current system with no success.
I wanted to try the debian 10.6 kernel 4.19.0-11 but no headers are found in the apt.

I'll try a debian 10.9 live cd for a sanity check then bisect live cds and see where the issue started happening.

Its seems like kernel, driver or software.

For the driver: cx23885

Git history https://github.com/torvalds/linux/tree/master/drivers/media/pci/cx23885 shows there was some changes 5 months ago.. I dont see the debian kernel git I only found the changelog here: https://salsa.debian.org/search?utf8=%E2%9C%93&search=cx23885&group_id=2107&project_id=18670&scope=&search_code=true&snippets=false&repository_ref=master&nav_source=navbar

    (1-5/5)