Project

General

Profile

Compiling TVheadend

Added by Bapak Ireng 5 months ago

Hi,

I just upgraded my DEBIAN Installation from DEBIAN 9 (Stretch) to DEBIAN10 (Buster) and wated to compile tvheadend one more time on the new system.

Installing the prerequisits resulted in the following dialogs:

le-dev libavresample-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
libavahi-client-dev ist schon die neueste Version (0.7-4+b1).
build-essential ist schon die neueste Version (12.6).
bzip2 ist schon die neueste Version (1.0.6-9.2~deb10u1).
libavcodec-dev ist schon die neueste Version (7:4.1.4-1~deb10u1).
libavformat-dev ist schon die neueste Version (7:4.1.4-1~deb10u1).
libavresample-dev ist schon die neueste Version (7:4.1.4-1~deb10u1).
libavutil-dev ist schon die neueste Version (7:4.1.4-1~deb10u1).
libswscale-dev ist schon die neueste Version (7:4.1.4-1~deb10u1).
libssl-dev ist schon die neueste Version (1.1.1d-0+deb10u2).
pkg-config ist schon die neueste Version (0.29-6).
wget ist schon die neueste Version (1.20.1-1.1).
zlib1g-dev ist schon die neueste Version (1:1.2.11.dfsg-1).
git ist schon die neueste Version (1:2.20.1-2+deb10u1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
root:serv01:/home/tvheadend4/tvheadend-master/tvheadend >apt install gettext
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
gettext ist schon die neueste Version (0.19.8.1-9).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
root:serv01:/home/tvheadend4/tvheadend-master/tvheadend >apt install cmake
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
cmake ist schon die neueste Version (3.13.4-1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
root:serv01:/home/tvheadend4/tvheadend-master/tvheadend >apt install libiconv-hook-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
libiconv-hook-dev ist schon die neueste Version (0.0.20021209-11).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
root:serv01:/home/tvheadend4/tvheadend-master/tvheadend >apt install liburiparser-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
liburiparser-dev ist schon die neueste Version (0.9.1-1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
root:serv01:/home/tvheadend4/tvheadend-master/tvheadend >apt install debhelper libcurl4-gnutls-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
libcurl4-gnutls-dev ist schon die neueste Version (7.64.0-4).
debhelper ist schon die neueste Version (12.1.1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

It showed me, that all required software was installed und up to date !

Issuing ./configure resulted into the following output :

Checking support/features
checking for cc execinfo.h ... ok
checking for cc -mmmx ... ok
checking for cc -msse2 ... ok
checking for cc -Wunused-result ... ok
checking for cc -fstack-protector ... ok
checking for cc -fstack-protector-strong ... ok
checking for cc -fstack-check ... ok
checking for cc -fPIE ... ok
checking for cc strlcat ... fail
checking for cc strlcpy ... fail
checking for cc fdatasync ... ok
checking for cc getloadavg ... ok
checking for cc atomic32 ... ok
checking for cc atomic64 ... ok
checking for cc atomic_time_t ... ok
checking for cc atomic_ptr ... ok
checking for cc bitops64 ... ok
checking for cc lockowner ... ok
checking for cc qsort_r ... ok
checking for cc stime ... ok
checking for cc gmtoff ... ok
checking for cc recvmmsg ... ok
checking for cc sendmmsg ... ok
checking for cc libiconv ... fail
^ using build-in glibc iconv routines
checking for cc ifnames ... ok
checking for cc cclang_threadsan ... fail
checking for py module gzip ... ok
checking for pkg-config ... ok
checking for xgettext ... ok
checking for msgmerge ... ok
checking for gzip ... ok
checking for bzip2 ... ok
checking for pkg openssl ... ok (detected 1.1.1d)
checking for cc linux/dvb/version.h ... ok
checking for pkg zlib ... ok (detected 1.2.11)
checking for pkg libpcre2-8 ... ok (detected 10.32)
checking for pkg liburiparser ... ok (detected 0.9.1)
checking for pkg avahi-client ... ok (detected 0.7)
checking for cmake ... ok
checking for cc -lstdc++ ... ok
checking for pkg libva >=0.38.0 ... ok (detected 1.4.0)
checking for pkg libva-x11 >=0.38.0 ... ok (detected 1.4.0)
checking for pkg libva-drm >=0.38.0 ... ok (detected 1.4.0)
checking for cc sys/inotify.h ... ok
checking for cc inotify_init1 ... ok
checking for cc dvbcsa/dvbcsa.h ... ok
checking for cc -ldvbcsa ... ok
fetching dvb-scan files ... ok
checking for cc epoll_create1 ... ok
checking for pkg dbus-1 ... ok (detected 1.12.16)

Compiler:
Using C compiler: cc
Using LD flags: -ldvbcsa
Build for arch: x86_64

Binaries:
Using PYTHON: python
Using GZIP: gzip
Using BZIP2: bzip2

Options:
pie yes
ccdebug no
cardclient yes
cwc yes
cccam yes
capmt yes
constcw yes
linuxdvb yes
satip_server yes
satip_client yes
hdhomerun_client yes
hdhomerun_static yes
iptv yes
tsfile yes
dvbscan yes
timeshift yes
trace yes
avahi yes
zlib yes
libav yes
ffmpeg_static yes
libx264 yes
libx264_static yes
libx265 yes
libx265_static yes
libvpx yes
libvpx_static yes
libtheora yes
libtheora_static yes
libvorbis yes
libvorbis_static yes
libfdkaac no
libfdkaac_static no
libopus yes
libopus_static yes
nvenc no
vaapi yes
mmal no
omx no
inotify yes
epoll yes
pcre no
pcre2 yes
uriparser yes
ccache no
tvhcsa yes
bundle no
pngquant no
kqueue no
dbus_1 yes
android no
gtimer_check no
slow_memoryinfo no
libsystemd_daemon no
pcloud_cache yes
ddci yes
cclang_threadsan no
gperftools no
execinfo yes
mmx yes
sse2 yes
W_unused_result yes
f_stack_protector yes
f_stack_protector_strong yes
f_stack_check yes
f_PIE yes
fdatasync yes
getloadavg yes
atomic32 yes
atomic64 yes
atomic_time_t yes
atomic_ptr yes
bitops64 yes
lockowner yes
qsort_r yes
stime yes
gmtoff yes
recvmmsg yes
sendmmsg yes
ifnames yes
py_gzip yes
bin_pkg_config yes
bin_xgettext yes
bin_msgmerge yes
bin_gzip yes
bin_bzip2 yes
ssl yes
linuxdvbapi yes
linuxdvb_ca yes
upnp yes
bin_cmake yes
stdcpp yes
libogg_static yes
hwaccels yes
inotify_h yes
inotify_init1 yes
dvbcsa yes
epoll_create1 yes
mpegts yes
mpegts_dvb yes

Packages:
openssl 1.1.1d
zlib 1.2.11
libpcre2-8 10.32
liburiparser 0.9.1
avahi-client 0.7
libva 1.4.0
libva-x11 1.4.0
libva-drm 1.4.0
dbus-1 1.12.16

Installation paths:
Prefix: /usr/local
Binaries: ${prefix}/bin
Libraries: ${prefix}/lib
Data files: ${prefix}/share
Man pages: ${datadir}/man

Final Binary:
/home/tvheadend4/tvheadend-master/tvheadend/build.linux/tvheadend

So far so good !

issuing the make command resulted into no error message!

./Autobuild.sh --> resulted into the following messages:

./Autobuild.sh

Auf Branch master
Ihr Branch ist auf demselben Stand wie 'origin/master'.

nichts zu committen, Arbeitsverzeichnis unverändert
dpkg-buildpackage: Information: Quellpaket tvheadend
dpkg-buildpackage: Information: Quellversion 4.3-1857~g221c29b40
dpkg-buildpackage: Information: Quelldistribution unstable
dpkg-buildpackage: Information: Quelle geändert durch Andreas Öman <>
dpkg-buildpackage: Information: Host-Architektur amd64
dpkg-source --before-build .
dpkg-checkbuilddeps: Fehler: Nicht erfüllte Bauabhängigkeiten: python-requests
dpkg-buildpackage: Warnung: Bauabhängigkeiten/-konflikte nicht erfüllt; Abbruch
dpkg-buildpackage: Warnung: (Verwenden Sie -d, um sich darüber hinwegzusetzen.)

However, no .deb package was created !

Python 2.7 and Python 3.0 are both installed onto the system !

Your answer & guidance is highly appreciated !

regards, ireng


Replies (6)

Compiling TVheadend - II - Added by Bapak Ireng 5 months ago

Thank you very much for your adviuce !

I went step by step through that manual....however the error still remains !

RE: Compiling TVheadend - Added by saen acro 5 months ago

python-requests

is it installed?

RE: Compiling TVheadend - Added by Bapak Ireng 5 months ago

Now !

./Autobuild.sh is working......

RE: Compiling TVheadend - Added by Bapak Ireng 5 months ago

and build the requested package !!!

many, many Thanks for your valuable advice !

I really appreciate it !

Best regards, Bapak ireng

RE: Compiling TVheadend - Added by john smith 2 months ago

Thank you very much for your advice ! [[https://get-tubemate.in]] [[https://get-mobdro.com]]

    (1-6/6)