Project

General

Profile

AVM FRITZ!WLAN Repeater DVB-C

Added by gary tan over 3 years ago

I'm looking to get a cable equivalent version of sat>ip and am wondering how the AVM FRITZ!WLAN Repeater DVB-C performs.

Hdhomerun devices are too expensive (4 tuner) or not available anymore (2 tuner). So just wondering how the fritz device is now performing and what if any issues still remain. I see a bug has just been closed by Jaroslav.


Replies (22)

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Steve O over 3 years ago

Hey Gary,

I also just saw the bug has been closed. I will report back after trying the current build from master.

With the previous patch provided in the bugtrace everything was running very smoothly for me already. With obtaining a second IP via an alias both tuners can be used simultaneously. The only slight issues I encountered are WIFI reception problems (sometimes the image gets blocky for a second if somebody is walking next to the access point) and rather slow channel switching times in kodi compared to a tv's build in tuner.

I might write a short tutorial on how to set up the device after testing the latest build.

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Steve O over 3 years ago

So far it is working nicely for me.

For configuration there are two different options:
1. Configure the AVM as IPTV source: https://discourse.osmc.tv/t/howto-tvheadend-setup-of-ip-tv-with-osmc-and-the-avm-fritz-wlan-repeater-dvb-c/8471
However, this only enables the use of one tuner

2. Configure the AVM as a SATIP server:
The device apparently is not compatible to the full SATIP protocol, but the developers were nice enough to implement a number of workarounds.

My tvheadend is running on Ubuntu 14.04, you need to add the repository for the master builds (find them under downloads on this webpage). Minimum version is: HTS Tvheadend 4.1-543~g75f4f0d.
Following steps are/might be needed:

a) Not sure if this is still necessary:
open command line

Stop running service:

sudo service tvheadend stop

Modify startup options: with discovery option enabled (see https://github.com/tvheadend/tvheadend/pull/638):

sudo nano /etc/default/tvheadend

at the end of the file change the options (add the correct IP address for the DVB-C repeater):

TVH_ARGS="--satip_xml http://your.box.ip.address:49000/satipdesc.xml" 

Start running service:

sudo service tvheadend start

b) Now both tuners should be visible once you login via the web interface. If you choose not to configure an IP alias (explained in c), you need to disable one of the tuners.
Make sure that "fast input switch" is disabled. Set "next tune delay" to something not too low (I have it set to 100) - if sometimes channel switching is not working in kodi on the first try, you need to increase it. I also checked "Force teardown delay".

Now create a network, add it to the tuners (double check that the network is selected for the tuner) and let it scan. It will lead to a lot of services (also encrypted channels are listed - of course you can't receive them), so you will face a lot of sorting work (took me more than an hour to select the channels I needed).

After mapping the channels, you should be fine. EPG will be received OTA.

c) If you want to use both tuners, you need to have a different IP address for each tuner. Fortunately, in Ubuntu you can configure this with a single adapter.

open command line

Find out which adapter you are using and the IP range:

ifconfig

Output for my configuration was:

wlan1     Link encap:Ethernet  HWaddr abcd
          inet addr:192.168.1.101
     +extra stuff

Edit the network configuration to add more IP addresses:

sudo nano /etc/network/interfaces

At the bottom of the file add 2 more entries:

auto wlan1:1
iface wlan1:1 inet static
address 192.168.1.5
netmask 255.255.255.0
broadcast 192.168.1.255

auto wlan1:2
iface wlan1:2 inet static
address 192.168.1.6
netmask 255.255.255.0
broadcast 192.168.1.255

Make sure to replace the "192.168.1."-part with your IP range and select 2 IP addresses which do not conflict with your DHCP. Also change the "wlan1" with your adapter name.

Restart the computer.

Login to tvheadend webinterface and set for each tuner one of the alias-IPs (Tuner bind IP address). In my case it was 192.168.1.6 and 192.168.1.5. Double check if the configuration is saved properly and enable the second tuner. Also set both tuners to the same network. Restart to be sure.

When adding both tuners to TVH make sure not to use the FritzApp anymore for watching TV, as it will then "steal" a tuner from TVH (same goes for watching directly via the rtsp links in VLC for example). Use for example the TVHclient App for android in combination with VLC and kodi HTS to have TVH managing the tuners.

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Simon Hörrle over 3 years ago

Thanks for your Instructions :-)
I looked for an easy way for recording since I got my AVM DVB-C Repeater.
I configured my Ubuntu Server with TvHeadend 4.0.7 Stable with Method 1: https://discourse.osmc.tv/t/howto-tvheadend-setup-of-ip-tv-with-osmc-and-the-avm-fritz-wlan-repeater-dvb-c/8471

But now, every time I try to record something I get a mesage like this in the TVHeadend System Log:
2015-11-01 13:28:11.000 subscription: 0001: No input source available for subscription "DVR: Mit Herz und Hammer" to channel "ZDF"

Did someone have any idea or hint for me what I can do, to make recording streams working?
THX in advance

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Steve O over 3 years ago

Hello Simon,

with the IPTV-method you need to make sure you tell tvheadend to use only one tuner. I never tried it though.

The tutorial is not written by me but by a user in a german forum:
http://www.ip-phone-forum.de/showthread.php?t=280394

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Simon Hörrle over 3 years ago

Thanks for your reply Steve.
After some trial and error I managed to get it work.
The problem occurs because of a too small MaxTimeout in the IPTV Source Settings.
After I set this value to "15" the Problem disapeared and everything seems to work eine now.

Thanks anyway ;-)

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Micha C. over 3 years ago

SATIP server works great...the only issue is channel switch took so long up to 4-5 sek
a look in tvheadend backend shows every channel switch use a other tuner

for example channel a - tuner0 --> channel b - tuner1 --> channel c - tuner0 and so on

is there a way to change this? tuner priority doesn't help

i also have an dvb-c usb device with single tuner connected where the delay is much better (1-2 sek)

thx

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Steve O over 3 years ago

Hello Micha,

I am afraid this is a limitation of the device - subscribing to a channel has a certain delay. For me tuning to a channel from kodi takes usually something like 2 s.

The behaviour of the backend is in my opinion correct - connecting to the second tuner should be faster than disconnecting the first and connecting it again. Note that fast channel switches (which do not require disconnecting from the tuner before tuning to a different channel) are not supported by the firmware of the device.

The USB device does probably not have limitations like that and therefore (also because of avoiding the ethernet) is much faster.

I doubt that the speed may be improved by any updates on the tvheadend side - the developers were very nice to implement workarounds for many limitations in the firmware of the Fritz tuner. Maybe you can write an e-mail to AVM and suggest they correctly implement the SATIP protocol in the firmware of the device - however I assume that they will not provide further updates to improve support.

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Th. Raddatz over 3 years ago

I try to follow Steve's description to configure the SATIP server. But unfortunately I cannot find any way to specify the TVH_ARGS property. My configuration is a DS216Play with TVheadend 4.1.1233.

I tried to specify TVH_ARGS in file 'tvheadend' at various locations in the file system with no success.

All I managed was that TVheadend created an adapter file for satip when I started TVheadend from the command line. But I cannot make it work when starting TVheadend from the Synology package manager.

Any ideas?

Thanks,

Thomas.

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Th. Raddatz over 3 years ago

I found the 'start-stop-status' script in '/var/packages/tvheadend-testing/scripts/' and added the '--satip_xml' parameter to the '${TVHEADEND}' statement in procedure start_daemon().

After restarting TVheadend the two AVM tuners show up in 'Configuration -> DVB Inputs -> TV adapters'. I disabled 'fast input switch' on the FRITZ!WLAN Repeater DVB-C node and I also set 'next tune delay' to 100 for both tuners and checked 'force tear down delay' as suggested. Then I created a DVB-C network at 'Configuration -> DVB Inputs -> Network' and assigned it to both tuners.

But now nothing happens when I select 'Force scan' for the selected network.

Any ideas?

Thomas.

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Simon Hörrle over 3 years ago

Have you set "idle scan muxes" to enabled and have selected a List with pre-defined Muxes (in my case "Germany: de-Unitymedia").
For me that does the trick. :-)

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Th. Raddatz over 3 years ago

Now I am a small step closer to the end, hopefully.

I checked 'idle scan muxes' and I also selected 'Germany: de-Unitymedia' and afterwards I got a muxes and services. Then disabled all encrypted services and let tvheadend map the remaining ones.

Now I can view a couple of TV channels. I did not yet test all mapped channels.

The current problem is that tvheadend still cannot use both dvb-c tuners of the AVM DVB-C repeater, although I configured a virtual LAN adapter and although I assigned different IP addresses to both TV adapters in tvheadend.

My network configuration looks like that:

ifcfg-eth0

DEVICE=eth0
BOOTPROTO=static
ONBOOT=yes
BRIDGE="" 
IPADDR=192.168.1.222
NETMASK=255.255.255.0

ifcfg-eth0:0

DEVICE=eth0:0
BOOTPROTO=static
ONBOOT=yes
BRIDGE="" 
IPADDR=192.168.1.223
NETMASK=255.255.255.0

Tuner #1 is assigned to 192.168.1.222 and tuner #2 is assigned to 192.168.1.223.

Can you use both tuners? I always get "Tuning failed" when trying to use both tuner simultaneously.

I almost forgot to mention that the second problem is, that I get error message "No assigned adapters" for some TV channels, e.g. "ZDF SD", "ZDF HD", "ServusTV HD" etc.

Thomas.

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Th. Raddatz over 3 years ago

Eventually I managed it to get both tuners working. The problem was that the alias network interface for the second IP address was lost after a restart of the Synology NAS.

For the "No assigned adapters" problem I had to assign the channel by hand to a service.

I consider writing a tutorial when I setup my NAS from the beginning to get rid of all unnecessary stuff.

Thomas.

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Steve O over 3 years ago

Hello Thomas,

good to hear you managed to get it to work! The "no assigned adapters" issue might arise from an outdated mux list in tvheadend - if you have tvheadend search for channels and map them with "check availability" on it should work.

Maybe I should add that the tutorial is valid for ubuntu - different distributions might of course have different ways of managing the configuration files.

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Simon Hörrle over 2 years ago

Today I got a new FRITZ!Box 6490 Cable with 4 integated Tuners.
Seems that the method mentioned here doesn't work with the box.
Neither with TVH_ARGS="--satip_xml http://192.168.178.1:49000/satipdesc.xml" nor with TVH_ARGS="--satip_xml http://192.168.178.254:49000/satipdesc.xml" it can find any tuners :(

TVHeadend Version: 4.1-2236~g817f67e~xenial
FRITZ!OS: 06.62

..::EDIT::..
Got it!
I have to use fritz.nas instead of a IP-Adress. Don't know why, but now it works fine :-)

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Micha C. over 2 years ago

You have to use the NAS ip that's correct ;)

here my systemd service

[Unit]
Description=tvheadend
After=network.target
#Wants=oscam.service
#After=oscam.service

[Service]
Type=forking
PIDFile=/run/tvheadend.pid
ExecStart=/usr/bin/tvheadend -f -p /run/tvheadend.pid -C -u hts -g video --satip_xml http://192.168.0.254:49000/satipdesc.xml
ExecStop=/usr/bin/rm /run/tvheadend.pid
Restart=always
RestartSec=5

[Install]
WantedBy=multi-user.target

And here some .png's with the Settings i figured out for TV Headend

I use it with Kodi and the Channel switching works like a charm. ;)

PS.

The Setting i add for the interfaces file in /etc/network

  1. eth0:4 - AVM DVB-C Tuner #1 loop
    iface eth0:4 inet static
    address 192.168.0.96
    netmask 255.255.255.0
    broadcast 192.168.0.255
  1. eth0:3 - AVM DVB-C Tuner #2 loop
    iface eth0:3 inet static
    address 192.168.0.97
    netmask 255.255.255.0
    broadcast 192.168.0.255
  1. eth0:1 - AVM DVB-C Tuner #3 loop
    iface eth0:1 inet static
    address 192.168.0.98
    netmask 255.255.255.0
    broadcast 192.168.0.255
  1. eth0:2 - AVM DVB-C Tuner #4 loop
    iface eth0:2 inet static
    address 192.168.0.99
    netmask 255.255.255.0
    broadcast 192.168.0.255

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Simon Hörrle over 2 years ago

Thanks again, it's working pretty well for me now too. :)

But I had to disable ipv6 support in sysctl.conf.
Otherwise TVHeadend wasn't able to subscribe to a mux.

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Martin Bachmann over 2 years ago

Hi,

wow - finally everything is working on my Synology DS112 together with my new FritzBox Cable 6490. Thanks for all the explanations in this blog! Only a few things missing for me - I have to add a script to re-create the virtual IP addresses in case the Synology reboots (I red more here: [[https://linuxconfig.org/configuring-virtual-network-interfaces-in-linux ).
One thing that is still really confusing me is the following observation:
- I added 4 different IP addresses to the four tuners in the 'TV-Adapter' setting, as indicated in the four screenshots above (they were really helpful)
- Now in the FritzBox UI - 'DVB-C' - 'Live TV' I can verify which tuner is currently working
- Now here is a real mix - the IP-addresses assigned earlier in 'TV-Adapter' do not match to the tuners. It looks as if the FritzBox (or TVHeadend) is selected the tuners from top-down, which is currently empty
- For example in 'Status' -> 'Abbonements' the Tuner #4 is shown, but in FritzBox it is Tuner #1.

Not sure if this is relevant?

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Steve O over 2 years ago

Good to hear it is working for you! :)

The assignment of subscriptions to the tuners is done be the Fritz device - it should not cause any problems.

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Ruth Server over 2 years ago

The repeater works great.
And this setup works also for the AVM Fritz!Box cable 6490.

But any idea how to use the 6490 AND the repeater together? Or what about having more than one repeater?

With "--satip_xml http://192.168.0.254:49000/satipdesc.xml" it's only possible to add one device.
And TVH uses the given IP.

So if the device cannot be found via autodiscover it's needed to add an option to add more than one device manually.

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Anthony Thomas over 2 years ago

Ruth Server wrote:

The repeater works great.
And this setup works also for the AVM Fritz!Box cable 6490.

But any idea how to use the 6490 AND the repeater together? Or what about having more than one repeater?

With "--satip_xml http://192.168.0.254:49000/satipdesc.xml" it's only possible to add one device.
And TVH uses the given IP.

So if the device cannot be found via autodiscover it's needed to add an option to add more than one device manually.

You can add multiple satip servers by just adding another to the startup argument eg

"--satip_xml http://192.168.0.254:49000/satipdesc.xml --satip_xml http://otherdeviceIP:49000/satipdesc.xml "

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Kurt M. about 2 years ago

Hi,

first of all, thank you for writing this tutorial and participating.
For my system (Synology DS716+II) the key was to add the parameter "--satip_XMl" to "start-stop-status" script.

Everything worked fine, even with oscam. But after 1.5 days everything broke together without touching anything. No EPG, no tuning at all ...

1.) I figured out that there are no tuner settings and I also get a "RTSP cmd error 7". Here is the log:
-------------
2017-01-31 08:15:59.523 satip: Triggered new server discovery
2017-01-31 08:16:21.533 satips: SAT>IP server announces an empty tuner list to a client 192.168.1.39 (missing tuner settings - global config)
2017-01-31 08:16:25.485 http: 192.168.1.39: using ticket 8E4E27B1D79DBF94400D69D7B14F400AB45074AA for /stream/channel/2d1b76bf14e2afa299e2f37c247b46b1
2017-01-31 08:16:25.485 mpegts: 794MHz in avm_dvbc - tuning on SAT>IP DVB-C Tuner #1 (192.168.1.254)
2017-01-31 08:16:25.486 subscription: 0006: "HTTP" subscribing on channel "BBC HD", weight: 100, adapter: "SAT>IP DVB-C Tuner #1 (192.168.1.254)", network: "avm_dvbc", mux: "794MHz", provider: "Unitymedia", service: "BBC HD", profile="pass", hostname="192.168.1.39", client="VLC/2.2.4 LibVLC/2.2.4"
2017-01-31 08:16:25.488 satip: SAT>IP DVB-C Tuner #1 (192.168.1.254) - RTSP cmd error 7 (Unknown error -7) [8-500]
2017-01-31 08:16:27.485 subscription: 0006: service instance is bad, reason: Tuning failed
2017-01-31 08:16:27.486 mpegts: 794MHz in avm_dvbc - tuning on SAT>IP DVB-C Tuner #2 (192.168.1.254)
2017-01-31 08:16:27.486 subscription: 0006: "HTTP" subscribing on channel "BBC HD", weight: 100, adapter: "SAT>IP DVB-C Tuner #2 (192.168.1.254)", network: "avm_dvbc", mux: "794MHz", provider: "Unitymedia", service: "BBC HD", profile="pass", hostname="192.168.1.39", client="VLC/2.2.4 LibVLC/2.2.4"
2017-01-31 08:16:27.488 satip: SAT>IP DVB-C Tuner #2 (192.168.1.254) - RTSP cmd error 7 (Unknown error -7) [8-500]
2017-01-31 08:16:29.485 subscription: 0006: service instance is bad, reason: Tuning failed
2017-01-31 08:16:30.486 subscription: 0006: "HTTP" unsubscribing from "BBC HD", hostname="192.168.1.39", client="VLC/2.2.4 LibVLC/2.2.4"
-------------

As you can see in the attached screenshot: Settings are saved. To change and save it again doesn't help.

2.) The log file /var/messages/ gave me this response:
-------------
2017-01-30T23:18:55+01:00 nas tvheadend[3703]: cwc: Can not descramble service "sixx HD", access denied (seqno: 55514 Req delay: 145 ms) from cwc-192.168.1.50-15000-098E
2017-01-31T04:29:02+01:00 nas tvheadend[3703]: cwc: read error 104 (Connection reset by peer)
2017-01-31T04:29:13+01:00 nas tvheadend[3703]: cwc: read error 110 (Connection timed out)
2017-01-31T08:09:23+01:00 nas tvheadend[32572]: satips: use --satip_bindaddr parameter to select the local IP for SAT>IP
2017-01-31T08:09:23+01:00 nas tvheadend[32572]: satips: using Google lookup (might block the task until timeout)
2017-01-31T08:09:25+01:00 nas tvheadend[32572]: satips: SAT>IP server announces an empty tuner list to a client 192.168.1.52 (missing tuner settings - global config)
2017-01-31T08:09:27+01:00 nas tvheadend[32572]: satips: SAT>IP server announces an empty tuner list to a client 192.168.1.39 (missing tuner settings - global config)
2017-01-31T08:16:21+01:00 nas tvheadend[32572]: satips: SAT>IP server announces an empty tuner list to a client 192.168.1.39 (missing tuner settings - global config)
2017-01-31T08:16:25+01:00 nas tvheadend[32572]: satip: SAT>IP DVB-C Tuner #1 (192.168.1.254) - RTSP cmd error 7 (Unknown error -7) [8-500]
2017-01-31T08:16:27+01:00 nas tvheadend[32572]: subscription: 0006: service instance is bad, reason: Tuning failed
2017-01-31T08:16:27+01:00 nas tvheadend[32572]: satip: SAT>IP DVB-C Tuner #2 (192.168.1.254) - RTSP cmd error 7 (Unknown error -7) [8-500]
2017-01-31T08:16:29+01:00 nas tvheadend[32572]: subscription: 0006: service instance is bad, reason: Tuning failed
-------------

3.) After that "break down" it seems that there is no tuning at all possible with the 6490. Even if I try to stream it directly from the fritz.box interface.
There is also the error message "no channels available. Please check your cables and search for channels." ("Es sind keine Sender verfügbar. Bitte überprüfen Sie Ihre Kabel und starten Sie den Sendersuchlauf.") - see attached screenshot.
Even though, channels are listed in menu DVB-C on fritz.box. To search again via fritz.box doesn't change anything.

4.) The only fix that helped me was to completely delete tvheadend and start the whole setup process from the beginning. But I won't do that every 1.5 days ... :(

Can anybody help?

tvh_global_settings.png (52.2 KB) tvh_global_settings.png global tuner settings
tvh_tuner_settings.png (52.1 KB) tvh_tuner_settings.png tuner settings
tvh_status.png (11.8 KB) tvh_status.png TVH status
fb-status.png (34.2 KB) fb-status.png FritzBox 6490

RE: AVM FRITZ!WLAN Repeater DVB-C - Added by Steve O about 2 years ago

Hello Kurt,

are you sure the issue is caused by tvheadend? Since I was setting mine up a year ago it is running without problems 24/7. If I take a look at the Fritz-event logs it shows sometimes some errors like "03.04.17 14:03:48 Der TV-Tuner wurde mit Fehlergrund 1 zurückgesetzt.".

I assume there are still some bugs in the Fritz firmware. Were you able to watch TV using the Fritz-App when tvheadend could not connect?

    (1-22/22)