Project

General

Profile

How to record on internal NTFS drive? | Trusty 14.04

Added by Big Wille over 5 years ago

Hi

since few days I try unsuccessfully to record on my internal NTFS drive. I can record without errors to directory "/home/hts" or if I execute the following command I can also record to "/home/user/Test":
"sudo chown -cR hts:video /home/user/Test/"

I don't understand why it's not working to record to my NTFS drive.

These are my settings, permissions and errrors:

fstab:
UUID=7406A3AF27E9C5E9 /media/user/TMP ntfs-3g rw,auto,users,uid=hts,gid=video,umask=000,fmask=000,dmask=000 0 0

folder permission:
drwxrwxrwx 1 hts video 0 Jul 2 18:59 PVR

errors:
2015-07-02 19:01:05.270 dvr: "Radsport: 102. Tour de France 2015" on "Eurosport Deutschland" recorder starting
2015-07-02 19:01:05.271 mpegts: 12226.5H in ASTRA - tuning on Conexant CX24120/CX24118 : DVB-S #0
2015-07-02 19:01:05.271 subscription: 0005: "epggrab" unsubscribing
2015-07-02 19:01:05.412 subscription: 0007: "DVR: Radsport: 102. Tour de France 2015" subscribing on channel "Eurosport Deutschland", weight: 300, adapter: "Conexant CX24120/CX24118 : DVB-S #0", network: "ASTRA", mux: "12226.5H", provider: "SES Astra", service: "Eurosport Deutschland", profile="pass"
2015-07-02 19:01:05.776 settings: Unable to create dir "/media/user/TMP": Permission denied
2015-07-02 19:01:05.776 dvr: Recording error: "Radsport: 102. Tour de France 2015": Unable to create directories
2015-07-02 19:01:06.053 settings: Unable to create dir "/media/user/TMP": Permission denied
2015-07-02 19:01:06.053 dvr: Recording error: "Radsport: 102. Tour de France 2015": Unable to create directories
2015-07-02 19:01:34.216 subscription: 0007: "DVR: Radsport: 102. Tour de France 2015" unsubscribing from "Eurosport Deutschland"
2015-07-02 19:01:34.217 dvr: "Radsport: 102. Tour de France 2015" on "Eurosport Deutschland": End of program: Time missed

Maybe someone can help me?

Sorry for my bad English.

Many thanks in advance.


Replies (6)

RE: How to record on internal NTFS drive? | Trusty 14.04 - Added by Mihail sovaby over 5 years ago

TMP mount point cannot touch

service tvheadend stop

edit fstab
UUID=7406A3AF27E9C5E9 /media/user ntfs-3g rw,auto,users,uid=hts,gid=video,umask=000,fmask=000,dmask=000 0 0

  1. mount /media/user
  2. chown -R hts:hts /media/user
  3. service tvheadend start

tvheadend create /media/user/ TMP on ntfs partition

RE: How to record on internal NTFS drive? | Trusty 14.04 - Added by Big Wille over 5 years ago

Thanks for your help. It works.

I'm not quite sure what the error was, as I have a second PC with the same setup and there the record did not work out the same.
- chown -R hts:hts /media/user

I think my mistake was that the mount point must own by the group hts.

RE: How to record on internal NTFS drive? | Trusty 14.04 - Added by Mihail sovaby over 5 years ago

Your mistake is that TMP is a mount point
TMP is a mount point! Сan not be touched.

RE: How to record on internal NTFS drive? | Trusty 14.04 - Added by Big Wille over 5 years ago

Sorry for my late reply, I was in getaway.

I have not done your proposal "chown -R hts HTS /media/user", otherwise all my mount point would own by hts?

I could record with my settings, but all files and folders owned hts and then I had problems with rsync.

You've correctly identified the mount point /media/user/tmp. The recordings should be included in the directory /media/user/tmp/Mediathek/Recordings/PVR.

Can you please explain again for me as dummy, where do I have to do something, so I can record to the above folder and all the files nevertheless still be mine.
Could it be easier if I change the Tvheadend user data to my own user?

Thank you in advance.

RE: How to record on internal NTFS drive? | Trusty 14.04 - Added by Mihail sovaby over 5 years ago

Ок =)

Sample
1 mkdir /mnt/ntfs
2 mount /dev/sdaХ то /mnt/ntfs

ntfs = mount point - Who owns it does not matter

If I want to change this point, you'll get an error.
Tvheadend In your case it would change !
It was necessary to create a deeper directory is not a mount point.
That's the whole problem!
Sorry for my english translation by Google =)

RE: How to record on internal NTFS drive? | Trusty 14.04 - Added by Big Wille over 5 years ago

Again learned something. I thought that on an ntfs disk permissions cannot set, only as in the fstab or with acl.

Thanks for the information.

    (1-6/6)