Project

General

Profile

TV Channels as radio channels

Added by Normand Leclerc over 7 years ago

Hi,

I managed to get my Hauppauge 2250 working; got services, mapped channels, have an account for EPG data and got that working as well; everything is good..... well... almost....

TVHeadend detected my TV channels as radio channels.... I changed the tags for TV/HDTV, saved the config and everything seemed good but XBMC will map the channels as radio channeld even if they are tagged TV/HDTV.

I guess the channel's type is not linked to the tag..... I didn't have this problem with MythTV so this is indeed TVHeadend related.

I have searched the forum but couldn't find any solution to the problem I am seeing. Looks like I'm not the only one.

Can I force a channel to be TV? Even if I do this manually once, I wouldn't mind (but must be fixed ;) )

tcn


Replies (3)

RE: TV Channels as radio channels - Added by Kevin Reuß about 5 years ago

push

have the same problem with latest stable version. manual workaround would be great!

regards
Kevin

RE: TV Channels as radio channels - Added by Kevin Reuß about 5 years ago

ok, figured it out myself. Remember the service name of the channel, then delete it and create a new channel manually, name it and map it to the correct service and add the correct tags.
After that Kodi will see it as a tv channel.
I hope i helped a few people withe the same issue :)

regards
Kevin

RE: TV Channels as radio channels - Added by Mark Clarkstone about 5 years ago

There's a type override.

Please ignore the gimp ui :p

You can use multi-select and change the detected type. Select the services (use Ctrl or Shift (to select a range)), while the channels are highlighted press the [Edit] button, then using the edit dialog check the checkbox next to the "Override type" field, select the desired override and save.

Note: if you can't see the override option, you may need to change the view level to expert or add the column (mouse over a column, click the arrow -> Columns -> Override type.

Hope this helps.

    (1-3/3)