Project

General

Profile

Signal sometimes interrupted on this one channel

Added by M J about 3 years ago

If I watch it live, sometimes the video just freezes for a few seconds, then comes back. If recording, it skips ahead several seconds (obviously from the same effect). It only happens on 1 channel. I've considered and eliminated these possibilities:
1. Weak signal: actually, this signal is the strongest one I receive. Even if I used rabbit ears it's hard not to get the signal and I use an outdoor antenna.
2. Required more throughput than my system can handle: that seems unlikely, because it is the only channel that is 720p. I often record from several 1080i channels and never have this problem.
3. Hardware: I've connected the tuner to my Linux computer and watched for a long time. Never had a problem.

All I can say about the channel is:
  • ATSC
  • Services tab has it as 539.028MHz
  • Real channel 25, virtual channel 4.1
  • The attached screen caps for the Muxes tab and Services tab on the web interface.

The tuner is a Hauppauge WinTV-HVR 955Q. I'm running Kodi 18.4 on Raspbian 10 and Tvheadend 4.2.8.

CBOT.png (102 KB) CBOT.png Screen cat of the Services tab on the web interface
muxes.png (91.1 KB) muxes.png The screen cap for the muxes tab

Replies (2)

RE: Signal sometimes interrupted on this one channel - Added by M J almost 3 years ago

bump
Well here's something interesting: checked out the syslog from last night's 30 minute recording. This is what I got:

Feb 20 18:59:30 dospace tvheadend[795]: dvr: "Concession_12-2020-02-20-19:00" on "CBOT-DT" recorder starting
Feb 20 18:59:30 dospace tvheadend[795]: dvr: About to set stop timer for "Concession_12-2020-02-20-19:00" on "CBOT-DT" at start 1582243200 and original stop 1582245000 and overall stop at 1582245000
Feb 20 18:59:30 dospace tvheadend[795]: mpegts: 539.028MHz in ATSC-T Network - tuning on LG Electronics LGDT3306A VSB/QAM Frontend #0 : ATSC-T #0
Feb 20 18:59:30 dospace tvheadend[795]: subscription: 0017: "DVR: Concession_12-2020-02-20-19:00" subscribing on channel "CBOT-DT", weight: 300, adapter: "LG Electronics LGDT3306A VSB/QAM Frontend #0 : ATSC-T #0", network: "ATSC-T Network", mux: "539.028MHz", service: "OTTAWA CBOT-DT", profile="pass" 
Feb 20 19:00:00 dospace tvheadend[795]: dvr: /home/pi/recordings/Concession_12-2020-02-20-19:00.ts from adapter: "LG Electronics LGDT3306A VSB/QAM Frontend #0 : ATSC-T #0", network: "ATSC-T Network", mux: "539.028MHz", provider: "<N/A>", service: "OTTAWA CBOT-DT" 
Feb 20 19:00:00 dospace tvheadend[795]: dvr:  #  type              lang  resolution  aspect ratio  sample rate  channels
Feb 20 19:00:00 dospace tvheadend[795]: dvr:  1  MPEG2VIDEO              1280x720    ?                                    
Feb 20 19:00:00 dospace tvheadend[795]: dvr:  2  AC3               eng                             ?            ?         
Feb 20 19:00:00 dospace tvheadend[795]: dvr:  3  AC3               und                             ?            ?         
Feb 20 19:02:38 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: MPEG2VIDEO @ #49 Continuity counter error (total 1)
Feb 20 19:02:46 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #52 Continuity counter error (total 1)
Feb 20 19:02:46 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #53 Continuity counter error (total 1)
Feb 20 19:14:05 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: MPEG2VIDEO @ #49 Continuity counter error (total 3)
Feb 20 19:14:05 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #52 Continuity counter error (total 2)
Feb 20 19:14:05 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #53 Continuity counter error (total 2)
Feb 20 19:14:49 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #52 Continuity counter error (total 3)
Feb 20 19:14:49 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #53 Continuity counter error (total 3)
Feb 20 19:17:02 dospace CRON[1201]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
Feb 20 19:24:34 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: MPEG2VIDEO @ #49 Continuity counter error (total 4)
Feb 20 19:24:34 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #52 Continuity counter error (total 4)
Feb 20 19:24:34 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #53 Continuity counter error (total 4)
Feb 20 19:27:21 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: MPEG2VIDEO @ #49 Continuity counter error (total 6)
Feb 20 19:27:21 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #53 Continuity counter error (total 6)
Feb 20 19:27:21 dospace tvheadend[795]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #52 Continuity counter error (total 6)
Feb 20 19:30:00 dospace tvheadend[795]: subscription: 0017: "DVR: Concession_12-2020-02-20-19:00" unsubscribing from "CBOT-DT" 
Feb 20 19:30:00 dospace tvheadend[795]: dvr: "Concession_12-2020-02-20-19:00" on "CBOT-DT": End of program: Completed OK

And I think those errors coincide w/problems I experienced.

RE: Signal sometimes interrupted on this one channel - Added by M J almost 3 years ago

So this time I tried turning debugging on and got:

Mar  7 14:14:10 dospace tvheadend[764]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT Transport error indicator (total 1)
Mar  7 14:14:10 dospace tvheadend[764]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: MPEG2VIDEO @ #49 Continuity counter error (total 1)
Mar  7 14:14:10 dospace tvheadend[764]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: MPEG2VIDEO @ #49: Invalid start code 0d:98:83
Mar  7 14:14:10 dospace tvheadend[764]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #53 Continuity counter error (total 1)
Mar  7 14:14:10 dospace tvheadend[764]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #53: Invalid start code 03:35:e7
Mar  7 14:14:10 dospace tvheadend[764]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #52 Continuity counter error (total 1)
Mar  7 14:15:55 dospace tvheadend[764]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: MPEG2VIDEO @ #49 Continuity counter error (total 14)
Mar  7 14:15:55 dospace tvheadend[764]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #52 Continuity counter error (total 3)
Mar  7 14:15:55 dospace tvheadend[764]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #53 Continuity counter error (total 4)
Mar  7 14:15:55 dospace tvheadend[764]: tsfix: transport stream MPEG2VIDEO, DTS discontinuity. DTS = 41487499, last = 41209721
Mar  7 14:15:56 dospace tvheadend[764]: tsfix: transport stream AC3, DTS discontinuity. DTS = 41448754, last = 41157874
Mar  7 14:15:56 dospace tvheadend[764]: tsfix: transport stream AC3, DTS discontinuity. DTS = 41448960, last = 41158080
Mar  7 14:16:32 dospace tvheadend[764]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: MPEG2VIDEO @ #49 Continuity counter error (total 15)
Mar  7 14:16:32 dospace tvheadend[764]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #52 Continuity counter error (total 4)
Mar  7 14:16:32 dospace tvheadend[764]: TS: ATSC-T Network/539.028MHz/OTTAWA CBOT-DT: AC3 @ #53 Continuity counter error (total 5)
Mar  7 14:16:32 dospace tvheadend[764]: tsfix: transport stream MPEG2VIDEO, DTS discontinuity. DTS = 44787796, last = 43442452
Mar  7 14:16:32 dospace tvheadend[764]: tsfix: transport stream AC3, DTS discontinuity. DTS = 44743474, last = 43369714
Mar  7 14:16:32 dospace tvheadend[764]: tsfix: transport stream AC3, DTS discontinuity. DTS = 44743680, last = 43369920
Mar  7 14:16:52 dospace tvheadend[764]: subscription: 0016: "127.0.0.1 [ angus | Kodi Media Center ]" unsubscribing from "CBOT-DT", hostname="127.0.0.1", username="127.0.0.1", client="Kodi Media Center" 

Does that say anything new?

    (1-2/2)