tvheadend and kodi lost connection

Added by onder tol almost 3 years ago

Hello world.
i try to install tvheaddend and relative addon in kodi 15.2 (ubuntu 15.10)... but when i activate the TV in kodi settings I have all time the message "lost connection" and the kodi's TV menu don't show.

With other version of ubuntu and kodi I haven't find this problem.
I tried to install two version of tvheadend: "Stable branch - nightly builds" and "Stable branch - official releases" but i have the same problem.

do you have any ideas to resolve this problem?

Thank you


Replies (12)

RE: tvheadend and kodi lost connection - Added by Prof Yaffle almost 3 years ago

Is tvheadend running? Can you access the web interface? Does it show in a ps list?

And is the Kodi addon configured properly, with the IP address (even as loopback), username and password?

RE: tvheadend and kodi lost connection - Added by onder tol almost 3 years ago

tvheaded running and i can access to the interface... but what's the ps list?

This evening I must verify the ip address... user and password I'm, sure!

I will write... soon.

Thank you!

RE: tvheadend and kodi lost connection - Added by Prof Yaffle almost 3 years ago

ps list would be a ps -eaf command on your tvheadend box - it would produce a process list, in which you'd see the tvheadend process if it were running. The fact that you can get into the interface means that it is...

... so it's something else.

RE: tvheadend and kodi lost connection - Added by onder tol almost 3 years ago

Thank you for your support Prof Yaffle... I mistaked the ip address in the addon's configuration... and now the problem is resolved.

RE: tvheadend and kodi lost connection - Added by Prof Yaffle almost 3 years ago

No problem, glad you got it fixed

RE: tvheadend and kodi lost connection - Added by Ben de Boer almost 3 years ago

Hello,

I have the same problem, installed Tvheaddend (3.9.2827~g477feab~trusty)and the relative addon in Kodi 16.0 Beta 2 (Ubuntu 15.10), but when I activate the TV in the Kodi settings there is all time the message "lost connection" and the Kodi's TV menu don't show. In Android (4.2.2) and Windows (10) Kodi 16.0 Beta 2 works fine with Tvheaddend.

Is there also a way to keep (create) the Channels in a group, each time when I start Kodi they are in all channels instead of the group I put them in Kodi?

Is there a newer version of Tvheaddend (3.9.2827~g477feab~trusty)?

Is there a way to have some channels out of my iptv.m3u in Tvheaddend?

Hope someone can help me.

Ben

RE: tvheadend and kodi lost connection - Added by onder tol almost 3 years ago

Hello Ben.
i resolved my problem to entry in the pvr tvheadend settings into kodi: you check if the computer's IP, the tvheadend user and password are correct.

But verify if tvheadend running after reboot... in my situation (ubuntu 15.10 and kodi 15.2) it don't started automatically. I had to force it.
to verify try to access it with " http://localhost:9981 "

bye
Lorenzo

RE: tvheadend and kodi lost connection - Added by Tobias Holm over 2 years ago

Ben de Boer wrote:

...installed Tvheaddend (3.9.2827~g477feab~trusty)and the relative addon in Kodi 16.0 Beta 2 (Ubuntu 15.10), but when I activate the TV in the Kodi settings there is all time the message "lost connection"...

I had a working setup using Kodi 14.2, but after an update through Ubuntus software updater I got Kodi 16.0, and after this tvheadend stopped working... Did you solve your issue? I suspect a downgrade to kodi 14.2 or 15 will solve the tvheadend connection issue, but I don't know how to downgrade kodi... :( I have tvheadend addon v2.2.14 which says "no updates available" if I search for updates.

RE: tvheadend and kodi lost connection - Added by Prof Yaffle over 2 years ago

Define "stopped working"? What version of tvh?

That's the latest PPA version of both Kodi and the pvr.hts addon, I believe, so both should work unless there's a version mismatch with your tvheadend backend.

If you do need to downgrade, sudo apt-cache policy kodi* will list available packages, and sudo apt-get install <package>=<version> will then install a specific version from that list. All subject to packages being available in the PPAs, of course.

RE: tvheadend and kodi lost connection - Added by Tobias Holm over 2 years ago

Thank you for your answer!

When I said "tvheadend" I meant the plugin for kodi. The tvheadend server still works (I have another Ubuntu with Kodi 14.2, and it still works). I use "HTS Tvheadend 3.4.28~geb79aee~trusty" on my backend server.

And by saying "stopped working" I meant my kodi, now version 16.0, gives the error "lost connection" to tvheadend backend.

I tried to downgrade kodi on my Ubuntu, but didn't get it to work. Maybe I should modify the version-number-string in some way?

[email protected]:~$ sudo apt-cache policy kodi*
N: Unable to locate package kodi_crashlog-20160206_080033.log
N: Couldn't find any package by regex 'kodi_crashlog-20160206_080033.log'
[email protected]:~$ sudo apt-cache policy kodi
kodi:
  Installed: 2:16.0~git20160220.1654-final-0wily
  Candidate: 2:16.0~git20160220.1654-final-0wily
  Version table:
 *** 2:16.0~git20160220.1654-final-0wily 0
        500 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu/ wily/main amd64 Packages
        100 /var/lib/dpkg/status
     15.1+dfsg1-3 0
        500 http://se.archive.ubuntu.com/ubuntu/ wily/universe amd64 Packages
[email protected]:~$ sudo apt-get install kodi="15.1+dfsg1-3 0" 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Version '15.1+dfsg1-3 0' for 'kodi' was not found
[email protected]:~$ uname -a
Linux frontend 4.2.0-30-generic #36-Ubuntu SMP Fri Feb 26 00:58:07 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
[email protected]:~$ 

RE: tvheadend and kodi lost connection - Added by Tobias Holm over 2 years ago

ok, found the answer for my system.

DOWNGRADE KODI 16.0 TO 15.2 IN UBUNTU 15.10 INCL TVHEADEND:

$ sudo add-apt-repository ppa:team-xbmc/kodi-old
$ sudo apt-get update
$ apt-cache showpkg kodi
$ sudo apt-get install kodi=2:15.2~git20151101.0902-final-0wily kodi-bin=2:15.2~git20151101.0902-final-0wily
$ sudo apt-get install kodi-pvr-tvheadend-hts=2.1.18-2~wily kodi-pvr-hts=2.1.18-2~wily
$ sudo apt-mark hold kodi kodi-bin kodi-pvr-tvheadend-hts kodi-pvr-hts

RE: tvheadend and kodi lost connection - Added by Prof Yaffle over 2 years ago

I would guess that it's related to a minimum API level. 3.4.x is ancient now, isn't supported and quite likely no longer works with the current addon API. You should really consider upgrading to the current stable - 4.0.8, I think, with 4.2 due "soon". Ish.

It looks from the apt-cache output that the PPA doesn't contain Kodi 15.x - so you'd have to find another source, or compile it yourself...

EDIT

There's an "old" PPA:

http://forum.kodi.tv/showthread.php?tid=261022

Add this PPA and then apt-get update && apt-cache policy kodi will list the 15.2 version; apt-get install kodi=2:15.2~git20151101.0902-final-0wily should install it.

But you'll keep getting the problem over time, as you're locking yourself into unsupported software. Time to upgrade IMO.

(1-12/12)