Project

General

Profile

TVHEADEND -> OSCAM -> CCCAM Server Cline

Added by Robert Meyer about 8 years ago

Hello together,

I am using TV Headened as the TV backend for Openelec/XBMC.
TVHEADEND works pretty good, no problem with the FTA channels, but PAYTV channels couldn be descrambiled.

I have a CCCAM C-Line for a CCCAM Server.

I know I habe to use OSCAM for it.

My oscam.server file looks like that:

[reader]
label = sky de,orf,hd+,srg
enable = 1
protocol = cccam
device = cccam-server.com,12345
user = USER
password = PASS
caid = 1702,1830,0D05,0500,0648
ident = 1702:000000;1830:000000,003411;0D05:000004,000010;0500:023800;0648:000000
group =
cccversion = 2.3.0
cccmaxhops = 1
ccckeepalive = 1
audisabled = 1

How do I have to setup my oscam.conf and how do I habe to configure TVHEADEND, that I can descramble the non FTA channels ?

Do you have any ideas ?

Thanks so far ?

Robert


Replies (6)

RE: TVHEADEND -> OSCAM -> CCCAM Server Cline - Added by Alex . about 8 years ago

Hi,

(Is your question a genericv questionm, or specific for your CCCAM C-Line?)

Did you look at this page, it contains an example of the oscam.conf and oscam.user files.
You will have to adapt for your specific case, but it tells you how to define the user and make tvheadend connect to it.

http://www.lonelycoder.com/redmine/projects/tvheadend/wiki/Tvheadend_oscam_ziggo

Alex.

RE: TVHEADEND -> OSCAM -> CCCAM Server Cline - Added by Marcus Muller about 8 years ago

Hi,

I'm having a similar setup like Robert and exactly the same question.
My Dreambox (bed room) is running a CCCam Server for years without problems and now I want to connect to it with my C-Line
from the RPi (living room) running TVHeadend. I know that I have to use OSCam and I already did some configurations:

oscam.conf:

[global]
Nice = -1
ClientTimeout = 7
FallbackTimeout=3
ClientMaxIdle=120
CacheDelay = 120
BindWait = 5
WaitForCards = 0
PreferLocalCards = 1
LogFile = stdout
saveinithistory = 1
readerrestartseconds = 5
maxlogsize = 200

[monitor]
nocrypt = 127.0.0.1,192.168.0.0-192.168.255.255
appendchaninfo = 1

[webif]
httpport = 8888
httpuser = root
httppwd = pwd
httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255

[dvbapi]
enabled = 1
au = 1
boxtype = pc
user = dvbapi
###### for E2 set pmt_mode = 0 ###########
###### for Titan set pmt_mode = 4 ###########
pmt_mode = 0

oscam.server:

[reader]
enable = 1
label = cccam-reader
protocol = cccam
device = 192.168.178.10,55555
user = living-room
password = pwd
group = 1
emmcache = 1,1,2
cccmaxhop = 5
cccversion = 2.2.1

oscam.user:

[account]
user = dvbapi
pwd = dvbapi
group = 1
au = 1
uniq = 0
betatunnel = 1833.FFFF:1702,1834.FFFF:1722

From the OSCam WebIf as configured above, I can see that the connection to the server (192.168.178.10) has been established, status is "CONNECTED".
What I am struggling with are the configurations that needs to be done in TVHeadend (Hostname, Port, Username, Password, DES Key).

Anybody that might can give me a hint?

RE: TVHEADEND -> OSCAM -> CCCAM Server Cline - Added by Alex . about 8 years ago

Your loginname and passsword seem to be (see your oscam.user) dvbapi , dvbapi

Hostname: use the IP address of your cardserver. Either full IP, or if it is on the same machine, try full ip first, or 127.0.0.1 later.

Port: default is 15050, but you can also define one in ther webif section ( see the link to an example posted before).
I also see something like 55555 in your reader.config files, dont know what this is ( where did you get this file from???) but if either 15050 or a custm define one ( 15080 in the example ), maybe try that one.

Once IP and Port are correct, make it active in tvheadend, and watch the OSCAM log again for errors ( maybe related to keys or something.

Alex.

RE: TVHEADEND -> OSCAM -> CCCAM Server Cline - Added by Marcus Muller about 8 years ago

HI Alex,

Thanks for your answer.

Yeah... I should have mentioned before that I wouldn't recommend anybody to rely on the correctness of the above ;) .
These config files are the results of hours of browsing and reading.
The linked tutorial is useful for compiling (kind of, because RPi is ARM platform) but when it comes to the configuration of CCCam I'm lost
because I want to use it as a client only, means I have no reader attached but a C-Line I want to use.

Hostname: use the IP address of your cardserver. Either full IP, or if it is on the same machine, try full ip first, or 127.0.0.1 later.

The cardserver is running on 192.168.178.10, port 55555.
So instead of defining localhost in TVH I need to put this host?

Port: default is 15050, but you can also define one in ther webif section ( see the link to an example posted before).
I also see something like 55555 in your reader.config files, dont know what this is ( where did you get this file from???) but if either 15050 or a custm define one ( 15080 in the example ), maybe try that one.

You mean 15050 is the standard port for OSCam or TVHeadend? According to my "oscam.conf" (WebIf section, httpport = 8888) do I need to put this port 8888 in TVH?
Port 55555 is the port I manually configured my already running CCCam-Server to listen on for incoming connections.
This part of the config I assume to work fine since I can see in the OSCam WebIf that the connection to the Cardserver has been established.

Last important question: Do I need to enter anything in "DES Key" ?

I'll use your instructions and give it a try once I'm back home. Thanks!

RE: TVHEADEND -> OSCAM -> CCCAM Server Cline - Added by Alex . about 8 years ago

Sorry about the webif-confusion: that is the port to your webinterface indeed ( so i was not right about using the 05080 or 8888 port).

Anyway:
- TVHeadend needs to point to the OSCAM Ip and port. ( thats what I called the cardserver, cince in my case oscam is the cardserver, and in your case too oscam seems to serve the codes to tvheadend).
- Also, since tvheadend needs to connect to OSCAM, use the OSCAM passwords.
- I think the DES key is optional:if it it not defined leave it empty.

Best thing I can think of is to make sure port and IP are right, then start the tvheadend coedewordclient ( make sure it is enabled in its configuration tab) and look at the oscam-output: It should show an attempt to login, and should give you more information ( for example, that the connection is accepted or not).
In this way, you can at least make sure that tvheadend tries to connect to the right service. After this , worry about the other details...

Hope that this might give you some more info about what is working and what is not...

Alex.

RE: TVHEADEND -> OSCAM -> CCCAM Server Cline - Added by Seven NL about 8 years ago

Hello,
Sorry to butti-in but i am struggling with the same problem , as many newcomers do, setting TVH + oscam correctly.

the point i am at, after a few days of reading posts and trying faultly CCcam's.
  • TVH is connected through the NewCamd connection to oscam.
  • I see in the logs of oscam the CCcam protocol made a connection to my CCcam server on the Dreambox.
    now i need the codes, that the CCcam protocol receives, send through the NewCamd protocol to TVH.
    ( this is how it is done as far as i can read out of the Ziggo post )

So The Dreambox server has to be seen as a local card reader.

here is what i have so far:

oscam.user:

# user connecting via NewCamd protocol to oscam (TVHEADEND)
[account]
user       = tvh
pwd        = tvh
monlevel   = 1
uniq       = 1
group      = 1
au         = newcamd_link
#services   = services1

oscam.server:

[reader]
label                         = newcamd_link
protocol                      = newcamd
device                        = 127.0.0.1,34000
key                           = 0102030405060708091011121314
user                          = tvh
password                      = tvh
fallback                      = 1
group                         = 1
#caid                          = 0604:000000

[reader]
enable<><------><------>      = 1
label                         = cccam_remote
description                   = Remote access
protocol                      = cccam
device                        = 192.168.1.100,29000
user                          = DBX
password                      = DBX
inactivitytimeout             = 1
group                         = 1
cccversion                    = 2.0.11
cccmaxhops                    = 2
ccckeepalive                  = 1

oscam.conf:

[global]
serverip                      = 127.0.0.1
logfile                       = /var/log/oscam/oscam.log
nice                          = -1
usrfile                       = /var/log/oscam/oscamuser.log
cwlogdir                      = /var/log/oscam/cw

[anticasc]
enabled                       = 1
numusers                      = 1
samples                       = 5
penalty                       = 1
aclogfile                     = /var/log/oscam/aclog.log
denysamples                   = 4

[newcamd]
port                          = 34000
serverip                      = 127.0.0.1
key                           = 0102030405060708091011121314
keepalive                     = 1

[monitor]
port                          = 988
aulow                         = 120
monlevel                      = 1

[webif]
httpport                      = 8888
httpuser                      = xbmc
httppwd                       = xbmc
httpallowed                   = 192.168.1.1-192.168.1.100
aulow                         = 120

Setting in tvheadend/configuration/code word client:

Enabled = on
Hostname = 127.0.0.1
username = tvh
password = tvh
DES key = 00:01:02:03:04:05:06:07:08:09:10:11:12:13:14
Update card = on
Update One = on

anyone an idea what i forgot/ doing wrong ?

    (1-6/6)