Project

General

Profile

CCam how to enable this?

Added by Bob Blob 7 months ago

Hi All

Just would like start this question thread as cant find simple answer for it. Have installed and running almost fine tvh server, one of the thing is that cant find CCcam section under CAs. Is there any way to enable it? Or how to compile tvh with this section fully accessible? Already did one but even CAs section wasnt visible at all.

Regards
Ra


Replies (18)

RE: CCam how to enable this? - Added by Mark Clarkstone 7 months ago

If you don't see the CAs tab, change the view level for the user to expert, and/or change the default view level in the base config (Config -> General -> Base).

RE: CCam how to enable this? - Added by Bob Blob 7 months ago

Hi
Thanks for reply.
How about if there is not visible CCcam option just newcamd?

Regards
Ra

RE: CCam how to enable this? - Added by Mark Clarkstone 7 months ago

Bob Blob wrote:

Hi
Thanks for reply.
How about if there is not visible CCcam option just newcamd?

Regards
Ra

Isn't that just dvbapi?

RE: CCam how to enable this? - Added by Bob Blob 7 months ago

Not sure, presume its Oscam version intergrated somehow.

RE: CCam how to enable this? - Added by balanga bar 6 months ago

Bob Blob wrote:

Hi All

Just would like start this question thread as cant find simple answer for it. Have installed and running almost fine tvh server, one of the thing is that cant find CCcam section under CAs. Is there any way to enable it? Or how to compile tvh with this section fully accessible? Already did one but even CAs section wasnt visible at all.

Regards
Ra

I've never figured out descrambling using cccam... I believe I need to run an OSCAM server but have no idea about how to confiure it. Is there a definitive guide anywhere?

RE: CCam how to enable this? - Added by Bob Blob 6 months ago

Guideline how to set oscam server? Plenty of howtos.

RE: CCam how to enable this? - Added by balanga bar 6 months ago

Bob Blob wrote:

Guideline how to set oscam server? Plenty of howtos.

They all seem to be related to Enigma. Is there anything specific to Tvheadend?

Getting cccam working on my Android decoder is very straightforward, but with Tvheadend it's very difficult.

RE: CCam how to enable this? - Added by balanga bar 6 months ago

After following:-

https://tvheadend.org/boards/13/topics/6211

I manageded to set up OSCAM and log on, but got stuck at:-

now point your browser to http://ip-of-your-oscam-server:8888/ login, configure newcamd, add a user and add a reader (your cccam server). Finally configure TVheadend to connect to Oscam and you should be able to start watching encrypted TV channels.

Not sure how to configure newcamd, add a user and add a reader....

Any guidance would be appreciated.

RE: CCam how to enable this? - Added by Bob Blob 6 months ago

In config upper tabs, set newcamd port, in oscam add user: tvhead with tvhead password or choose whatever you like. In tvheadend use those creditenials.

RE: CCam how to enable this? - Added by balanga bar 6 months ago

Bob Blob wrote:

In config upper tabs, set newcamd port, in oscam add user: tvhead with tvhead password or choose whatever you like. In tvheadend use those creditenials.

I wish I understood any of that!

It seems that I need to configure oscam.conf oscam.user oscam.server correctly and then add a client via the Tvheadend GUI and know how each of the values interacts with other files.

In this post [https://tvheadend.org/boards/13/topics/13301] it says to use dvapi rather newcamd, but others have other views.

Wish someone would provide a definitive step by step (uptodate) guide on setting up Oscam on Tvheadend.... There are so many conflicting configurations.

RE: CCam how to enable this? - Added by Bob Blob 6 months ago

Yes, pm me maybe we gonna organise TeamViewer sesion.

RE: CCam how to enable this? - Added by balanga bar 6 months ago

Bob Blob wrote:

Yes, pm me maybe we gonna organise TeamViewer sesion.

What's TeamViewer?

RE: CCam how to enable this? - Added by Bob Blob 6 months ago

Remote desktop.

RE: CCam how to enable this? - Added by balanga bar 6 months ago

I've never used that.... and I'm running on Debian Linux.

I followed the instructions here - http://techblog.thomserve.co.uk/2016/07/26/how-to-integrate-oscam-with-tvheadend/

which are more recent than most and relatively simple. The log show there has been an initialisation from my service provider, but for some reason I get errors connecting to 192.160.0.10:2006. I don't know what this is or where it is set.

RE: CCam how to enable this? - Added by saen acro 6 months ago

Describe step by step what you do and how you do it.

Every thing is simple when simple logic is used ;)

RE: CCam how to enable this? - Added by balanga bar 6 months ago

saen acro wrote:

Describe step by step what you do and how you do it.

Every thing is simple when simple logic is used ;)

There are simply too many steps involved to accurately described what I did... but in outline terms, I installed Debian Linux (OpenVault version) http://openvault.com/

Installed Tvheaadend - not sure which instructions I followed but am running HTS Tvheadend 4.2.6-9~g12bff89b4

Installed Oscam using instructions here - http://www.streamboard.tv/wiki/OSCam/en

I'm running OSCam: 1.20-unstable_svn Build: r11425 Compiler: x86_64-linux-gnu

Followed the instructions here to integrate OScam with TVHeadend

http://techblog.thomserve.co.uk/2016/07/26/how-to-integrate-oscam-with-tvheadend/

oscam.user:-

[account]
user                          = tvheadhend
pwd                           = tvheadend
monlevel                      = 4
group                         = 1
max_connections               = 99

oscam.server:-

[reader]
label     = CCcam
protocol  = cccam
device    = MY-SERVICE_PROVIDER-HOSTNAME,MY-SERVICE_PROVIDER-PORT
user      = MY-USERID
password  = MY-PASSWORD
group     = 1
caid      = 0100,0500,0604,1810,1802,1880
cccversion= 1.2.3
cccbuild  = 4567

oscam.conf:-

[global]
logfile                       = /var/log/oscam/oscam.log
nice                          = -1
usrfile                       = /var/log/oscam/oscamuser.log
cwlogdir                      = /var/log/oscam/cw

[anticasc]
enabled                       = 1
numusers                      = 1
samples                       = 5
penalty                       = 1
aclogfile                     = /var/log/oscam/aclog.log
denysamples                   = 4

[cache]

[cs378x]
port                          = [email protected]:FFFFFF;[email protected]:FFF000,FFFF00;[email protected]:FFFFFF

[newcamd]
port                          = [email protected]:FFFFFF;[email protected]:FFF000,FFFF00;[email protected]:FFFFFF
key                           = 000102030405060708090A0B0C0D

[radegast]
port                          = 20000
allowed                       = 192.168.0.0-192.168.255.255
user                          = user1

[serial]
device                        = [email protected]/dev/ttyS0?delay=1&timeout=300;[email protected],2006?delay=1&timeout=5000

[gbox]
port                          = 50000
hostname                      = host.example.com
my_password                   = AB1122C1

[cccam]
port                          = MY-SERVICE_PROVIDER-PORT
nodeid                        = F37EA75D10CD1586
version                       = 2.0.11
reshare                       = 2

[dvbapi]
enabled                       = 1
pmt_mode                      = 0
listen_port                   = 9001
ecminfo_type                  = 4
user                          = tvheadhend
read_sdt                      = 1
boxtype                       = pc

[monitor]
port                          = 988
aulow                         = 120
monlevel                      = 1

[webif]
httpport                      = 8888
httpuser                      = root
httppwd                       = password
httpallowed                   = 127.0.0.1,192.168.1.0-192.168.255.255,255.255.255.255
aulow                         = 120

Having spent many hours trying various things to try and get this working, I may have omitted various additional steps.

One thing I can't figure out is why does my /var/log/oscam.log show attempts to try and connect to 192.160.0.10:2006

RE: CCam how to enable this? - Added by saen acro 6 months ago

Fallow logic of connection
Oscam C-line port

oscam.conf

[cccam]
port                          = 12345

rest is not needed

next create user

oscam.user

[account]
user                          = tvheadhend
pwd                           = tvheadend
group                         = 1

group need to be same as reader used to connect to service provider or local card reader

add client in TVH connecting to ip of oscam with port 12345

for beginners use web-ui of oscam don't be so hackers

RE: CCam how to enable this? - Added by balanga bar 6 months ago

Many thanks for this!!!!

I was mixing up the port with the port I used for connecting to my service provider.

I have it working now.... sort of... maybe I'm missing some encryption algorithms. Are they specified by CAID?

    (1-18/18)