Project

General

Profile

tvheadend - is this even works? For me - it doesn't

Added by giaur giaur almost 10 years ago

Hello,

I've just installed tvheadend on my debian sid. I want to stream tv via network and watch channels from other computers. Unfortunatelly, this is the result:

http://www.pixhost.org/show/3200/10036781_tv.png

And logs are flooded with this:

Nov 15 09:49:29 TS: IT9135 USB DVB-T/610,000 kHz/TVP2: H264 #202: Continuity counter error, 234 duplicate log lines suppressed
Nov 15 09:49:29 TS: IT9135 USB DVB-T/610,000 kHz/TVP2: AC3
#203: Continuity counter error, 138 duplicate log lines suppressed
Nov 15 09:49:29 TS: IT9135 USB DVB-T/610,000 kHz/TVP2: MPEG2AUDIO #204: Continuity counter error, 54 duplicate log lines suppressed
Nov 15 09:49:29 TS: IT9135 USB DVB-T/610,000 kHz/TVP2: TELETEXT
#205: Continuity counter error, 63 duplicate log lines suppressed
Nov 15 09:49:30 TS: IT9135 USB DVB-T/610,000 kHz/TVP2: H264 #202: Continuity counter error, 333 duplicate log lines suppressed
Nov 15 09:49:30 TS: IT9135 USB DVB-T/610,000 kHz/TVP2: AC3
#203: Continuity counter error, 195 duplicate log lines suppressed
Nov 15 09:49:30 TS: IT9135 USB DVB-T/610,000 kHz/TVP2: MPEG2AUDIO #204: Continuity counter error, 79 duplicate log lines suppressed
Nov 15 09:49:30 TS: IT9135 USB DVB-T/610,000 kHz/TVP2: TELETEXT
#205: Continuity counter error, 93 duplicate log lines suppressed
Nov 15 09:49:31 TS: IT9135 USB DVB-T/610,000 kHz/TVP2: H264 #202: Continuity counter error, 420 duplicate log lines suppressed
Nov 15 09:49:31 TS: IT9135 USB DVB-T/610,000 kHz/TVP2: AC3
#203: Continuity counter error, 247 duplicate log lines suppressed

Of course, adapter works perfectly when I try to watch tv locally (for example - using kaffeine or vlc) and signal is very good (almost 100%)

I've searched google but I found nothing, only some (ignered) messages on this forum, describing similar problems. So, is there any solution to fix this issue? As you can see, problem is not hardware related. I've also disabled Idle scanning option for ma adapter but still the same.


Replies (11)

RE: tvheadend - is this even works? For me - it doesn't - Added by Hein Rigolo almost 10 years ago

What version of tvheadend are you running (2.12 or a git version and exactly which one) and what is your dvb network?

RE: tvheadend - is this even works? For me - it doesn't - Added by giaur giaur almost 10 years ago

Hello,

I'm running 2.12 installed today from Debian repository provided on your site. I've added repo to debian sources list and installed tvheadend using apt-get. My system is Debian Sid.

What do you mean dvb network? This is dvb-t mpeg4 ts stream and SD resolution from Poland. Signal is very good - 100/100 in Kaffeine and really stable. I was excited tvheadend features (and how it looks like), but now I'm confused becasuse nothing works as should.

What works:
- EPG
- Service/channel list

What does not work:
-watching tv: video on vlc looks like on my screenshot, also - there is no sound.

Recording is not tested yet - watching tv remotely via network or internet (I have enough bandwidth to get this work) is matadory for me.

RE: tvheadend - is this even works? For me - it doesn't - Added by Hein Rigolo almost 10 years ago

Okee, you are probably beter of using a self compiled version based on our latest git. Also vlc is not the best client to use with tvheadend. If you want to use it for live tv streaming then using a xbmc client with the latest pvr add on is beter suited. If you are only intrested in creating recordings then you can use tvheadend standalone and use any media player to play back the recorded mkv files. In the latest version various fixes have been implemented to let tvheadend work better with h.264 videa and audio streams although there are still some issues with aec3 audio and recordings.

You might want to check out lar op den kamp's repository for the latest xbmc pvr releases. He also maintaines a packed version of our git version.

Hein

RE: tvheadend - is this even works? For me - it doesn't - Added by giaur giaur almost 10 years ago

Yes I know about xbmc, but I need to play streams on Windows 7 computers also, so vlc seems to be quite good and easy for setup tool for this? As I can see, also vlc plugin is used to play tv via web interface (it crashes anyway, but I think standalone vlc should work good).

About kamp's repository: is there binary tvheadend packages for Debian available? I want to awoid compiling by myself, if this possible, it will be better to install from .deb.

RE: tvheadend - is this even works? For me - it doesn't - Added by Hein Rigolo almost 10 years ago

There are binary packages available but nit sure if they can be applied to debian sid, or if they are ubutu specific. And ... There is xbmc for windows.

Also keep in mind the the streaming code is not very robust. So you might hit some problems.

Creating your own .deb fro the tvheadend sour e is not that difficult to do it your self. You can use debuild inside the tvheadend source dir, just make sure you have a correct changelog file.

Hein

RE: tvheadend - is this even works? For me - it doesn't - Added by giaur giaur almost 10 years ago

Where can I find binary packages you are talking about? And last question - is there any tutorial how to build tvheadent from source? I've never use debuild to create debs, always checkinstall was enouh but I'll try debuild if this is necessary.

RE: tvheadend - is this even works? For me - it doesn't - Added by Hein Rigolo almost 10 years ago

On the wiki there are instruction how to build it (without using a .deb)
And you can google for lars op den kamp ppa to find his repository

Hein

RE: tvheadend - is this even works? For me - it doesn't - Added by giaur giaur almost 10 years ago

Bad news..

I've compiled andoma-tvheadend-9075408 from source. Seems this is newest available version (downloaded today from git repo). And still the same. It seems there is a lot of work remaining to do to make this even usable for mpeg4 dvb.

Was even dvb-t/s/c 576p tested? I suspect some problems with encoding. I get the same blury green image when I try to convert saved .ts using mencoder or avidemux (for examle, to xvid).

Finally.. do you have any idea what else can I do to make this working, or - as yet - I rather should look for other solutions for tv streaming?

RE: tvheadend - is this even works? For me - it doesn't - Added by giaur giaur almost 10 years ago

Recording does not work too. The same flood messages in logs and here you can download sample recorded mkv: http://www.filesonic.com/file/3730563435/Serwis_sportowy.mkv

As you can see, this is the same corrupted video as on my screenshot.

RE: tvheadend - is this even works? For me - it doesn't - Added by Hein Rigolo almost 10 years ago

And if you make a recording using the dvb-apps tools? Do you have the same issue's? You said you tried with kaffeine .. Is that on the same machine/hardware?

I assume that these feeds are not encrypted.

Hein

RE: tvheadend - is this even works? For me - it doesn't - Added by giaur giaur almost 10 years ago

It seems to be my fault. All my previous installations was performed on virtual machine (virtualbox) and usb dvb-t tuner connected to virtual machine. I compiled tvheadend on my host machine (Debian Sid too). And now, it's better.

What works:
- plaing channels via VLC (on localhost, playing via network is not tested yet). This opened with vlc (for example): http://127.0.0.1:9981/stream/channelid/6 seems to be ok.

What does not work:
- play with web interface. If I can suggest anything - is this possible to implement html5 streaming (like youtube html5) instead of using vlc plugin, wchich crashes and never works?
- recording. It works.. partially, look at this: http://www.filesonic.com/file/3840023055/Info_Dziennik_-_Gość.mkv - much more better, but record is still corrupted.

Some more questions:
- Streams played like I described above does not contain epg and teletext or dvb subtitles. Is this possible to include epg and teletext information in stream
- Why this does not work on virtual machine - do you think this is becasuse dvb-t tuner connected to vm does not work as should?

    (1-11/11)