Project

General

Profile

Oscam + Tvheadend. Channels won't descramble. Please help.

Added by Peter LB almost 4 years ago

Hi I'm new to Oscam so hope someone can help me. Have used many hours and it still won't work.
Earlier I was running NewCS on a raspberry pi, but would like to switch to Oscam, since I couldn't decrypt all channels.

I'm running Oscam on a Debian VirtualBox and USB passthrough on my Smargo Smartreader2+ with a Viaccess card, I'm running it up against a TVHeadend, but it wont descramble any channels. TVheadend log is also included.

oscam.server
  1. oscam.server generated automatically by Streamboard OSCAM 1.20-unstable_svn SVN r11360
  2. Read more: http://www.streamboard.tv/svn/oscam/trun...scam.server.txt

[reader]
label = Ziggo
protocol = mouse
device = /dev/ttyUSB0
pincode = 0000
caid = 0500
detect = cd
mhz = 600
ident = 0500:FFF490,040210,040220,040230,040240
showcls = 4
group = 1
emmcache = 1,3,2,0

oscam.user
  1. oscam.user generated automatically by Streamboard OSCAM 1.20-unstable_svn SVN r11360
  2. Read more: http://www.streamboard.tv/svn/oscam/trun.../oscam.user.txt

[account]
user = tvheadend
pwd = tvheadend
caid = 0500
monlevel = 1
au = Ziggo
group = 1

oscam.conf #
  1. main configuration #

[global]
nice = -1
WaitForCards = 1

  1. logging

logfile = /var/log/oscam/oscam.log
usrfile = /var/log/oscam/oscamuser.log
cwlogdir = /var/log/oscam/cw

  1. monitor

[monitor]
port = 988
aulow = 120
monlevel = 1

  1. web interface

[webif]
httpport = 8888
httpuser = xxxxx
httppwd = xxxxx
httpallowed = 127.0.0.1,192.168.1.1-192.168.1.255,::1

  1. anti-cascading

[anticasc]
enabled = 1
numusers = 1
sampletime = 2
samples = 5
penalty = 1
aclogfile = /var/log/oscam/aclog.log
denysamples = 9

  1. protocols

[newcamd]
key = 0102030405060708091011121314
port = [email protected]:FFFFFF;[email protected]:FFF000,FFFF00;[email protected]:FFFFFF

Tvheadend:
2017-02-28 14:03:41.322 cwc: Connected to 192.168.1.27:10000
2017-02-28 14:03:44.198 cwc: 192.168.1.27:10000: Connected as user tvheadend to a Viaccess-card [0x0500 : 00.00.00.00.00.00.00.00] with 1 provider
2017-02-28 14:03:44.198 cwc: 192.168.1.27:10000: Provider ID #1: 0x0500:0xffffff 00.00.00.00.00.00.00.00
2017-02-28 14:03:44.198 cwc: 192.168.1.27:10000: Will not forward EMMs (not allowed by server)
2017-02-28 14:04:00.976 mpegts: 188MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #0 (192.168.1.187)
2017-02-28 14:04:00.976 tvhdhomerun: tuning to a8qam64-6875:188000000
2017-02-28 14:04:00.981 subscription: 0033: "epggrab" subscribing to mux "188MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #0 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:04:00.981 mpegts: 506MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #1 (192.168.1.187)
2017-02-28 14:04:00.981 tvhdhomerun: tuning to a8qam64-6875:506000000
2017-02-28 14:04:00.990 subscription: 0034: "epggrab" subscribing to mux "506MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #1 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:04:00.990 mpegts: 143MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #2 (192.168.1.187)
2017-02-28 14:04:00.990 tvhdhomerun: tuning to a8qam64-6875:143000000
2017-02-28 14:04:00.998 subscription: 0035: "epggrab" subscribing to mux "143MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #2 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:04:00.998 mpegts: 514MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #3 (192.168.1.187)
2017-02-28 14:04:00.998 tvhdhomerun: tuning to a8qam64-6875:514000000
2017-02-28 14:04:01.007 subscription: 0036: "epggrab" subscribing to mux "514MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #3 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:14:15.976 epggrab: PSIP: ATSC Grabber - data completion timeout for 188MHz in DVB-C Network
2017-02-28 14:14:15.976 epggrab: EIT: DVB Grabber - data completion timeout for 188MHz in DVB-C Network
2017-02-28 14:14:15.976 subscription: 0033: "epggrab" unsubscribing
2017-02-28 14:14:15.991 epggrab: EIT: DVB Grabber - data completion timeout for 514MHz in DVB-C Network
2017-02-28 14:14:15.991 epggrab: PSIP: ATSC Grabber - data completion timeout for 514MHz in DVB-C Network
2017-02-28 14:14:15.991 subscription: 0036: "epggrab" unsubscribing
2017-02-28 14:14:15.993 epggrab: PSIP: ATSC Grabber - data completion timeout for 143MHz in DVB-C Network
2017-02-28 14:14:15.993 epggrab: EIT: DVB Grabber - data completion timeout for 143MHz in DVB-C Network
2017-02-28 14:14:15.993 subscription: 0035: "epggrab" unsubscribing
2017-02-28 14:14:15.994 epggrab: EIT: DVB Grabber - data completion timeout for 506MHz in DVB-C Network
2017-02-28 14:14:15.994 epggrab: PSIP: ATSC Grabber - data completion timeout for 506MHz in DVB-C Network
2017-02-28 14:14:15.994 subscription: 0034: "epggrab" unsubscribing
2017-02-28 14:14:16.992 mpegts: 570MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #0 (192.168.1.187)
2017-02-28 14:14:16.992 tvhdhomerun: tuning to a8qam64-6875:570000000
2017-02-28 14:14:16.996 subscription: 0038: "epggrab" subscribing to mux "570MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #0 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:14:16.996 mpegts: 546MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #1 (192.168.1.187)
2017-02-28 14:14:16.996 tvhdhomerun: tuning to a8qam64-6875:546000000
2017-02-28 14:14:17.001 subscription: 0039: "epggrab" subscribing to mux "546MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #1 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:14:17.001 mpegts: 530MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #2 (192.168.1.187)
2017-02-28 14:14:17.001 tvhdhomerun: tuning to a8qam64-6875:530000000
2017-02-28 14:14:17.007 subscription: 003A: "epggrab" subscribing to mux "530MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #2 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:14:17.007 mpegts: 458MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #3 (192.168.1.187)
2017-02-28 14:14:17.007 tvhdhomerun: tuning to a8qam64-6875:458000000
2017-02-28 14:14:17.013 subscription: 003B: "epggrab" subscribing to mux "458MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #3 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:24:31.992 epggrab: PSIP: ATSC Grabber - data completion timeout for 458MHz in DVB-C Network
2017-02-28 14:24:31.992 epggrab: EIT: DVB Grabber - data completion timeout for 458MHz in DVB-C Network
2017-02-28 14:24:31.992 subscription: 003B: "epggrab" unsubscribing
2017-02-28 14:24:31.994 epggrab: EIT: DVB Grabber - data completion timeout for 530MHz in DVB-C Network
2017-02-28 14:24:31.994 epggrab: PSIP: ATSC Grabber - data completion timeout for 530MHz in DVB-C Network
2017-02-28 14:24:31.994 subscription: 003A: "epggrab" unsubscribing
2017-02-28 14:24:31.996 epggrab: EIT: DVB Grabber - data completion timeout for 546MHz in DVB-C Network
2017-02-28 14:24:31.996 epggrab: PSIP: ATSC Grabber - data completion timeout for 546MHz in DVB-C Network
2017-02-28 14:24:31.996 subscription: 0039: "epggrab" unsubscribing
2017-02-28 14:24:31.997 epggrab: EIT: DVB Grabber - data completion timeout for 570MHz in DVB-C Network
2017-02-28 14:24:31.997 epggrab: PSIP: ATSC Grabber - data completion timeout for 570MHz in DVB-C Network
2017-02-28 14:24:31.997 subscription: 0038: "epggrab" unsubscribing
2017-02-28 14:24:33.000 mpegts: 578MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #0 (192.168.1.187)
2017-02-28 14:24:33.000 tvhdhomerun: tuning to a8qam64-6875:578000000
2017-02-28 14:24:33.005 subscription: 003D: "epggrab" subscribing to mux "578MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #0 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:24:33.005 mpegts: 602MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #1 (192.168.1.187)
2017-02-28 14:24:33.005 tvhdhomerun: tuning to a8qam64-6875:602000000
2017-02-28 14:24:33.009 subscription: 003E: "epggrab" subscribing to mux "602MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #1 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:24:33.009 mpegts: 538MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #2 (192.168.1.187)
2017-02-28 14:24:33.009 tvhdhomerun: tuning to a8qam64-6875:538000000
2017-02-28 14:24:33.013 subscription: 003F: "epggrab" subscribing to mux "538MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #2 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:24:33.013 mpegts: 586MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #3 (192.168.1.187)
2017-02-28 14:24:33.013 tvhdhomerun: tuning to a8qam64-6875:586000000
2017-02-28 14:24:33.018 subscription: 0040: "epggrab" subscribing to mux "586MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #3 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:34:48.006 epggrab: EIT: DVB Grabber - data completion timeout for 586MHz in DVB-C Network
2017-02-28 14:34:48.006 epggrab: PSIP: ATSC Grabber - data completion timeout for 586MHz in DVB-C Network
2017-02-28 14:34:48.006 subscription: 0040: "epggrab" unsubscribing
2017-02-28 14:34:48.007 epggrab: EIT: DVB Grabber - data completion timeout for 538MHz in DVB-C Network
2017-02-28 14:34:48.007 epggrab: PSIP: ATSC Grabber - data completion timeout for 538MHz in DVB-C Network
2017-02-28 14:34:48.007 subscription: 003F: "epggrab" unsubscribing
2017-02-28 14:34:48.008 epggrab: EIT: DVB Grabber - data completion timeout for 602MHz in DVB-C Network
2017-02-28 14:34:48.008 epggrab: PSIP: ATSC Grabber - data completion timeout for 602MHz in DVB-C Network
2017-02-28 14:34:48.008 subscription: 003E: "epggrab" unsubscribing
2017-02-28 14:34:48.009 epggrab: EIT: DVB Grabber - data completion timeout for 578MHz in DVB-C Network
2017-02-28 14:34:48.009 epggrab: PSIP: ATSC Grabber - data completion timeout for 578MHz in DVB-C Network
2017-02-28 14:34:48.009 subscription: 003D: "epggrab" unsubscribing
2017-02-28 14:34:49.011 mpegts: 196MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #0 (192.168.1.187)
2017-02-28 14:34:49.012 tvhdhomerun: tuning to a8qam64-6875:196000000
2017-02-28 14:34:49.018 subscription: 0042: "epggrab" subscribing to mux "196MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #0 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:34:49.019 mpegts: 498MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #1 (192.168.1.187)
2017-02-28 14:34:49.020 tvhdhomerun: tuning to a8qam64-6875:498000000
2017-02-28 14:34:49.026 subscription: 0043: "epggrab" subscribing to mux "498MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #1 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:34:49.026 mpegts: 594MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #2 (192.168.1.187)
2017-02-28 14:34:49.027 tvhdhomerun: tuning to a8qam64-6875:594000000
2017-02-28 14:34:49.031 subscription: 0044: "epggrab" subscribing to mux "594MHz", weight: 4, adapter: "HDHomeRun DVB-C Tuner #2 (192.168.1.187)", network: "DVB-C Network", service: "Raw PID Subscription"
2017-02-28 14:45:04.020 epggrab: EIT: DVB Grabber - data completion timeout for 594MHz in DVB-C Network
2017-02-28 14:45:04.020 epggrab: PSIP: ATSC Grabber - data completion timeout for 594MHz in DVB-C Network
2017-02-28 14:45:04.020 subscription: 0044: "epggrab" unsubscribing
2017-02-28 14:45:04.023 epggrab: EIT: DVB Grabber - data completion timeout for 498MHz in DVB-C Network
2017-02-28 14:45:04.023 epggrab: PSIP: ATSC Grabber - data completion timeout for 498MHz in DVB-C Network
2017-02-28 14:45:04.023 subscription: 0043: "epggrab" unsubscribing
2017-02-28 14:45:04.025 epggrab: PSIP: ATSC Grabber - data completion timeout for 196MHz in DVB-C Network
2017-02-28 14:45:04.025 epggrab: EIT: DVB Grabber - data completion timeout for 196MHz in DVB-C Network
2017-02-28 14:45:04.025 subscription: 0042: "epggrab" unsubscribing
Loglevel debug: enabled
Loglevel debug: disabled

2017-02-28 15:10:13.586 htsp: xx.xx.xxx.x [ admin | org.tvheadend.tvhclient ]: Disconnected
2017-02-28 15:10:13.653 htsp: Got connection from xx.xx.xxx.x
2017-02-28 15:10:13.662 htsp: xx.xx.xxx.x: Identified as user 'admin' (unverified)
2017-02-28 15:10:13.662 htsp: xx.xx.xxx.x [ admin ]: Welcomed client software: org.tvheadend.tvhclient (HTSPv23)
2017-02-28 15:10:13.692 htsp: xx.xx.xxx.x [ admin | org.tvheadend.tvhclient ]: Identified as user 'admin'
2017-02-28 15:10:13.692 htsp: xx.xx.xxx.x [ admin | org.tvheadend.tvhclient ]: Privileges updated
2017-02-28 15:10:19.597 htsp: xx.xx.xxx.x [ admin | org.tvheadend.tvhclient ]: Disconnected
2017-02-28 15:10:23.572 htsp: Got connection from xx.xx.xxx.x
2017-02-28 15:10:23.585 htsp: xx.xx.xxx.x: Identified as user 'admin' (unverified)
2017-02-28 15:10:23.585 htsp: xx.xx.xxx.x [ admin ]: Welcomed client software: org.tvheadend.tvhclient (HTSPv23)
2017-02-28 15:10:23.612 htsp: xx.xx.xxx.x [ admin | org.tvheadend.tvhclient ]: Identified as user 'admin'
2017-02-28 15:10:23.612 htsp: xx.xx.xxx.x [ admin | org.tvheadend.tvhclient ]: Privileges updated
2017-02-28 15:10:33.725 http: xx.xx.xxx.x: using ticket A62B253DDX316FC289E0BA848F52086XXC055C33F0A for /stream/channelid/985083476
2017-02-28 15:10:33.725 mpegts: 514MHz in DVB-C Network - tuning on HDHomeRun DVB-C Tuner #0 (192.168.1.187)
2017-02-28 15:10:33.725 tvhdhomerun: tuning to a8qam64-6875:514000000
2017-02-28 15:10:33.735 subscription: 0045: "HTTP" subscribing on channel "TV3+", weight: 100, adapter: "HDHomeRun DVB-C Tuner #0 (192.168.1.187)", network: "DVB-C Network", mux: "514MHz", provider: "YouSee", service: "TV3+", profile="pass", hostname=" xx.xx.xxx.x", username="admin", client="Mozilla/5.0 (Linux; Android 6.0.1; da-DK; SM-G935F Build/MMB29K.G935FXXU1BPLB) MXPlayer/1.8.9"
2017-02-28 15:10:36.033 descrambler: cannot decode packets for service "TV3+"
2017-02-28 15:10:46.061 descrambler: cannot decode packets for service "TV3+"
2017-02-28 15:10:56.075 descrambler: cannot decode packets for service "TV3+"


Replies (45)

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Peter LB almost 4 years ago

Hi the log i have is this. Hope you can help me:

2017/03/01 15:12:30 00000000 s (main) System name = Linux
2017/03/01 15:12:30 00000000 s (main) Host name = PlexServer
2017/03/01 15:12:30 00000000 s (main) Release = 3.16.0-4-amd64
2017/03/01 15:12:30 00000000 s (main) Version = #1 SMP Debian 3.16.39-1+deb8u1 (2017-02-22)
2017/03/01 15:12:30 00000000 s (main) Machine = x86_64
2017/03/01 15:12:30 00000000 s (main) creating pidfile /tmp/.oscam/oscam.pid with pid 26947
2017/03/01 15:12:30 00000000 s couldn't open statistics file: /var/log/oscam/oscamuser.log
2017/03/01 15:12:30 00000000 s (config) userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
2017/03/01 15:12:30 00000000 s (main) signal handling initialized
2017/03/01 15:12:30 00000000 s (net) monitor: initialized (fd=4, port=988)
2017/03/01 15:12:30 00000000 s (net) newcamd: initialized (fd=5, port=10000)
2017/03/01 15:12:30 00000000 s (net) > CAID: 0500 PROVID: FFFFFF
2017/03/01 15:12:30 00000000 s (net) newcamd: initialized (fd=6, port=10001)
2017/03/01 15:12:30 00000000 s (net) -> CAID: 0200 PROVID: FFF000, FFFF00
2017/03/01 15:12:30 00000000 s (net) newcamd: initialized (fd=7, port=10002)
2017/03/01 15:12:30 00000000 s (net) -> CAID: 0300 PROVID: FFFFFF
2017/03/01 15:12:30 00000000 s (reader) Ziggo [mouse] creating thread for device /dev/ttyUSB0
2017/03/01 15:12:30 00000000 s (stat) loadbalancer: could not open /tmp/.oscam/stat for reading (errno=2 No such file or directory)
2017/03/01 15:12:30 00000000 s (main) waiting for local card init
2017/03/01 15:12:30 58A3F116 h (webif) webif: decompressed 184578 bytes back into 434648 bytes
2017/03/01 15:12:30 58A3F116 h (webif) HTTP Server running. ip=0.0.0.0 port=8888
2017/03/01 15:12:30 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 82606
2017/03/01 15:12:30 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 77089
2017/03/01 15:12:30 0C8759B2 r (reader) Ziggo [mouse] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=600, cardmhz=357)
2017/03/01 15:12:31 0C8759B2 r (reader) Ziggo [mouse] card detected
2017/03/01 15:12:31 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 84961
2017/03/01 15:12:32 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 75283
2017/03/01 15:12:33 0C8759B2 r (reader) Ziggo [mouse] ATR: 11 E7 FF FF BC FF 03 11 E7 FF FF BC A1 DD BF E9 F6
2017/03/01 15:12:33 0C8759B2 r (reader) Ziggo [mouse] ERROR: Could not read reader
>convention
2017/03/01 15:12:33 0C8759B2 r (reader) Ziggo [mouse] Error activating card.
2017/03/01 15:12:34 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 75606
2017/03/01 15:12:35 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 75811
2017/03/01 15:12:36 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 93126
2017/03/01 15:12:38 0C8759B2 r (reader) Ziggo [mouse] ATR: 3F 77 18 00 00 C2 7A 44 02 68 90 00
2017/03/01 15:12:38 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 80451
2017/03/01 15:12:38 0C8759B2 r (reader) Ziggo [mouse] Init card protocol T0, FI=1, F=372, D=12, N=0
2017/03/01 15:12:38 0C8759B2 r (reader) Ziggo [mouse] Setting baudrate to 115200 bps
2017/03/01 15:12:38 0C8759B2 r (reader) Ziggo [mouse] Calculated work ETU is 5.17 us reader mhz = 600
2017/03/01 15:12:38 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 85918
2017/03/01 15:12:38 0C8759B2 r (reader) Ziggo [mouse] ATR Fsmax is 5 MHz, clocking card to wanted user cardspeed off 6.00 MHz (specified in reader->mhz)
2017/03/01 15:12:40 0C8759B2 r (reader) Ziggo [mouse] card system not supported
2017/03/01 15:12:40 0C8759B2 r (reader) Ziggo [mouse] Normal mode failed, reverting to Deprecated Mode
2017/03/01 15:12:40 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 77468
2017/03/01 15:12:41 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 77332
2017/03/01 15:12:42 0C8759B2 r (reader) Ziggo [mouse] ATR: 11 E7 FF FF BC A1 03 11 E7 FF FF BC A1 DD BF E9 F6
2017/03/01 15:12:42 0C8759B2 r (reader) Ziggo [mouse] ERROR: Could not read reader->convention
2017/03/01 15:12:42 0C8759B2 r (reader) Ziggo [mouse] Error activating card.
2017/03/01 15:12:43 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 79926
2017/03/01 15:12:44 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 79276
2017/03/01 15:12:45 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 75310
2017/03/01 15:12:47 0C8759B2 r (reader) Ziggo [mouse] ATR: 3F 77 18 00 00 C2 7A 44 02 68 90 00
2017/03/01 15:12:47 0C8759B2 r (reader) Ziggo [mouse] Warning: D=0 is invalid, forcing D=1
2017/03/01 15:12:47 0C8759B2 r (reader) Ziggo [mouse] Init card protocol T0, FI=1, F=372, D=1, N=0
2017/03/01 15:12:47 0C8759B2 r (reader) Ziggo [mouse] Calculated work ETU is 62.00 us reader mhz = 600
2017/03/01 15:12:47 0C8759B2 r (reader) Ziggo [mouse] Buffers readed 0 bytes total time_us 76430
2017/03/01 15:12:47 0C8759B2 r (reader) Ziggo [mouse] ATR Fsmax is 5 MHz, clocking card to wanted user cardspeed off 6.00 MHz (specified in reader->mhz)
2017/03/01 15:12:48 0C8759B2 r (reader) Ziggo [mouse] using ecm #601 for long viaccess ecm
2017/03/01 15:12:48 0C8759B2 r (reader) Ziggo [mouse] type: Viaccess (standard atr), caid: 0500, serial: ##########
2017/03/01 15:12:50 0C8759B2 r (reader) Ziggo [mouse] providers: 5 (FFF490,040210,040220,040230,040240)
2017/03/01 15:12:50 0C8759B2 r (reader) Ziggo [mouse] Maturity level [5]= older than 5 years
2017/03/01 15:12:50 0C8759B2 r (reader) Ziggo [mouse] ready for requests
2017/03/01 15:12:50 0C8759B2 r (reader) Ziggo [mouse] found card system viaccess
2017/03/01 15:12:50 0C8759B2 r (reader) Ziggo [viaccess] THIS WAS A SUCCESSFUL START ATTEMPT No 1 out of max alloted of 1
2017/03/01 15:12:50 0C8759B2 r (reader) Ziggo [viaccess] card detected
2017/03/01 15:12:50 0C8759B2 r (reader) Ziggo [viaccess] serial: ##########
2017/03/01 15:12:51 0C8759B2 r (reader) Ziggo [viaccess] provider: 1, id: ########################, sa: ########, geo: empty
2017/03/01 15:12:51 0C8759B2 r (reader) Ziggo [viaccess] provider: 2, id: ######################, sa: ########, geo: FF FF FF FF
2017/03/01 15:12:52 0C8759B2 r (reader) Ziggo [viaccess] provider: 3, id: ######################, sa: ########, geo: FF FF FF FF
2017/03/01 15:12:52 0C8759B2 r (reader) Ziggo [viaccess] provider: 4, id: ######################, sa: ########, geo: FF FF FF FF
2017/03/01 15:12:54 0C8759B2 r (reader) Ziggo [viaccess] provider: 5, id: #################, sa: ########, geo: FF FF FF FF
2017/03/01 15:12:54 00000000 s (main) init for all local cards done
2017/03/01 15:12:54 00000000 s (emmcache) loaded 0 emmcache records from /tmp/.oscam/oscam.emmcache in 1 ms
2017/03/01 15:12:54 00000000 s (emmcache) loaded 0 emmstat records from /tmp/.oscam/oscam.emmstat in 0 ms
2017/03/01 15:12:54 00000000 s (anticasc) ERROR: Can't open anti cascading logfile: /var/log/oscam/aclog.log (errno=2 No such file or directory)
2017/03/01 15:12:54 38001C13 c (newcamd) client connected to 10000 port
2017/03/01 15:12:54 6358C6D3 c () - Skipped 1 duplicated log lines --
2017/03/01 15:12:54 6358C6D3 c (client) anonymous disconnected from 192.168.1.180
2017/03/01 15:12:54 04D3BC32 c () - Skipped 1 duplicated log lines --
2017/03/01 15:12:54 04D3BC32 c (newcamd) client connected to 10000 port
2017/03/01 15:12:54 04D3BC32 c (client) anonymous disconnected from 192.168.1.180
2017/03/01 15:12:56 5786435E c (newcamd) client connected to 10000 port
2017/03/01 15:12:56 5786435E c (client) encrypted newcamd:10000-client 192.168.1.180 granted (tvheadend, au=on (1 reader))
2017/03/01 15:12:56 5786435E c (newcamd) user tvheadend authenticated successfully (Tvheadend)
2017/03/01 15:12:56 5786435E c (newcamd) AU disabled for user tvheadend
Save LogShow SettingsStop Log

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by saen acro almost 4 years ago

port = [email protected]:FFFFFF;[email protected]:FFF000,FFFF00;[email protected]:FFFFFF

replace "F" with "0"(zero)

Are you shure about AU and local card? At end of pay period (32days) card will stop to work

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Peter LB almost 4 years ago

I'm not shure about it. I have a Viaccess card (yousee) using USB passthrough on virtualbox.

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Christian Brauwers almost 4 years ago

you should use dvbapi instead of newcamd as protocol

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Peter LB almost 4 years ago

How would the settings be then. Can you please help me?

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Peter LB almost 4 years ago

And I would like to have multiple users.

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Christian Brauwers almost 4 years ago

Multiple User? on which system? tvh or oscam ?

on oscam side you have to config like

[dvbapi]
enabled  = 1
au = 1
pmt_mode = 0
listen_port = PORT OF YOUR CHOOSE
user = USERNAME OF YOUR CHOOSE
boxtype = pc

and in tvh you configure a oscam tcp with the port you have taken ... (can't look exactly, have changed my server to dvbviewer cause of descramble problems with my local cam)

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Peter LB almost 4 years ago

Thanks for the answer. Im guessing on both. When using newcs i have multiple users with newcamd and multiple users on tvheadend for connecting to newcamd. So i can see different channels simultaniously on different muxes. Does that make sense.

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Peter LB almost 3 years ago

Can someone help, I still have this problem.

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Markus Endres over 2 years ago

Try following settings:

oscam.conf:

[dvbapi]
enabled                       = 1
au                            = 1
pmt_mode                      = 4
request_mode                  = 1
listen_port                   = 9000
user                          = dvbapi
boxtype                       = pc

oscam.user

user                          = dvbapi
description                   = dvbapi for tvheadend
au                            = 1
group                         = 1

tvheadend:

Mode: OSCam net protocol (rev >= 10389)
Camd.socket Filename / IP Address (TCP mode): *IP-address of oscam*
Listen / Connect port: *same port as listen_port in oscam.conf*

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Peter LB over 2 years ago

Hi thanks for getting back to me. I've already tried the configuration above just with tvheadend instead of dvbapi as user, but still the same, no EMMs:(

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by saen acro over 2 years ago

how exactly you setup TVH
and on Oscam is readr and user are in same group

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Peter LB over 2 years ago

oscam.conf

  1. oscam.conf generated automatically by Streamboard OSCAM 1.00-unstable_svn build #0
  2. Read more: http://streamboard.gmc.to/svn/oscam/trunk/Distribution/doc/txt/oscam.conf.txt

#[global]
#usrfile = /storage/.kodi/userdata/addon_data/service.softcam.oscam/log/oscamuser.log
#logfile = /storage/.kodi/userdata/addon_data/service.softcam.oscam/log/oscam.log
#emmlogdir = /storage/.kodi/userdata/addon_data/service.softcam.oscam/log/
#cwlogdir = /storage/.kodi/userdata/addon_data/service.softcam.oscam/log/cw/
#nice = -1
#saveinithistory = 1
#lb_mode = 1
#lb_save = 100
#lb_savepath = /storage/.kodi/userdata/addon_data/service.softcam.oscam/log/
#fallbacktimeout = 2600
#lb_min_ecmcount = 5
#lb_max_ecmcount = 500
#lb_reopen_seconds = 900

#[monitor]
#port = 988
#aulow = 120
#hideclient_to = 15
#monlevel = 1
#appendchaninfo = 0

[webif]
httpport = 8888
httpuser = admin
httppwd = pass
httpallowed = 0.0.0.0-255.255.255.255

#[newcamd]
#key = 0102030405060708091011121314
#port = [email protected]:FFF490,040210,040220,040230,040240
#keepalive = 1

[global]
logfile = /storage/.kodi/userdata/addon_data/service.softcam.oscam/log/oscam.log
nice = -1
maxlogsize = 1000
dropdups = 1
usrfile = /storage/.kodi/userdata/addon_data/service.softcam.oscam/log/oscamuser.log
cwlogdir = /storage/.kodi/userdata/addon_data/service.softcam.oscam/log/cw/
emmlogdir = /storage/.kodi/userdata/addon_data/service.softcam.oscam/log/
double_check_caid = 0500
lb_mode = 1
fallbacktimeout = 2500
lb_min_ecmcount = 5
lb_max_ecmcount = 500
lb_reopen_seconds = 900

[cache]
max_time = 100

[dvbapi]
enabled = 1
au = 1
pmt_mode = 4
request_mode = 1
listen_port = 9000
user = tvheadend
boxtype = pc

oscam.user
#[account]
#user = tvheadend
#pwd = tvheadend
##au = Ziggo
#au = 1
#group = 1,2
#cccstealth = 1

#[account]
#user = tvheadend1
#pwd = tvheadend1
##au = Ziggo1
#au = 1
#group = 1,2
#cccstealth = 1

#[account]
#user = tvheadend2
#pwd = tvheadend2
##au = Ziggo
#au = 1
#group = 1,2
#cccstealth = 1

#[account]
#user = tvheadend3
#pwd = tvheadend3
##au = Ziggo1
#au = 1
#group = 1,2
#cccstealth = 1

#[account]
#user = tvheadendtest
#au = 1

[account]
user = tvheadend
#pwd = xxxxxxxxxxxx
au = 1
group = 1,2
#caid = 0500

oscam.server
  1. oscam.server generated automatically by Streamboard OSCAM 1.20-unstable_svn SVN r11391
  2. Read more: http://www.streamboard.tv/svn/oscam/trunk/Distribution/doc/txt/oscam.server.txt

#[reader]
#label = Ziggo
#protocol = smargo
#device = /dev/ttyUSB0
#detect = cd
#mhz = 369
#cardmhz = 369
#group = 1
#emmcache = 1,2,2,0
##emmcache = 2,2,2,0
#blockemm-unknown = 1
#blockemm-g = 1
#saveemm-u = 1
#saveemm-s = 1

#[reader]
#label = Ziggo1
#protocol = smargo
#device = /dev/ttyUSB1
#detect = cd
#group = 2
#emmcache = 1,2,2,0
##emmcache = 2,2,2,0
#blockemm-unknown = 1
#blockemm-g = 1
#saveemm-u = 1
#saveemm-s = 1

[reader]
label = SMARGO
description = Smartreader
protocol = smargo
device = /dev/ttyUSB0
smargopatch = 1
caid = 0500
detect = none
mhz = 600
cardmhz = 600
ident = 0500:0,FFF490,040210,040220,040230,040240
group = 1
emmcache = 1,3,2,0
#blockemm-unknown = 1
#blockemm-g = 1
saveemm-u = 1
saveemm-s = 1
ratelimitecm = 2
ratelimittime = 10000
srvidholdtime = 5000
lb_weight = 130
inactivitytimeout = 30

[reader]
label = SMARGO1
description = Smartreader
protocol = smargo
device = /dev/ttyUSB1
smargopatch = 1
caid = 0500
detect = cd
mhz = 600
cardmhz = 600
ident = 0500:0,FFF490,040210,040220,040230,040240
group = 2
emmcache = 1,5,15,0
#blockemm-unknown = 1
#blockemm-g = 1
saveemm-u = 1
saveemm-s = 1
ratelimitecm = 2
ratelimittime = 10000
srvidholdtime = 5000
lb_weight = 130
inactivitytimeout = 30

Tvheadend:
Mode: OSCam net protocol (rev >= 10389)
TCP Mode: 127.0.0.1
Port: 9000

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by saen acro over 2 years ago

do not comment use disable in Oscam UI
do you have some firewall enabled

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Markus Endres over 2 years ago

If your Provider is "yousee"

your reader should be somthing like this:

[reader]
label = SMARGO1
description = Smartreader
protocol = smargo
device = /dev/ttyUSB1
smargopatch = 1
caid = 0500
detect = cd
mhz = 357
cardmhz = 357
ident = 0500:040210
group = 1

what type of reader do you use?
okay, smartreader v2

best way:

lsusb -v | grep Serial

then you should see somthing like this

Bus 001 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT232 Serial (UART) IC
  idProduct          0x6001 FT232 Serial (UART) IC
  iSerial                 3 Reader 12345678

then use
protocol = smartreader
device = SRv2;Serial:12345678

Instead of
protocol = smargo
device = /dev/ttyUSB1

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Markus Endres over 2 years ago

And a new log of oscam (without serials) would help, too

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Peter LB over 2 years ago

Hi again thanks for the answer/guide.

Markus S: Yes, you are correct it's Yousee

Unfortunately it still won't get EMM's working. The "funny" thing is, that I've tested a similar setup with NewCS and Newcamd and it gets EMM right away, but I can't get it to work in Oscam which I want to use with dvbapi (it won't even work with newcamd in Oscam either:( )

I've updates the config files and here are the changes (have removed the # lines from this below, since it's not relevant)

Hope you can help, since it's really frustrating and I've spend many months on this to work.

oscam.conf: https://pastebin.com/g7S6bGLu

oscam.user: https://pastebin.com/aXdxsGsq

oscam.server:
https://pastebin.com/KBH18PTQ

Log are here:
https://pastebin.com/R7U4H0ph

For reference my settings in NewCS if you can use that for something:
newcs.xml: https://pastebin.com/YeEJJDfj

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by saen acro over 2 years ago

How is configured dvbapi client in TVH?
Is Oscam compiled by you, or taken from somewhere?

my dvbapi settings in oscam.conf
oscam-1.20-unstable_svn-r11399

[dvbapi]
enabled                       = 1
au                            = 1
pmt_mode                      = 4
request_mode                  = 1
listen_port                   = 9000
delayer                       = 60
user                          = dvbapi
read_sdt                      = 2
write_sdt_prov                = 1
extended_cw_api               = 1
boxtype                       = pc

do you touch oscam.dvbapi
an is there anything?
or if not add
P:0500:040210 1

save and restart oscam

What is situation with C or N line client in TVH

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Peter LB over 2 years ago

My oscam comes from Libreelec as an addon.
In TVHeadend it is configured like the NewCS (which works) when using Newcamd.

For DVBAPI:
Tvheadend:
Mode: OSCam net protocol (rev >= 10389)
TCP Mode: 127.0.0.1
Port: 9000

I don't have anything in oscam.dvbapi.

What is situation with C or N line client in TVH.
I don't know what that is.

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Markus Endres over 2 years ago

Try to add

emmreassembly = 0

To your account in oscam.user

If it doesn't work try

emmreassembly = 1

RE: Oscam + Tvheadend. Channels won't descramble. Please help. - Added by Peter LB over 2 years ago

In users it shows the EMM but nothing in readers. See pictures. I think we are getting close, but what can I do to get them right to readers.

(1-25/45)