schedule direct json grabber on ubuntu v20.04 lts

Added by B Majewski 6 months ago

hello all --

i've been trying to get my epg grabber to work under tvhe 4.2.8 in ubuntu 20.04 lts without much success.

i've downloaded tvheadend from the ubuntu software "store"; it was not an old-fashioned apt-get install.
after i got all my channels configured, mapped and everything in tvhead, i went to configure the epg grabber.
since i have a schedule direct account, might as well use that.

so i ran the script "tv_grab_zz_sdjson --configure" in /snap/tvheadend/152/usr/bin: it generated a config file in /root/.xmltv/.
the file name is "tv_grab_zz_sdjson.conf".
I then ran the script from the command-line (again, in /snap/tvheadend/152/usr/bin) to make sure everything was ok;
it ran successfully and generated a cache file in /root/.xmltv/.
that file name is "tv_grab_zz_sdjson.cache".
both files are owned by root, with rw,r,r permissions.

before choosing the epg grabber, i got the tvheadend log pane to show up (at the bottom of the window).

so i selected the schedules direct grabber (json interface, no sql lite), enabled it and clicked on "save".
tvheadend then tried to run "/snap/tvheadend/152/usr/bin/tv_grab_zz_sdjson", only to tell me i had to configure
the grabber by running it with --configure. (huh, i did it already?)
it also complained with "no output detected" and "grab returned no data".

thinking it might need a reboot for the new config (i disabled the over-the-air epg and enabled the scheduledirect
one) to kick in, i rebooted the box. that didn't help, same result.

i've tried to point it to the configuration file by specifying "--config-file ~/.xmltv/tvgrab_zz-sdjson.conf" in the
"extra arguments" field, to no avail.

am not sure what to do next, though i'm convinced the problem is staring me in the face and i can't see it.

anyone else run into this?

thanks in advance.

Replies (3)

RE: schedule direct json grabber on ubuntu v20.04 lts - Added by Ian Roberts 4 months ago

I'm running this on ubuntu 20.04 and have got it to work.
from your post it looks like you are running it as root instead of running it with the hts user.

I may be wrong, because I didnt install tvheadend via snap, I installed via the unofficial ubuntu/debian PPA (which is v4.2.9 if using stable version) - this runs tvheadend as hts user.

RE: schedule direct json grabber on ubuntu v20.04 lts - Added by Ian Roberts 4 months ago

If your having issues with running the "tv_grab_zz_sdjson --configure", let me know. I recall maybe having to substitute code from a newer version of the grabber. But this is only to generate the config file cause I've since moved my install of tvheadend to another host, and now only have the default xmltv package version of the sdjson grabber and everything still works.

RE: schedule direct json grabber on ubuntu v20.04 lts - Added by B Majewski 3 months ago

Reviving an old thread after too long.

Long story short, with some missing bits, as I am going from memory here:

Ended up getting the epg grabber working, after realising that the way software is packaged in the snap store, a lot of files that are used are not in the standard spots. You can see it in my original message (/snap/tvheadend/152/usr/bin/ ...). I had to figure out where some of the config files that are actually used by the grabber were and what to change in there.

Anyway, it all ended up working, but I kept getting error messages related to the JSON::XS module (again, going from memory + some of my notes), i.e. things are not accelerated and performance would suck. No matter what I did (IIRC, Perl version, compiling/installing JSON::XS, etc.) I kept getting those error messages. So obviously, the TVHE snap package was looking for stuff in places I could not identify.

So I resorted to brute force method, also motivated by the fact that most if not all documentation & tip/hints found online didn't work with the snap: I removed the TVHE snap and re-installed from Marley's PPA. Now everything works without any error messages re. JSON::XS or other performance-related concerns. I'm seeing a ten-fold increase in speed processing the EPG data downloaded from SchedulesDirect.

I would say that if you are installing from the PPA, you just have to make sure you have the right Perl version, the XMLTV package for starters. "make" & gcc are Good Things(tm) to have, also. Just in case.

Am now looking to see if I can make use of multiple EPG grabbers in TVHE. I've got tv_grab_zz_sdjson_sqlite running, grabbing a series of listings all over the place to get EPG data for my OTA channels + a third of my FTA channels. I have found some listings on the web for an added 7 FTA channels, but it would require to run two other grabbers from what I see -- i think webgrab+ could do the trick.

Now the question becomes: if I run even just one other grabber than tv_grab_zz_sdjson_sqlite, but at a different time (3 hours later), will the TVHE EPG show data from both grabbers? I guess there's only one way to find out... I'll post a follow-up to this after further experimentation.

If there is one thing or two I've learned in all of this, it's: (1) TAKE NOTES, (2) be ready for a lot of trial-and-error and (3) be ready to blow-up & reinstall what you did until you get it right.