Project

General

Profile

xmltv - zap2it - issue

Added by Joe Rizzo 2 months ago

Hi guys,

Hopefully i explain this properly. I used "script.xmltv.tvheadend" and followed this guide

https://github.com/rocky4546/script.xmltv.tvheadend/wiki/Guide:-How-to-Setup-XMLTV-for-TVHeadEnd#how-to-manually-update-the-epg

Had some bumps but I seem to finally was able to create a xmltv.xml file. My hopefully last hurdle is as follows. When I run the internal grabber in tvheadend I'm hit with the below error:

2018-10-10 13:04:56.000 xmltv: /usr/bin/tv_grab_file: grab /usr/bin/tv_grab_file
2018-10-10 13:04:56.002 spawn: Executing "/usr/bin/tv_grab_file"
2018-10-10 13:04:56.010 spawn: cat: /home/hts/.xmltv/xmltv.xml: Permission denied
2018-10-10 13:04:56.011 xmltv: /usr/bin/tv_grab_file: no output detected
2018-10-10 13:04:56.011 xmltv: /usr/bin/tv_grab_file: grab returned no data_

Ive tried changing rights to 777, deleting the symbolic link and rerunning the script to recreate everything. Manually recreating following the instructions on the site, but still the same error. Any help would be appreciated.

Thanks!


Replies (10)

RE: xmltv - zap2it - issue - Added by Joe User 2 months ago

what are the permissions of /home/hts and /home/hts/.xmltv? What are the permissions of the directory it is linked to?

RE: xmltv - zap2it - issue - Added by Joe Rizzo 2 months ago

Joe User wrote:

what are the permissions of /home/hts and /home/hts/.xmltv? What are the permissions of the directory it is linked to?

answered in the order in which you asked:

drwxrwxrwx 3 hts hts 4096 Oct 10 13:08 hts
lrwxrwxrwx 1 hts hts 25 Oct 10 13:08 .xmltv -> /home/administrator/xmltv
drwxrwxrwx 6 hts hts 4096 Oct 10 05:34 xmltv

RE: xmltv - zap2it - issue - Added by K Shea 2 months ago

sudo su hts
touch /home/hts/.xmltv/xmltv.xml

Then if you still get the error try changing the permissions on /home/hts/.xmltv/xmltv.xml to 777

If that doesn't work maybe you might find something helpful in https://freetoairamerica.wordpress.com/2014/12/03/some-hints-for-getting-free-to-air-satellite-channels-into-the-electronic-program-guide-in-kodi-or-xbmc-or-another-frontend/

RE: xmltv - zap2it - issue - Added by Joe Rizzo about 2 months ago

Unfortunately nothing worked. I am open to any other suggestions.

RE: xmltv - zap2it - issue - Added by Ron L about 1 month ago

/usr/bin/tv_grab_file is chmod 755?

RE: xmltv - zap2it - issue - Added by Joe Rizzo about 1 month ago

yes thats correct.

I forced it again, but regardless the error is the same as in the first post. Nothing works :(

RE: xmltv - zap2it - issue - Added by Joe User about 1 month ago

Joe Rizzo wrote:

Joe User wrote:

what are the permissions of /home/hts and /home/hts/.xmltv? What are the permissions of the directory it is linked to?

answered in the order in which you asked:

drwxrwxrwx 3 hts hts 4096 Oct 10 13:08 hts
lrwxrwxrwx 1 hts hts 25 Oct 10 13:08 .xmltv -> /home/administrator/xmltv
drwxrwxrwx 6 hts hts 4096 Oct 10 05:34 xmltv

the "hts" user probably does not have permission to see "/home/administrator", so it can not see "/home/administrator/xmltv" no matter what its permissions are.

The guide assumed some [user] which is normally not "administrator", which is a special user.

Better to just put the ".xmltv" directory directly in /home/hts

RE: xmltv - zap2it - issue - Added by Joe Rizzo about 1 month ago

so THAT worked!

But, please see the following output from tvheadend:
018-11-12 00:01:27.203 xmltv: /usr/bin/tv_grab_file: channels tot= 74 new= 0 mod= 0
2018-11-12 00:01:27.203 xmltv: /usr/bin/tv_grab_file: brands tot= 0 new= 0 mod= 0
2018-11-12 00:01:27.203 xmltv: /usr/bin/tv_grab_file: seasons tot= 0 new= 0 mod= 0
2018-11-12 00:01:27.203 xmltv: /usr/bin/tv_grab_file: episodes tot= 0 new= 0 mod= 0
2018-11-12 00:01:27.203 xmltv: /usr/bin/tv_grab_file: broadcasts tot= 0 new= 0 mod= 0

No new episodes, or anything? The xmltv.xml file is FULL of data, yet this output doesnt seem to be reflecting it, nor does the guide in Kodi. Any ideas?

RE: xmltv - zap2it - issue - Added by K Shea about 1 month ago

I'm guessing Tvheadend read the file just fine but it isn't associating the guide data with your channels. Now you need to go to the Configuration | Channels/EPG | Channels tab and for each channel pick an EPG source (refresh your browser if you don't see any). You may also need to set "Use EPG running state" to Enabled. Then go to the EPG Grabber tab and click the "Re-run Internal EPG Grabbers" link.

RE: xmltv - zap2it - issue - Added by Joe Rizzo about 1 month ago

that did it! Thanks

    (1-10/10)