Project

General

Profile

Internal epg grabber running every minute

Added by Tom Johnson almost 3 years ago

So, first, thanks to everyone that has helped me through my epg setup problems. It's all working. Perhaps too good! I have setup the tv_grab_file internal epg grabber

(per https://freetoairamerica.wordpress.com/2014/12/03/some-hints-for-getting-free-to-air-satellite-channels-into-the-electronic-program-guide-in-kodi-or-xbmc-or-another-frontend/ and https://github.com/Rigolo/tv-grab-file , thank you Sean Sean micklem)

and have the file being populated from an outside wget once per day at 2AM.

That is the only cron entry I have in any of my user crontab -e files.

In my tvheadend config tab "EPG Grabber", the "Internal Grabber - Cron Multi Line" has been left at the default

  1. Default config (00:04 and 12:04 everyday)
    4 */12 * * *

Yet for some reason, my internal grabber is running every minute.

Any ideas where else I can look to stop this?


Replies (1)

RE: Internal epg grabber running every minute - Added by K Shea almost 3 years ago

There is no reason whatsoever to run the internal grabber more than once a day, shortly after your wget is completed. If you get the file at 2 AM then try something like

15 2 * * *

To run the internal grabber at 2:15 AM.

But still, the line you used shouldn't be causing that problem since as you note it is the default setting. I'd try changing it just to see what happens, but if that doesn't help then I'd wonder what else might be going on. I have never seen that happen, but I have the default commented out and only run the grabber once a day. You didn't say what version you are running but if it's a nightly, you may have uncovered a bug!

EDIT: Also, I'd make sure you don't accidentally have any OTA grabbers enabled.

    (1-1/1)