Bug #524

SVN-r5788: RTSP streaming non-functional

Added by Bob C over 6 years ago. Updated over 5 years ago.

Status:InvalidStart date:2011-05-21
Priority:NormalDue date:
Assignee:Hein Rigolo% Done:

0%

Category:Streaming
Target version:-
Found in version:2.12 svn5788 Affected Versions:

Description

Build: SVN-r5788
System: Ubuntu 11.04

On the Configuration -> TV Adapters -> Services page: Clicking any of the Play links does nothing (browser problem). The channels are viewable via the links on the Configuration -> Channels page.

I copied the RTSP URL to mplayer, and got the following:

$ mplayer rtsp://127.0.0.1:9981/service/_dev_dvb_adapter0_Auvitek_AU8522_QAM_8VSB_Frontend549000000_07db
MPlayer 1.0rc4-4.5.2 (C) 2000-2010 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing rtsp://127.0.0.1:9981/service/_dev_dvb_adapter0_Auvitek_AU8522_QAM_8VSB_Frontend549000000_07db.
Resolving 127.0.0.1 for AF_INET6...
Couldn't resolve name for AF_INET6: 127.0.0.1
Connecting to server 127.0.0.1[127.0.0.1]: 9981...
librtsp: server responds: 'RTSP/1.0 503 No input detected'
rtsp_session: unsupported RTSP server. Server type is 'unknown'.
STREAM_LIVE555, URL: rtsp://127.0.0.1:9981/service/_dev_dvb_adapter0_Auvitek_AU8522_QAM_8VSB_Frontend549000000_07db
Stream not seekable!
 file format detected.
Failed to get a SDP description from URL "rtsp://127.0.0.1:9981/service/_dev_dvb_adapter0_Auvitek_AU8522_QAM_8VSB_Frontend549000000_07db": 503 No input detected

Exiting... (End of file)

In the tvheadend System Log:

May 18 21:01:55 subscription: "RTSP" direct subscription to adapter: "HD Cable", network: "", mux: "549,000 kHz", provider: "", service: "", quality: 100
May 18 21:02:05 subscription: "RTSP" unsubscribing
May 18 21:02:05 RTSP: 127.0.0.1: rtsp://127.0.0.1:9981/service/_dev_dvb_adapter0_Auvitek_AU8522_QAM_8VSB_Frontend549000000_07db -- No input detected

History

#1 Updated by Hein Rigolo about 6 years ago

  • Category changed from DVB to Streaming
  • Found in version set to 2.12 svn5788

#2 Updated by Hein Rigolo about 6 years ago

  • Assignee changed from Andreas Öman to Hein Rigolo

#3 Updated by John Törnblom over 5 years ago

  • Status changed from New to Resolved

RTSP has been removed from TVHeadend so the issue is not valid any more

#4 Updated by Adam Sutton over 5 years ago

  • Status changed from Resolved to Invalid

Also available in: Atom PDF