Bug #4836

Bug #4835: TVHeadend crashes when the end of a recording is reached while fast-forwarding in Kodi

TVHeadend doesn't play recordings over HTSP from version 4.3-909_g50ab53f_xenial_amd64

Added by Christian Völkel 11 days ago. Updated 6 days ago.

Status:RejectedStart date:2018-01-07
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Crashes
Target version:-
Found in version:4.3-909_g50ab53f_xenial_amd64 Affected Versions:

Description

Hello, first thanks for your great work, i have the following issue since version 4.3-909_g50ab53f_xenial_amd64:
TVHeadend doesn't play recordings over HTSP and crashes:

2018-01-07 21:14:21.098 htsp: Opening file /home/hts/2018-01-06_17-35_ZDF HD_plan b: Weniger ist mehr_Vom Glueck anders zu wirtschaften_Staffel: 1, Folge: 10.ts -- OK
2018-01-07 21:14:21.811 htsp: 192.168.160.100 [ wohnzimmer | Kodi Media Center ]: failed to serialize data
2018-01-07 21:14:26.812 htsp: 192.168.160.100 [ wohnzimmer | Kodi Media Center ]: Disconnected
2018-01-07 21:14:26.812 htsp: Closed opened file /home/hts/2018-01-06_17-35_ZDF HD_plan b: Weniger ist mehr_Vom Glueck anders zu wirtschaften_Staffel: 1, Folge: 10.ts
2018-01-07 21:14:26.812 subscription: 0003: "HTSP" unsubscribing, hostname="192.168.160.100", username="wohnzimmer", client="Kodi Media Center"
2018-01-07 21:14:26.813 htsp: Got connection from 192.168.160.100
2018-01-07 21:14:26.813 htsp: 192.168.160.100: Welcomed client software: Kodi Media Center (HTSPv25)
2018-01-07 21:14:26.813 htsp: 192.168.160.100 [ Kodi Media Center ]: Identified as user 'wohnzimmer'
2018-01-07 21:14:26.813 htsp: 192.168.160.100 [ wohnzimmer | Kodi Media Center ]: Privileges updated
2018-01-07 21:14:26.814 htsp: Opening file /home/hts/2018-01-06_17-35_ZDF HD_plan b: Weniger ist mehr_Vom Glueck anders zu wirtschaften_Staffel: 1, Folge: 10.ts -- OK
2018-01-07 21:14:31.818 htsp: 192.168.160.100 [ wohnzimmer | Kodi Media Center ]: Disconnected
2018-01-07 21:14:31.818 htsp: Closed opened file /home/hts/2018-01-06_17-35_ZDF HD_plan b: Weniger ist mehr_Vom Glueck anders zu wirtschaften_Staffel: 1, Folge: 10.ts
2018-01-07 21:14:31.818 subscription: 0004: "HTSP" unsubscribing, hostname="192.168.160.100", username="wohnzimmer", client="Kodi Media Center"
2018-01-07 21:14:46.823 htsp: Got connection from 192.168.160.100
2018-01-07 21:14:46.823 htsp: 192.168.160.100: Welcomed client software: Kodi Media Center (HTSPv25)
2018-01-07 21:14:46.824 htsp: 192.168.160.100 [ Kodi Media Center ]: Identified as user 'wohnzimmer'
2018-01-07 21:14:46.824 htsp: 192.168.160.100 [ wohnzimmer | Kodi Media Center ]: Privileges updated

Linux is giving the following hint:
[ 228.463324] tvh:htsp-write2814: segfault at 1 ip 00007f53e4087840 sp 00007f53a59cb7e8 error 4 in libc-2.23.so[7f53e3fe8000+1c0000]

History

#2 Updated by bas t 9 days ago

Hello.
I've been investigating the exact same issue. On my Debian Stretch system, tvheadend does not crash, but all other symptons are the same.
Reverting the 'offending' commit does indeed solve the problem.
Cheers,
Tycho.

#3 Updated by Michael Marley 7 days ago

This looks like a dupe of https://tvheadend.org/issues/4835.

#4 Updated by Jaroslav Kysela 6 days ago

  • Status changed from New to Rejected
  • Parent task set to #4835

Also available in: Atom PDF