Bug #4720

Kodi not showing recordings that were not created from within Kodi for an unknown reason

Added by Tuomas Jormola 12 days ago. Updated 8 days ago.

Status:FixedStart date:2017-11-10
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Found in version:4.2.3 Affected Versions:

Description

See https://tvheadend.org/boards/14/topics/29458?r=29519 for initial discussion of this problem.

Only recordings initiated from within Kodi appear in the recordings listing of Kodi. Recordings done by timers created from Tvheadend EPG guide or autorec entries remain absent. The user that the Kodi Tvheadend addon uses has pretty much everything enabled access wise. See the attached screenshot showing the user config and all finished recordings in Tvheadend and Kodi showing the view available for it. Tvheadend seem to work great otherwise.

Using Tvheadend 4.2.3 on Ubuntu 16.04, installed from the official Tvheadend APT repository, Kodi 17.5 on various client OSes and pvr.hts 3.4.27. Attached you'll find debug log of Tvheadend and debug log of Kodi client running on macOS demonstraing a short session where Kodi is started, the recordings view is accessed and then exit Kodi and Tvheadend is restarted thus ending the log.

kodi.log.txt Magnifier - Kodi debug log showing connection to Tvheadend (154 KB) Tuomas Jormola, 2017-11-10 01:59

tvheadend.log.txt Magnifier - Tvheadend debug log with all subsystems while Kodi connects (1.74 MB) Tuomas Jormola, 2017-11-10 01:59

Screen Shot 2017-11-10 at 0.36.03.png - Tvheadend user setup and the list of stored recordings (1.33 MB) Tuomas Jormola, 2017-11-10 01:59

Associated revisions

Revision 1510fa0a
Added by Jaroslav Kysela 12 days ago

htsp server: try to play correctly with older htsp clients (DVR prio NOTSET), fixes #4720

History

#1 Updated by Jaroslav Kysela 12 days ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

#2 Updated by Jaroslav Kysela 12 days ago

  • Status changed from Fixed to New
  • % Done changed from 100 to 0

Fixed in v4.2.4-14-g1510fa0a8 .

#3 Updated by Tuomas Jormola 11 days ago

I can confirm that this fixes the problem for me, thanks.

#4 Updated by Jaroslav Kysela 8 days ago

  • Status changed from New to Fixed

Also available in: Atom PDF