Bug #4701

Only audio gets played in a IPTV stream

Added by pinkflozd lk 19 days ago. Updated 8 days ago.

Status:FixedStart date:2017-11-03
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:IPTV
Target version:-
Found in version:4.3-git Affected Versions:

Description

Hello. lately i've been having more and more of this errors.
tsfix: The timediff for AAC-LATM is big (266165), using current dts

The stream gets only audio played. To get the video working i have to play and stop the channel a few times. Attached a 30s stream example.
It's a IPTV stream

b.ts (7.34 MB) pinkflozd lk, 2017-11-03 10:09

Associated revisions

Revision 910fef46
Added by Jaroslav Kysela 19 days ago

service: use s_pending_restart more properly, issue #4701

Revision a5ecd97a
Added by Jaroslav Kysela 18 days ago

tsfix: take in account negative pcr for the video stream, issue #4701

History

#1 Updated by Jaroslav Kysela 19 days ago

Give a test with v4.3-604-g910fef467 .

#2 Updated by pinkflozd lk 18 days ago

it works better for a few channels now. but for the same mux as i posted i get this now:
2017-11-04 12:11:17.760 tsfix: The timediff for TELETEXT is big (365400), using current dts
2017-11-04 12:11:26.905 tsfix: transport stream TELETEXT, DTS discontinuity. DTS = 900000, last = 0
still no picture only audio

#3 Updated by Jaroslav Kysela 18 days ago

v4.3-607-ga5ecd97a9 . Otherwise, provide the non-working .ts input again.

#4 Updated by pinkflozd lk 17 days ago

v4.3-607-ga5ecd97a9 fixed it.
thanks to all the hard work you are putting in it

#5 Updated by Jaroslav Kysela 8 days ago

  • Status changed from New to Fixed

Also available in: Atom PDF