Tvheadend packages for Synology NAS

Added by Martin Walter about 1 year ago

For those interested in native (non-docker) Tvheadend packages for their Synology NAS systems, you will find recent release packages (currently 4.2.6) published here:

https://synocommunity.com/

Test packages for future releases might be advertised and tested here again, but for the time being, please report any Synology package-specific issues with the Synocommunity, i.e. here:

https://github.com/SynoCommunity/spksrc/issues


Some important remarks for test packages (currently not applicable):
  • All packages provided here are beta packages. Use at your own risk.
  • Always back up your Tvheadend configuration before you upgrade!
  • You cannot upgrade from a Tvheadend-Testing to a Tvheadend release package or vice versa. These packages have separate configurations. NEVER run a testing and a release package in parallel.
  • The upgrade process may take several minutes as recordings might have to be moved. Please be patient if the upgraded package does not start right away.
  • The release packages are very recent and up-to-date. I highly recommend staying away from testing packages at the moment, unless you cannot run the release packages for whatever reason and you know what you are doing.
  • If you are already running a package, which you have downloaded from here, upgrading should be safe (backup anyway!)
  • Otherwise, I recommend clean installations, especially if you have already installed packages from different sources and you have had trouble with user permissions in the past. There is some likelihood they are messed up. Also:
    - If you are currently running a Tvheadend-Testing package and you want to install a release package, you will have to start configuring it from scratch anyways.
    - If you are running an old release package on DSM5.2 and you want to upgrade your DSM and Tvheadend, upgrade your DSM first, only then upgrade TVH with a new release package. However, depending on how old your old release package is, you might still run into hicups. If that happens, you are most likely better off starting a clean configuration from scratch, too.

Updates / Edits:
- 08.05.2018: TVH 4.2.6 packages have been published on the Synocommunity repository. Link added.
- 14.04.2018: Update to TVH 4.2.6 (latest maintenance release) and fixes for installations on non-standard volumes
- 24.03.2018: Update fixing recordings being stored in the wrong place
- 26.01.2018: Added upgrading instructions
- 16.01.2018: Update to TVH 4.2.5 (latest maintenance release)
- 21.10.2017: Update to TVH 4.2.4 (latest maintenance release)


Replies (184)

RE: Tvheadend packages for Synology NAS - Added by P L 6 months ago

@Martin Walter

The log that shows Tvheadend crashing was uploaded in my previous post. Other than that I don't see additional log entries. Uploading again just in case.

tvheadend.log (6.95 KB)

RE: Tvheadend packages for Synology NAS - Added by Russel Crowe 6 months ago

@ Chad d

Please look in the webif of tvheadend if it is realy not running. In my case it was but the center called it wasn't.

If you have video station installed and running, please give it a try and stop video station.
This helps in my case.
otherwise try login via ssh
sudo /var/packages/tvheadend/scripts/start-stop-status stop
Then try to start with packet centre

RE: Tvheadend packages for Synology NAS - Added by Martin Walter 6 months ago

P L wrote:

@Martin Walter

It is stable as long as I don’t stop the package. If I do, I cannot start it again. Only thing that enables me to start it again is if I reboot DSM and try starting the package repeatedly.

@P L:
I was referring to your statement above, i.e. the fact that the package does not start again after you have stopped it. Can you provide a different log-file containing that behavior or are you telling me that you can reproduce crashes that way like in the log-file you have shared?

RE: Tvheadend packages for Synology NAS - Added by Chad d 6 months ago

Russel Crowe wrote:

@ Chad d

Please look in the webif of tvheadend if it is realy not running. In my case it was but the center called it wasn't.

If you have video station installed and running, please give it a try and stop video station.
This helps in my case.
otherwise try login via ssh
sudo /var/packages/tvheadend/scripts/start-stop-status stop
Then try to start with packet centre

wow, thank you. I looked at webif and it was running just as you suspected. Weird. I'm not running Video Station, is it possible a different package could be causing the conflict? Running channel scan now. After I back up and running I will log in and do a status stop and see if that allows package center to start run.

RE: Tvheadend packages for Synology NAS - Added by Chad d 6 months ago

After running through wizard, scanning channels and finishing configuration, then going back to webif, in package center, selecting run for TVheadend package starts up normal. Thank you again.

RE: Tvheadend packages for Synology NAS - Added by P L 6 months ago

Martin Walter wrote:

@P L:
I was referring to your statement above, i.e. the fact that the package does not start again after you have stopped it. Can you provide a different log-file containing that behavior or are you telling me that you can reproduce crashes that way like in the log-file you have shared?

@Martin Walter
Yes I can reproduce the crash. Here goes the logs:
1 - Tvheadend running and then stopped (tvheadend_1.log)
2 - I tried starting Tvheadend one time (tvheadend_2.log) but package remained in a stopped state. Strangely the log shows no signed of Tvheadend being stopped, on the contrary.
3 - I tried starting Tvheadend again but no crash was seen in the logs again. So I tried starting Tvheadend again (tvheadend_3.log). That's when I could see the crash in the logs.

I am able to reproduce the crash but not consistently. It doesn't happen each time I start Tvheanded. Perhaps every 2 to 3 attempts sometimes every 4 or 5 attempts. No matter whether Tvheadend is crashed or not Tvheadend will be in a stopped state until I reboot and I try starting it again multiple times.

tvheadend_1.log - Tvheadend running (89.3 KB)

tvheadend_2.log - Tvheadend stopped (3.8 KB)

tvheadend_3.log - Tvheadend re-start>crash (6 KB)

RE: Tvheadend packages for Synology NAS - Added by Martin Walter 6 months ago

@P L : Thanks for getting back and providing all the logs. Much appreciated. I have compared your logfiles with mine. Still digging, but maybe an idea: What kind of tuners are you using? DVB-something (USB / otherwise)? A Sat>IP server? Or no tuners at all (just IPTV or similar)?

RE: Tvheadend packages for Synology NAS - Added by Martin Walter 5 months ago

Upgrades to the latest maintenance release (TVH 4.2.6) are now available (see post #1). The new packages contain a fix for installations on non-standard volumes. As always, don't forget to backup before upgrading and keep reporting any issues you might run into.

RE: Tvheadend packages for Synology NAS - Added by Chad d 5 months ago

@Martin Walter
Thank you for the latest update (and all priors). Any interest in integrating comskip?

RE: Tvheadend packages for Synology NAS - Added by Martin Walter 5 months ago

I believe a comskip package is already available, as beta, but still...
https://synocommunity.com/package/comskip

RE: Tvheadend packages for Synology NAS - Added by Olof Sandberg 5 months ago

Martin Walter wrote:

Upgrades to the latest maintenance release (TVH 4.2.6) are now available (see post #1). The new packages contain a fix for installations on non-standard volumes. As always, don't forget to backup before upgrading and keep reporting any issues you might run into.

Thanks a lot!
This new version starts on first try on DS418j, running DS6.2(beta). However, after stopping the package, it doesn't start again until after a DS reboot. Nothing is visible in the TVH log either.
After the reboot, it starts automatically.

RE: Tvheadend packages for Synology NAS - Added by P L 5 months ago

Martin Walter wrote:

@P L : Thanks for getting back and providing all the logs. Much appreciated. I have compared your logfiles with mine. Still digging, but maybe an idea: What kind of tuners are you using? DVB-something (USB / otherwise)? A Sat>IP server? Or no tuners at all (just IPTV or similar)?

No worries. I still don't have a tuner so I can't even test Tvheadend for what it is supposed to do.

Martin Walter wrote:

Upgrades to the latest maintenance release (TVH 4.2.6) are now available (see post #1). The new packages contain a fix for installations on non-standard volumes. As always, don't forget to backup before upgrading and keep reporting any issues you might run into.

That update seems to have fixed the start/stop issue. I updated the package to 4.2.6 and now Tvheadend starts and stops gracefully reliably.

RE: Tvheadend packages for Synology NAS - Added by Martin Walter 5 months ago

@Olof Sandberg : OK, at least you have got a way to get it running then. I'm really out of ideas what might cause this, but will keep it in mind. Maybe others run into the problem too, which might give us more hints on the rationales. I hope you can still use the package despite those limitations for the time being...

@P L: Great. Then it was most likely an issue with the old 4.2.5 version rather than the Synology-specific packaging. Either way: As long as it works, you can finally purchase and install your tuners now! ;-)

RE: Tvheadend packages for Synology NAS - Added by Olof Sandberg 5 months ago

Martin Walter wrote:

@Olof Sandberg : OK, at least you have got a way to get it running then. I'm really out of ideas what might cause this, but will keep it in mind. Maybe others run into the problem too, which might give us more hints on the rationales. I hope you can still use the package despite those limitations for the time being...

Oh, I'm super grateful for your work! The package error is not really a big problem, since the build is really stable. And this is a big step-up in terms of my IPTV experience. Thanks a lot!!!

RE: Tvheadend packages for Synology NAS EPG time - Added by Richard Vogt 5 months ago

I'm having a problem with the EPG time on my Synology DS918 running TVHeadend 4.2.5-12. All EPG times are always wrong listed in UTC time (2 hours too early) but the Synology server has correct UTC+2 time, the network under DVB-Input is set to locale time and even when I set it to UTC+2 the EPG time still remains wrong (UTC time). On my second server DS-916 I'm having exactly the same problem.

RE: Tvheadend packages for Synology NAS - Added by Martin Walter 5 months ago

Try setting the time in the tvh-network tab to UTC.

RE: Tvheadend packages for Synology NAS - Added by Richard Vogt 5 months ago

Perfect solution, works on both servers. But has to be corrected in the software, because makes not much sense as it is right now.;)

RE: Tvheadend packages for Synology NAS - Added by Peter Schneider 5 months ago

Having difficulties on a DS216j with DSM 6.1.6-15266 (Update 1) when trying to install the latest TVH version (4.2.6, armada 38x build): The package does not start in the package manager. When trying to start in manually in /var/packages/tvheadend/scripts/, I get the following errors:

./service-setup: line 6: [: : integer expression expected
Starting ...
./service-setup: line 18: type: service_prestart: not found
./start-stop-status: line 29: [: : integer expression expected

Seems that several of the required parameters like "SYNOPKG_DSM_VERSION_MAJOR" are not available on my system.

What should I do?

Thanks a lot in advance!

RE: Tvheadend packages for Synology NAS - Added by Martin Walter 5 months ago

First of all, give it time. After the upgrade and before starting, TVH performs a backup, which can take several minutes. Then, recordings might have to be moved, which can take a lot of time. Just start it and let it run for an hour or so (ignore the run state in the package manager). After waiting, try to log into the TVH Web-userinterface. IF it works, fine. If not, provide log files please. You will find instructions how to retrieve those if you read back into this thread.

Btw, the package has to be started via the package manager. It cannot be started manually anymore.

RE: Tvheadend packages for Synology NAS - Added by Martin Walter 5 months ago

The 4.2.6 package you guys have tested has been accepted and published on the Synocommunity repository and can be obtained from there. This thread might be reactivated with future testing packages. For the time begin, please report any Synology-package specific issues with the Synocommnity. The initial post has been updated and contains the relevant links. Many thanks to all testers and contributors here!

RE: Tvheadend packages for Synology NAS - Added by Steven Moschidis 4 months ago

I have just installed the (latest version of this) package on my Synology DS1515+ running the latest DSM.
I have a dual tuner HDHomeRun.
I am based in the UK.

I am a noob, so I have no idea what I'm doing. However, having set up a network and linked it to the two tuners I am stuck. When I click on Force scan, nothing happens (nothing in the logs either).

I am doing something wrong for sure, but seeing as there are 0 docs for these things, I fail to see what I could try.

Any ideas?

RE: Tvheadend packages for Synology NAS - Added by Martin Walter 4 months ago

As long as the tuners show up, you are in a good place.
Take a look here:
http://docs.tvheadend.org/configure_tvheadend/
This is work-in-progress but contains the key elements.
Or search the internet for some other standard configuration instructions.

Basically, you have to
(1) Define the right network you are using (probably US_ATSC, but not sure)
(2) Assign the networks to the tuners AND activate the tuners
(3) Scan for muxes and services
(4) Map services to channels

Click on the little cog wheel on the lower right hand side of the web interface to see log entries. This definitely helps to see when something goes wrong in one of the steps above...

RE: Tvheadend packages for Synology NAS - Added by Steven Moschidis 4 months ago

Thank you Martin.
I have defined the network; like I said, I'm based in the UK.
I have indeed read through that wiki article, but it offers no relevant information.
I'm surprised that there are no docs for setting this stuff up. I'm thinking of typing it all up, if I manage to figure it out.

In any case, like I said, my issue is that "Force scan" does nothing. And as I said there is nothing in the logs either.

One weird thing was that my HDHomeRun was not identified as DVB-T, but DVB-C. I had to force it to DVB-T.

Does anyone have any relevant information based on the above?

RE: Tvheadend packages for Synology NAS - Added by Mark Clarkstone 4 months ago

Steven Moschidis wrote:

Thank you Martin.
I have defined the network; like I said, I'm based in the UK.
I have indeed read through that wiki article, but it offers no relevant information.
I'm surprised that there are no docs for setting this stuff up. I'm thinking of typing it all up, if I manage to figure it out.

In any case, like I said, my issue is that "Force scan" does nothing. And as I said there is nothing in the logs either.

One weird thing was that my HDHomeRun was not identified as DVB-T, but DVB-C. I had to force it to DVB-T.

Does anyone have any relevant information based on the above?

When Martin says "Scan for muxes and services" he means you either need to manually add the frequencies or use a pre-defined list (not recommended as they're out of date).

Here's an example of my mux list.

RE: Tvheadend packages for Synology NAS - Added by Steven Moschidis 4 months ago

So are you saying that I have to manually add all the muxes (as the predefined lists are fubar)?

I thought the "Force scan" option in the network tab was supposed to make tvheadend discover all available muxes direct from the tuner. Is that not the case? If not, then why not? What is it supposed to do?

I have a friend who set up tvheadend on a pi (or nuc) using the same hdhomerun as I have. He fired up tvheadend, added the network, linked it to the tuners, hit the force-scan button and the muxes appeared.

1 ... 4 5 6 7 8 (126-150/184)