WinTV-dualHD Raspbian

Added by Scott Shepard 2 months ago

I have setup a Raspberry Pi 3 running Raspbian and have installed tvheadend successfully. I have also purchased a Hauppauge WinTV-DualHD tuner (Model 1597). So restarting the Pi and looking at the configuration page I can see two devices listed as connected which is a great start:

TV Adapters
/dev/dvb/adapter0 [Silicon Labs Si2168]
Silicon Labs Si2168 : DVB-C #0
Silicon Labs Si2168 : DVB-T #0

So I start configuring DVB-T because I know that is what is used in Melbourne Australia. Below is what I end up with:

See attached picture 1.png for TV Adapter setup

So far so good i then add the network DVB-T choosing Pre-defined muxes "Australia: au-Melbourne" which successfully sets up all the Muxes

See attached picture 2.png for Networks setup

I then hit force scan and tvheadend dutifully starts down the list of Muxes but each one in turn then fails. I know the Hauppauge card works because I have successfully used it on the same cable with the provided windows software on a laptop.

See attached picture 3.png for Muxes errors

Is there something I am missing that could cause this to fail?

Scott

1.PNG - TV Adapters (35.6 KB)

2.PNG - Networks (46.5 KB)

3.PNG - Muxes (104 KB)


Replies (2)

RE: WinTV-dualHD Raspbian - Added by Mark Clarkstone 2 months ago

Scott Shepard wrote:

I have setup a Raspberry Pi 3 running Raspbian and have installed tvheadend successfully. I have also purchased a Hauppauge WinTV-DualHD tuner (Model 1597). So restarting the Pi and looking at the configuration page I can see two devices listed as connected which is a great start:

TV Adapters
/dev/dvb/adapter0 [Silicon Labs Si2168]
Silicon Labs Si2168 : DVB-C #0
Silicon Labs Si2168 : DVB-T #0

So I start configuring DVB-T because I know that is what is used in Melbourne Australia. Below is what I end up with:

See attached picture 1.png for TV Adapter setup

So far so good i then add the network DVB-T choosing Pre-defined muxes "Australia: au-Melbourne" which successfully sets up all the Muxes

See attached picture 2.png for Networks setup

I then hit force scan and tvheadend dutifully starts down the list of Muxes but each one in turn then fails. I know the Hauppauge card works because I have successfully used it on the same cable with the provided windows software on a laptop.

See attached picture 3.png for Muxes errors

Is there something I am missing that could cause this to fail?

Scott

  • Check dmesg, make sure you're not missing firmware.
  • Don't use the pre-defined muxes, they're extremely outdated - add your own manually. A quick google returned this, not sure how correct this is as it's I'm in the UK. Be careful to enter the right number of zeros, e.g. 666000000.
  • Provided you have Network (or mux) discovery enabled you generally only need to add one, tvheadend can usually find the rest. Note, not all countries use NIT so manual entry for each mux might be needed. YMMV.

RE: WinTV-dualHD Raspbian - Added by Scott Shepard 2 months ago

Check dmesg, make sure you're not missing firmware.

Thank you Mark Clarkstone your first point was the right one, I honestly had no idea how to check dmesg for missing firmwares but searched online for firmware for the WinTV-dualHD and came upon the below page:

https://www.linuxtv.org/wiki/index.php/Hauppauge_WinTV-dualHD

which had a firmware download link:
http://palosaari.fi/linux/v4l-dvb/firmware/Si2168/Si2168-B40/4.0.11/dvb-demod-si2168-b40-01.fw

I just copied the file to the /lib/firmware folder rebooted the Pi and boom it started picking up all the channels no trouble, so simple.

Thanks so much for the quick assistance. Some of my Googling I did see a comment about the default melbourne muxes missing a couple entries I will need to come back to that, for now I'm just happy to see it doing something at least.

Thanks again for the help Mark.

Scott

(1-2/2)