Repository problem?

Added by FuN KeY about 2 years ago

Hello everyone,

Starting tonight I am unable to update tvheadend using the apt repository.

At the time I did follow the procedure described here: https://bintray.com/tvheadend/ubuntu and it worked pretty well.

Here is what I now get when I try to do an "apt-get update"

Ign:5 https://dl.bintray.com/tvheadend/ubuntu master InRelease
Ign:6 https://dl.bintray.com/tvheadend/ubuntu master Release
Ign:7 https://dl.bintray.com/tvheadend/ubuntu master/main amd64 Packages.diff/Index
Ign:8 https://dl.bintray.com/tvheadend/ubuntu master/main i386 Packages.diff/Index
Ign:9 https://dl.bintray.com/tvheadend/ubuntu master/main all Packages
Ign:10 https://dl.bintray.com/tvheadend/ubuntu master/main Translation-en_US
Ign:11 https://dl.bintray.com/tvheadend/ubuntu master/main Translation-en
Ign:12 https://dl.bintray.com/tvheadend/ubuntu master/main amd64 Packages
Ign:13 https://dl.bintray.com/tvheadend/ubuntu master/main i386 Packages
Ign:9 https://dl.bintray.com/tvheadend/ubuntu master/main all Packages
Ign:10 https://dl.bintray.com/tvheadend/ubuntu master/main Translation-en_US
Ign:11 https://dl.bintray.com/tvheadend/ubuntu master/main Translation-en
Ign:12 https://dl.bintray.com/tvheadend/ubuntu master/main amd64 Packages
Ign:13 https://dl.bintray.com/tvheadend/ubuntu master/main i386 Packages
Ign:9 https://dl.bintray.com/tvheadend/ubuntu master/main all Packages
Ign:10 https://dl.bintray.com/tvheadend/ubuntu master/main Translation-en_US
Ign:11 https://dl.bintray.com/tvheadend/ubuntu master/main Translation-en
Ign:12 https://dl.bintray.com/tvheadend/ubuntu master/main amd64 Packages
Ign:13 https://dl.bintray.com/tvheadend/ubuntu master/main i386 Packages
Ign:9 https://dl.bintray.com/tvheadend/ubuntu master/main all Packages
Ign:10 https://dl.bintray.com/tvheadend/ubuntu master/main Translation-en_US
Ign:11 https://dl.bintray.com/tvheadend/ubuntu master/main Translation-en
Ign:12 https://dl.bintray.com/tvheadend/ubuntu master/main amd64 Packages
Ign:13 https://dl.bintray.com/tvheadend/ubuntu master/main i386 Packages
Ign:9 https://dl.bintray.com/tvheadend/ubuntu master/main all Packages
Ign:10 https://dl.bintray.com/tvheadend/ubuntu master/main Translation-en_US
Ign:11 https://dl.bintray.com/tvheadend/ubuntu master/main Translation-en
Ign:12 https://dl.bintray.com/tvheadend/ubuntu master/main amd64 Packages
Ign:13 https://dl.bintray.com/tvheadend/ubuntu master/main i386 Packages
Ign:9 https://dl.bintray.com/tvheadend/ubuntu master/main all Packages
Ign:10 https://dl.bintray.com/tvheadend/ubuntu master/main Translation-en_US
Ign:11 https://dl.bintray.com/tvheadend/ubuntu master/main Translation-en
Err:12 https://dl.bintray.com/tvheadend/ubuntu master/main amd64 Packages
  404  Not Found
Err:13 https://dl.bintray.com/tvheadend/ubuntu master/main i386 Packages
  404  Not Found
Fetched 94.5 kB in 1s (55.5 kB/s)
Reading package lists... Done
W: The repository 'https://dl.bintray.com/tvheadend/ubuntu master Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://dl.bintray.com/tvheadend/ubuntu/dists/master/main/binary-amd64/Packages  404  Not Found
E: Failed to fetch https://dl.bintray.com/tvheadend/ubuntu/dists/master/main/binary-i386/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Anyone else with the problem?


Replies (45)

RE: Repository problem? - Added by Diego Rivera about 2 years ago

Confirmed! Attempting to access [[https://dl.bintray.com/tvheadend/deb/dists/jessie/Release]] results in an HTTP 403 Forbidden error, likewise other files (Packages, etc.).

Probably a permissions issue on the build scripts - not generating the target files with the necessary permissions.

RE: Repository problem? - Added by Daniel Alexandre about 2 years ago

I Have the same problem i try make the instalation but show me the same error.

Problem with repository?

Someone knows other way to install the tvheadend?

I work with ubuntu server

RE: Repository problem? - Added by FuN KeY about 2 years ago

I made a bug report out of the problem https://tvheadend.org/issues/3866

RE: Repository problem? - Added by Jonathan Thomson about 2 years ago

The official/new TVHeadend repository is very unreliable - I see regular 403 errors when trying to update (I'm on the 'unstable' branch so get updates almost every day...or would do if the repository was up).

I have switched to using the legacy repository (which according to the wiki will be maintained for the foreseeable) which seems to be in sync with the new repository and have seen no such problems to date.

See here for how to add or switch to the legacy repository: http://tvheadend.org/projects/tvheadend/wiki/AptRepository

RE: Repository problem? - Added by Diego Rivera about 2 years ago

As I recall, the legacy repo doesn't carry some ARM builds, which are only available in the "new" repo.

RE: Repository problem? - Added by Jonathan Thomson about 2 years ago

Good shout - for those on x86_64 builds I would definitely recommend adding or replacing the main repository with the legacy one until the issues are fixed.

RE: Repository problem? - Added by Jason Weathered about 2 years ago

Thinking there was an issue with Bintray itself, I sent them a support ticket earlier today. Here’s their reply just now:

You're Bintray account is currently blocked for exceeding its storage quota (14GB/10GB). This looks like it's due to a large number of .work directories stored under your account. Bintray is a distribution platform intended primarily for release versions. If your goal is to host snapshots that are consumed by CI builds, we recommend using Artifactory Online.

Once you've reduced your storage usage to within the account's limits (10GB), please let us know and we will unblock your account.

RE: Repository problem? - Added by Diego Rivera about 2 years ago

I would recommend that builds be done "elsewhere", and thus only use Bintray for distribution.

Then again, I'm unfamiliar with the particulars of Bintray or the build process.

RE: Repository problem? - Added by Thorsten Steinbrenner about 2 years ago

Is there another repository out there to install thveadend on my Raspberry without compiling it myself?

THX!

RE: Repository problem? - Added by Cédric M. about 2 years ago

Hello.

Up. Same problem here on a raspbian.
I've to prepare a rpi for a friend of mine, and I'm stuck by this problem :'(

It's strange to see that nobody take care of this since a week; even the ticket is a dead letter.
For me it's a critical issue, I'm really surprised of so few complaints.

Well, hopefully someone with "power" will pass by here ... the soonest will be the better :D

Thanks.

RE: Repository problem? - Added by Thorsten Steinbrenner about 2 years ago

Agree! I'm also kind of frustrated waiting for someone to fix it.... Well it's an open source project thus the only thing we can do is to be patient and wait......

Thanks!

Regards

RE: Repository problem? - Added by Cédric M. about 2 years ago

Thorsten Steinbrenner wrote:

I'm also kind of frustrated waiting for someone to fix it.... Well it's an open source project thus the only thing we can do is to be patient and wait......

If you are impatient, you can always do a

wget http://apt.tvheadend.org/unstable/pool/main/t/tvheadend/tvheadend_4.1-1429~ge29df17~jessie_armhf.deb
sudo dpkg -i tvheadend_4.1-1429~ge29df17~jessie_armhf.deb

(for rpi!)

Not tested but it should work (but you will not receive updates).

RE: Repository problem? - Added by Thorsten Steinbrenner about 2 years ago

I kind of prefere the stable release and automatic updates via apt. Is there another repository for the stable release for armhf? What do I have to put in my sources.lst?

RE: Repository problem? - Added by Cédric M. about 2 years ago

Thorsten Steinbrenner wrote:

I kind of prefere the stable release and automatic updates via apt. Is there another repository for the stable release for armhf? What do I have to put in my sources.lst?

I've tried with

deb http://apt.tvheadend.org/unstable/ jessie main

or

deb http://apt.tvheadend.org/stable/ jessie main

(note: if you want to try, you have to add the key with "apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys B42317285E12C7CF")

But apt complains about mal-formed Realease file

Unable to find expected entry 'main/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

Maybe I do something wrong ...

Well, I guess the better is to wait for the Bintray repo :(

RE: Repository problem? - Added by Chris Nicholaidis about 2 years ago

Am I missing something here guys? So their repo share is simply over quota? So why is it 1 week on and it's still over quota with zero change? Is TVHeadened no longer under active development or is no-one willing to make a management decision as to what can be deleted freeing up storage? I'm left scratching my head on how such an epically simple problem is taking so long to sort out?

RE: Repository problem? - Added by Thorsten Steinbrenner about 2 years ago

I think you are right! Maybe the one and only developer is on vacation?!?! :(
Maybe we really just have to be patient......

RE: Repository problem? - Added by Jonathan Thomson about 2 years ago

Patience is indeed a virtue.

Remember that as annoying as it may seem, this is a free product and people give their time for free to make it a possibility. We have no idea what's going on behind the scenes and why it's taking so long to fix the problem.

If you are on an x86 build then you can switch to the legacy repository and carry on. If you need a armhf/Raspberry Pi build, I've created a test build which you can download from http://tvheadend.org/boards/5/topics/21236?page=2 which is based on a the latest git release.

RE: Repository problem? - Added by Cédric M. about 2 years ago

Jonathan Thomson wrote:

See this thread for armhf builds: http://tvheadend.org/boards/5/topics/21528

Awesome!
I will give it a try soon.
Thank you very much.

RE: Repository problem? - Added by Thorsten Steinbrenner about 2 years ago

Thanks a lot! Works great!
Can I just switch to the official repo if it's back online again by just change the entry in sources.list?

RE: Repository problem? - Added by Jonathan Thomson about 2 years ago

You could (if the 403 errors don't bother you too much) just leave both repo's in the sources.list file - the official repo will (once the problem is resolved) be more up to date than mine and apt/aptitude always pulls the latest version available across repositories so if there's a newer 'official' build then it'll pull it from the official repo, likewise if the official repo is still offline it'll pull new versions from my repo.

RE: Repository problem? - Added by Josu Lazkano about 2 years ago

Hello,

What happens with bintray.com? Could we contact with them?

Regards.

RE: Repository problem? - Added by Jonathan Thomson about 2 years ago

We need the TVHeadend staff to sort out the problem with Bintray - Bintray themselves can't/won't do anything.

RE: Repository problem? - Added by Josu Lazkano about 2 years ago

Hello,

I need to install a new server, which apt repository could I use for Debian?

Kind regards.

RE: Repository problem? - Added by Jonathan Thomson about 2 years ago

Which architecture?

1 2 (1-25/45)